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1.3 Struktura dat - koncept lokací a mapsetů . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
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Školení GRASS GIS pro začátečníky, verze 1.1.0

GRASS (Geographic Resources Analysis Support System) je multiplatformní desktopový geografický in-
formační systém (GIS) určený pro správu geografických 2D/3D rastrových a vektorových dat, obrazových
záznamů, produkci vysoce kvalitních grafických výstupů, časoprostorové modelování a vizualizaci dat.

Obrázek 1: Logo projektu GRASS GIS

GRASS GIS (http://grass.osgeo.org) je free software a open source publikovaný pod všeobecnou licencí
GNU GPL (General Public License). Tato licence nejenže umožňuje software použít k libovolným účelům
včetně komerčních, dovoluje také studovat jeho zdrojový kód, upravovat ho a tyto změny či opravy šířit dál.

Důležité: Školení je zaměřeno na aktuální verzi GRASS 7.0. Ve starší verzi GRASS 6.4 není zaručena
funkčnost uvedených příkladů, případné rozdíly mezi těmito verzemi jsou vždy explicitně zdůrazněny. Dále
předpokládáme zapnutou anglickou lokalizaci, viz kapitola Volba lokalizace. Na toto školení do jisté míry
navazuje školení GRASS GIS pro pokročilé.

Poznámka k datové sadě GISMentors

GRASS lokace GISMentors je stažitelná jako zip archiv (830 MB), družicové snímky Landsat (985 MB).
Tato datová sada je složena z dat pocházejících z otevřených či veřejných zdrojů jako je EU-DEM, RÚIAN,
OpenStreetMap, Dibavod a IPR.
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KAPITOLA 1

První kroky

1.1 Instalace

GRASS GIS byl od svého počátku (tj. první poloviny 80.let!) vyvíjen na platformách, které mají blízko k
Unixovým operačním systémům.

Obrázek 1.1: Programátor systému GRASS Dave Gerdes USA-CERL (US Army Construction Engineering
Research Laboratory) před počítačem Compaq 386 na který portoval GRASS.

YouTube – GRASS GIS (CERL, 1987)
http://www.youtube.com/embed/U3Hf0qI4JLc

Postupem času byl systém GRASS portován na další platformy a nadále vyvíjen jako striktně multiplat-
formní informační systém. V současnosti mezi oficiálně podporované platformy patří GNU/Linux, Mac
OSX a MS Windows. GRASS je ale možné po menších úpravách zprovoznit na dalších méně obvyklých
platformách jako je např. AIX.

V následujícím textu se zaměříme na dvě nejrozšířenější platformy - GNU/Linux a MS Windows.
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1.1.1 GNU/Linux

Systém GRASS je dostupný ve většině rozšířených linuxových distribucí jako tzv. balíček (package).

Poznámka pro pokročilé

Pokud balíčkovací systém dané linuxové distribuce neobsahuje GRASS nebo nabízí jeho zastaralou verzi
lze systém GRASS poměrně jednoduše zkompilovat 1 vlastními silami.

Postup instalace pro Debian GNU/Linux

Přehled balíčků GRASS dostupných pro Debian GNU/Linux (viz projekt DebianGIS):

• http://packages.debian.org/search?keywords=grass&searchon=names&suite=all&section=all

Instalace z příkazové řádky

sudo apt-get install grass grass-gui grass-doc

Postup instalace pro Ubuntu

Přehled balíčků GRASS dostupných pro Ubuntu (viz Launchpad):

Instalace z příkazové řádky

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install grass

Obrázek 1.2: Spuštění systému GRASS v Ubuntu

1 http://freegis.fsv.cvut.cz/gwiki/GRASS_GIS_/_Instalace_GNU/Linux#Kompilace
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1.1.2 MS Windows

Systém GRASS je možné pod MS Windows nainstalovat dvěma způsoby:

1. pomocí nativního instalátoru

• pro začátečníky

• nepředpokládáme častou aktualizaci softwaru

2. v rámci OSGeo4W frameworku

• pro pokročilejší uživatele

• komplexnější řešení umožňující instalaci dalšího softwaru distribuovaného pod hlavičkou OS-
Geo (jako je např. QGIS, MapServer a další)

• vhodné při předpokladu časté aktualizace softwaru

Nativní instalátor

Nativní (standalone) instalátor pro GRASS 7.0 je dostupný na adrese:

• http://grass.osgeo.org/grass70/binary/mswindows/native/

Obrázek 1.3: Spustíme instalátor.

1.1. Instalace 5
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Obrázek 1.4: Potvrdíme licenci.

Obrázek 1.5: Zvolíme adresář, kam se má GRASS nainstalovat.

Obrázek 1.6: Důrazně doporučujeme (vyhnete se problémům při spuštení systému GRASS v případě chy-
bějících knihoven MS Windows) nainstalovat také "Important Microsoft Runtime Libraries"a pokud nemáte
vlastní data tak i ukázkovou geografickou datovou sadu pro GRASS "North Carolina".

6 Kapitola 1. První kroky
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Obrázek 1.7: GRASS můžeme spustit z nabídky Start.

Obrázek 1.8: Po startu se objeví úvodní obrazovka systému GRASS pro výběr, viz kapitola Struktura dat -
koncept lokací a mapsetů.

1.1. Instalace 7
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OSGeo4W

Instalátor frameworku OSGeo4W je ke stažení na adrese:

• http://download.osgeo.org/osgeo4w/

Obrázek 1.9: GRASS 7 nainstalujeme ze sekce Advanced Install.

Obrázek 1.10: Vybereme instalaci z Internetu.

Obrázek 1.11: Zvolíme adresář, kam se má GRASS nainstalovat.

8 Kapitola 1. První kroky
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Obrázek 1.12: Nastavíme cestu k adresáři, kam se budou stahovat data instalátoru.

Obrázek 1.13: Ze sekce Desktop vybereme balíček grass.

Obrázek 1.14: Nutné závislosti (jako např. knihovna GDAL, Python či wxPython) se nainstalují automa-
ticky.

1.1. Instalace 9
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Obrázek 1.15: GRASS spustíme z nabídky Start OSGeo4W.

Poznámka pro pokročilé

V rámci frameworku OSGeo4W je možné nainstalovat i denní snapshoty vývojové verze systému GRASS.
To se hodí v případě, že potřebujete otestovat např. novou funkcionalitu, která není součástí stabilní verze.

Obrázek 1.16: Ze sekce Desktop vybereme balíček grass-daily (denní snapshoty aktuální vývojové
verze systému GRASS).

10 Kapitola 1. První kroky
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Poznámky

Nastavení velikosti fontu terminálu V novějších verzích Windows bývá výchozí velikost fontu terminálu
příliš malá.

Velikost fontu můžete změnit ve vlastnostech okna (pravé tlačítko myši nad titulkem okna, Vlastnosti).

Automatická aktualizace (pro velmi pokročilé uživatele) Aktualizovat instalaci OSGeo4W (včetně in-
stalace systému GRASS) lze provádět automaticky v rámci plánovače úloh MS Windows.

Stačí umístit do zvoleného adresáře níže uvedený skript s příponou bat (předpokládejme, že je framework
OSGeo4W nainstalován v adresáři C:\OSGeo4W):

@echo off

set PATH=C:\OSGeo4W\bin;%PATH%
call o4w_env.bat

apt update
apt upgrade

a nastavit spuštění skriptu jako úlohu.

1.1. Instalace 11
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1.2 Úvod do systému GRASS

Systém GRASS vyžaduje spravovat geodata v pevně definované struktuře, v konceptu tzv. lokací a mapsetů.
To bývá pro začínajícího uživatele kritickým bodem, proto doporučujeme začít pracovat s předpřiprave-
nými datovými sadami (viz poznámka níže) a teprve po pochopení tohoto konceptu importovat do systému
GRASS svoje vlastní data.

Tip: Na webových stránkách projektu GRASS jsou volně ke stažení testovací a edukační datasety. Jde
především o edukační datovou sadu OSGeo North Carolina dataset, která je ke stažení jako zip archiv. Tato
data lze pod MS Windows stáhnout i pomocí nativního instalátoru. V tomto případě najdete data v adresáři
%USERPROFILE%\Documents\grassdata.

1.2.1 Spuštění systému GRASS

V případě, že je GRASS nainstalován standardní cestou, měl by být dostupný z hlavní nabídky vašeho
operačního systému.

Obrázek 1.17: Spuštění systému GRASS v Ubuntu

Obrázek 1.18: Spuštění systému GRASS z nabídky Start v MS Windows.

12 Kapitola 1. První kroky

http://grass.osgeo.org/download/sample-data/
http://www.grassbook.org/data_menu3rd.php
http://grass.osgeo.org/sampledata/north_carolina/nc_spm_08_grass7.zip


Školení GRASS GIS pro začátečníky, verze 1.1.0

Spuštění systému GRASS v OS Linux z příkazové řádky

V operačním systému GNU/Linux je dostupný systém GRASS po instalaci z příkazové řádky jako program
grassXY, kde XY označuje jeho verzi. To umožňuje vedle sebe nainstalovat současně různé verze systému
GRASS. Příklad spuštění verze GRASS 7.0:

grass70

Ve výchozím nastavení program nastartuje v grafickém módu. Úvodní dialog umožňuje nastavit adresář s
geodaty, lokaci a mapset, které jsou nutné pro samotné spuštění systému. Po jejich zadaní lze pokračovat
dále (tlačítko Start GRASS ).

Obrázek 1.19: Úvodní dialog systému GRASS pro výběr adresáře s geodaty (1), lokace (2), mapsetu (3) a
spuštění systému GRASS (4).

Poznámka pro pokročilé

Příklady spuštění systému GRASS z příkazové řádky

• GRASS v textovém rozhraní, adresář s geodaty nastaven na /opt/grassdata, lokace
gismentors a mapset user1:

grass70 -text /opt/grassdata/gismentors/user1

• GRASS v grafickém rozhraní, adresář s geodaty, lokace a mapset nastavena z předchozího spuštění:

grass70 -gui

• GRASS v grafickém rozhraní, vytvořit novou lokace skoleni (souřadnicový systém S-JTSK
EPSG:5514 s transformačními parametry pro území ČR - kód 3):

grass70 -gui -c EPSG:5514:3 /opt/grassdata/skoleni

1.2. Úvod do systému GRASS 13
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1.3 Struktura dat - koncept lokací a mapsetů

Data, ke kterým GRASS přistupuje, mají pevně danou strukturu. Při spuštění systému GRASS musí uživatel
zvolit tři níže uvedené elementy v daném pořadí:

Adresář s geodaty (DataBase)

Jde o adresář umístěný na lokálním či sít’ovém disku, např. /opt/grassdata nebo
C:\grassdata v případě MS Windows. V tomto adresáři jsou uložena veškerá data, ke kte-
rým GRASS přistupuje (tedy rastrové a vektorové mapy v nativním formátu GRASS, atributové
tabulky ve formátu SQLite či DBF, různá nastavení apod.). Výjimku představují atributová (po-
pisná) data skladovaná v databázových systémech jako je např. PostgreSQL či MySQL.

Lokace (Location)

Lokace je adresář umístěný v GRASS DataBase (adresáři s geodaty). Tento adresář obsahuje
data, která souvisejí s daným projektem. Lokace je definována souřadnicovým systémem (re-
ferenční elipsoid, kartografické zobrazení, mapové jednotky) a výchozí velikostí zájmového
území.

Mapset

Mapset je souborem map, které tvoří jakýsi logický celek v rámci lokace (projektu). Může
např. odpovídat jednotlivým uživatelům nebo uceleným analýzám (studium vegetace, zápla-
vová území, apod.). Každá lokace musí obsahovat alespoň jeden mapset s unikátním názvem
PERMANENT. Ten většinou obsahuje základní datové vrstvy a ostatní mapsety jsou brány jako
pracovní (zpracování vstupních dat, jejich analýza apod.).

Obrázek 1.20: Struktura adresáře s geodaty, vztah lokace a mapsetů, umístění souborů s daty pro různé typy
map (zdroj: manuál systému GRASS).

Poznámka pro pokročilé

GRASS DataBase je definovaná proměnnou prostředí GISDBASE, lokace LOCATION_NAME a mapset
proměnnou MAPSET, viz modul g.gisenv.

14 Kapitola 1. První kroky
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Poznámka: Obvyklé umístění adresáře s geodaty

Adresář s geodaty je většinou umístěn v domovském adresáři uživatele pod názvem grassdata. V případě
MS Windows to může být %USERPROFILE%\Documents\grassdata, u UNIXových operačních sys-
témů jako je GNU/Linux či Mac OS X potom $HOME/grassdata.

1.3.1 Vyhledávací cesta

Vyhledávací cesta definuje viditelné mapsety v rámci aktuální lokace. Ve výchozím nastavení je ve vyhle-
dávací cestě vždy umístěn aktuální mapset a mapset PERMANENT.

Obrázek 1.21: Přidání nové rastrové mapy do mapového okna, viditelné jsou pouze dva mapsety - aktuální
(user1) a mapset PERMANENT.

Vyhledávací cestu lze modifikovat z menu Settings → GRASS working environment → Mapset access.

Obrázek 1.22: Přidání mapsetu ruian do vyhledávací cesty.

Přidání mapsetu do vyhledávací cesty z příkazové řádky

g.mapsets mapset=ruian operation=add

1.3. Struktura dat - koncept lokací a mapsetů 15
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Obrázek 1.23: Přidání nové rastrové mapy do mapového okna, kromě aktuálního mapsetu a mapset PER-
MANENT je viditelný i mapset ruian.

1.4 Zobrazení geodat v mapovém okně

Po spuštění grafického uživatelského rozhraní (GUI) systému GRASS se objeví správce vrstev (Layer Ma-
nager) a mapové okno (Map Display).

Tip: Pokud GUI systému GRASS z nějaké důvodu zhavaruje, lze ho z příkazové řádky nastartovat znovu
pomocí příkazu g.gui.

g.gui

Obrázek 1.24: Základní komponenty GUI systému GRASS - správce vrstev (1) a mapové okno (2).

Rastrová či vektorová data lze do stromu vrstev (viz záložka Map layers ) přidávat z menu File → Map
display, nástrojové lišty či přímo z příkazové řádky správce vrstev, viz níže.
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Poznámka: Pokud se v mapovém okně nezobrazují žádná data, je nutné nastavit pohled na aktuálně vybra-
nou mapu.

Obrázek 1.25: Nastavení pohledu mapového okna na aktuálně vybranou mapovou vrstvu.

Automatické nastavení pohledu při přidání nové mapové vrstvy lze nastavit v Settings → Preferences.

Obrázek 1.26: Nastavení automatické změny pohledu při přidání nové mapové vrstvy.

Poznámka pro pokročilé

Geodata lze vykreslovat z příkazové řádky či skriptů do nejrůznějších formátů od PNG, GIF až po SVG či
PDF pomocí modulu d.mon v kombinaci s moduly d.rast a d.vect. Tyto techniky jsou součástí navazujícího
školení pro pokročilé uživatele.

1.4.1 Rastrová data

Rastrová data (v terminologii systému GRASS tzv. rastrovou mapu) lze přidat do správce vrstev, resp.
mapového okna čtyřmi různými způsoby:

1. z nástrojové lišty správce vrstev

Obrázek 1.27: Přidání rastrové mapy z nástrojové lišty správce vrstev.
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Obrázek 1.28: Volba rastrové mapy.

2. z menu File → Map display → Add raster

3. pomocí klávesové zkratky Ctrl+Shift+R

4. z příkazové řádky (Command console) správce vrstev příkazem d.rast

Obrázek 1.29: Příkazová řádka správce vrstev.

Obrázek 1.30: Přidání rastrové mapy z příkazové řádky správce vrstev.

Ostatní mapové vrstvy, které mají rastrový charakter jsou dostupné z nástrojové lišty nebo z příkazové řádky
správce vrstev.

Obrázek 1.31: Přidání ostatních rastrových dat z nástrojové lišty správce vrstev.

18 Kapitola 1. První kroky

http://grass.osgeo.org/grass70/manuals/d.rast.html


Školení GRASS GIS pro začátečníky, verze 1.1.0

Obrázek 1.32: Menu pro přidání rastrových dat.

Jde o následující typy rastrových dat:

• 3D rastrová data

• RGB barevná syntéza - příkaz d.rgb

• HIS barevná syntéza - příkaz d.his

• stínovaný reliéf - příkaz d.shadedmap

• rastrová mapa, zobrazení směru - příkaz d.rast.arrow

• rastrová mapa, zobrazení hodnot buněk - příkaz d.rast.num

Obrázek 1.33: Příklad zobrazení barevné syntézy kanálů Landsat 8 ETM z mapsetu landsat ve skutečných
barvách.

1.4.2 Vektorová data

Podobně lze přidat vektorová data (tzv. vektorovou mapu):

1. z nástrojové lišty správce vrstev:

Obrázek 1.34: Přidání vektorové mapy z nástrojové lišty správce vrstev.
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http://cs.wikipedia.org/wiki/RGB
http://grass.osgeo.org/grass70/manuals/d.rgb.html
http://cs.wikipedia.org/wiki/HSL
http://grass.osgeo.org/grass70/manuals/d.his.html
http://en.wikipedia.org/wiki/Shapeded relief
http://grass.osgeo.org/grass70/manuals/d.shadedmap.html
http://grass.osgeo.org/grass70/manuals/d.rast.arrow.html
http://grass.osgeo.org/grass70/manuals/d.rast.num.html
http://cs.wikipedia.org/wiki/Landsat


Školení GRASS GIS pro začátečníky, verze 1.1.0

Obrázek 1.35: Volba vektorové mapy.

2. z menu File → Map display → Add vector

3. pomocí klávesové zkratky Ctrl+Shift+V

4. z příkazové řádky (Command console) správce vrstev příkazem d.vect

Obrázek 1.36: Přidání vektorové mapy z příkazové řádky správce vrstev.

Ostatní mapové vrstvy, které mají vektorový charakter jsou dostupné z nástrojové lišty nebo z příkazové
řádky správce vrstev.

Obrázek 1.37: Přidání ostatních vektorových dat z nástrojové lišty správce vrstev.

Jde o následující typy vektorových dat:

• tématické zobrazení plošných vektorových dat - příkaz d.thematic.area
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Obrázek 1.38: Menu pro přidání vektorových dat.

• zobrazení grafů - d.vect.chart

1.5 Příkazy systému GRASS

GRASS GIS je modulární systém, který disponuje poměrně rozsáhlou množinou malých, ale výkonných
programů (v terminologii systému GRASS modulů).

Poznámka: To odpovídá koncepci Unixu jako takového. Daný program má za úkol vyřešit dílčí problém,
měl by být co nejmenší a poměrně jednoduchý.

Jednotlivé příkazy systému GRASS - moduly - mají konzistentní syntaxi, jejich názvy se skládají z předpony
označující skupinu příkazů a krátkého názvu napovídající účel modulu (viz tabulka níže). Například modul
v.buffer patří do skupiny vector a je určen pro vytvoření obalové zóny (tzv. bufferu) nad vektorovými daty.

prefix skupina popis
db. database práce s atributovými daty a tabulkami
d. display grafické výstupy a vizuální dotazy
g. general obecné příkazy pro manipulaci s daty
i. imagery zpracování obrazových dat
ps. postscript tvorba mapových výstupů ve formátu PostScript
r. raster zpracování (2D) rastrových dat
r3. raster3D zpracování 3D rastrových dat (voxels)
v. vector zpracování 2D/3D vektorových dat

Příkazy systému GRASS lze spouštět několika způsoby (příklad pro r.buffer):

1. z menu správce vrstev

2. z nástroje Search module správce vrstev

3. z příkazové řádky správce vrstev

Pokud jsou zadány všechny povinné parametry (v případě modulu r.buffer jde o parametry input,
output a distances), tak se modul spustí přímo. Pokud tato podmínka není splněna, zobrazí se
dialog nástroje.

4. z grafického modeleru
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Obrázek 1.39: Spuštění modulu r.buffer z menu správce vrstev.

Obrázek 1.40: Spuštění modulu r.buffer pomocí nástroje Search module .
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Obrázek 1.41: Spuštění modulu r.buffer z příkazové řádky správce vrstev.

Obrázek 1.42: Spuštění modulu r.buffer včetně zadání parametrů.
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1.5.1 Nápověda k modulům

Nápověda systému GRASS je dostupná z menu Help → GRASS help.

Obrázek 1.43: Nápověda systému GRASS v okně webového prohlížeče.

Zobrazení nápovědy z příkazové řádky

Nápovědu lze spustit pomocí modulu g.manual:

g.manual -i

g.manual r.buffer

Obrázek 1.44: Nápověda k jednotlivým modulům je dostupná i z dialogového okna.
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KAPITOLA 2

Základní pojmy

2.1 Rastrová data

Rastrová data jsou v systému GRASS uložena v podobě tzv. rastrových map. Jde o:

• reprezentaci v podobě pravidelné mřížky hodnot (GRASS nepodporuje nepravidelné mřížky)

• je ideální pro reprezentaci spojitých jevů jako nadmořská výška, teplota povrchu a pod.

• elementem mřížky je buňka či tzv. pixel, jehož tvar může být bud’ čtvercový nebo obdélníkový

• velikost pixelu je dána prostorovým rozlišením

• k hodnotě buňky lze přiřadit textový popisek (tzv. label) - příklad

2.1.1 Metadata

Základní metadata o rastrových datech vypisuje modul r.info dostupný z menu Raster → Reports and sta-
tistics → Basic raster metadata anebo z kontextového menu rastrové mapy ve správci vrstev.

Obrázek 2.1: Spuštění nástroje pro výpis metadat rastrových map z kontextového menu správce vrsvev.
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Obrázek 2.2: Příklad výpisu metadat rastrové mapy dmt.

2.1.2 Typy rastrových map

GRASS rozlišuje tři typy rastrových map podle datového typu buňky:

• CELL (celé číslo, integer)

Obrázek 2.3: Celočíselné hodnoty rastrové mřížky.

• FCELL (hodnoty s plovoucí desetinnou čárkou, float)

• DCELL (hodnoty s plovoucí desetinnou čárkou s dvojnásobnou přesností, double precision)
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Obrázek 2.4: Hodnoty s plovoucí desetinnou čárkou rastrové mřížky.

Poznámka: Kromě 2D rastrových dat GRASS podporuje i 3D rastrová data (tzv. volumes) a nad nimi
postavené analýzy. Tato problematika je ale nad rámec tohoto školení a je probírána v navazující školení pro
pokročilé uživatele.

2.2 Vektorová data

Vektorová data jsou v systému GRASS uložena v podobě tzv. vektorových map.

• Vektorová data reprezentují nejčastěji diskrétní fenomény

Ve 2D GIS rozlišujeme tři základní typy geoprvků, které označujeme jako jednoduché (simple features):

• bodové (point)

• liniové (linestring)

• plošné (polygon)

GRASS je nicméně striktně topologický GIS, který s jednoduchými geoprvky nepracuje. Vektorová data
ukládá v topologickém formátu, v případě importu vektorových dat z netopologických formátů jako je např.
Esri Shapefile data převádí do topologické formy automaticky.

Poznámka: Topologie sleduje prostorové vztahy mezi objekty (návaznost linií, sousednost ploch atd.), viz
prostorová topologie.

Vstupní vektorová data často obsahují nejrůznější topologické chyby, jako např. překrývající se polygony.
Importní nástroj systému GRASS v.in.ogr se snaží tyto chyby automaticky opravit. V některých případech
to však není možné a je dále na uživateli, aby data opravil sám. Opravám případných topologických chyb se
věnuje podrobněji navazující kapitola.

Poznámka: Nativní vektorový formát systému GRASS umožňuje na rozdíl od jiných formátů jako je
např. Esri Shapefile uložit v jednou souboru (vektorové mapě) rozdílné typy geoprvků najednou. V jedné
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vektorové mapě tedy mohou být uloženy bodové, liniové i plošné geoprvky zároveň, viz kapitola o editaci
vektorových dat.

2.2.1 Metadata

Základní metadata o vektorové mapě vypisuje modul v.info dostupný z menu Vector → Reports and statistics
→ Basic vector metadata anebo z kontextového menu vektorové mapy ve správci vrstev.

Obrázek 2.5: Spuštění nástroje pro výpis metadat vektorových map z kontextového menu správce vrsvev.

Obrázek 2.6: Příklad výpisu metadat vektorové mapy obce_polygony.
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2.2.2 Topologický model

Topologický model systému GRASS liniové a plošné elementy (bodové geoprvky nejsou součástí topologie)
rozkládá dále na tzv. topologické elementy:

• uzel (node),

– každá linie či hraniční linie musí začínat a končit v uzlu

– linie se musí křížit vždy v uzlu

– izolované uzly nejsou podporovány

• linie (line),

• hraniční linie (boundary) a

• reprezentační bod plochy (centroid).

Hraniční linie je liniový element, který na rozdíl od elementu označovaného jako linie, může tvořit hranici
plochy. Plošný topologický element area je tvořen jednou či více hraničními liniemi a případně i jedním
centroidem. Izolovaná plocha nebo souvislá množina ploch formuje plošný element označovaný jako ostrov
(isle).

Příklad

Na obrázku níže je zobrazen:

• jeden bodový geoprvek

• jeden liniový geoprvek

• dva plošné geoprvky, z toho jeden z nich obsahuje otvor
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Tato kompozice bude v topologické modelu systému GRASS vyjádřena následující topologickými ele-
menty:

• pěti uzly n1-5

• jednou linií 2

• čtyřmi hraničními liniemi 3,4,6,8

• dvěma centroidy 5,7

2.2.3 Atributová data

Atributová data jsou uložena v libovolném formátu podporovaném jedním z databázových ovladačů systému
GRASS.

Pro verzi GRASS 7 je výchozí formát SQLite.

Poznámka pro GRASS GIS verze 6

Ve verzi GRASS 6 je výchozím formátem pro atributová data DBF.

Volitelně lze atributová data ukládat do databáze PostgreSQL, MySQL či do jiné databáze pomocí rozhraní
ODBC.

Výchozí nastavení formátu pro uložení atributových dat můžete změnit pomocí modulu db.connect (Data-
base → Manage databases → Connect). Aktuální nastavení vypisuje přepínač -p.

Obrázek 2.7: Výchozí nastavení připojení atributových dat v GRASS - databáze SQLite.

Nastavení databáze PostgreSQL pro uložení atributových dat z příkazové řádky

db.connect driver=pg database=grass

Poznámka: Změna nastavení formátu uložení atributových dat se projeví až u nově vytvořených vektoro-
vých map.
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Poznámka pro pokročilé

K jedné vektorové mapě lze přiřadit více atributových tabulek. Tato problematika je ale nad rámec tohoto
školení a je probírána v navazující školení pro pokročilé uživatele.
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2.3 Výpočetní region

Výpočetní region je dán hraničními souřadnicemi (sever, jih, východ, západ) a prostorovým rozlišením ve
směru sever-jih, východ-západ. Pro 3D data jsou definovány hraniční souřadnice a prostorové rozlišení navíc
ve vertikálním směru (top-bottom). Vzniká tak pravidelná mřížka jejíž buňky mají čtvercový (prostorové
rozlišení ve směru sever-jih a východ-západ totožnou hodnotu) nebo obdélníkový tvar, viz 2.8.

Obrázek 2.8: Mřížka výpočetního regionu pro 2D data.

Důležité: Veškeré rastrové operace jsou prováděny vždy a pouze v rámci aktuálně nastaveného výpočetního
regionu! Pouze několik málo nástrojů pro zpracování rastrových dat (tj. moduly s prefixem r.*) výpočetní
region ignorují. Například modul r.in.gdal pro import rastrových dat. Drtivá většina nástrojů pro zpracování
vektorových dat (v.*) ignoruje nastavení výpočetního regionu zcela.

Varování: V případě, že se hraniční souřadnice a rozlišení vstupních rastrových dat liší od nastavení
výpočetního regionu, jsou vstupní rastrová data před výpočtem převzorkována metodou nejbližšího sou-
seda. Mřížka výstupních rastrových dat vždy odpovídají aktuálně nastavenému regionu.

Důležité: Změna pohledu v mapovém okně nemá na nastavení regionu žádný vliv. Aktuální rozsah území
zobrazené v mapovém okně je dostupný ze stavové lišty jako volba Extent , viz kapitola Kontrola výpočet-
ního regionu.

Obrázek 2.9: Rozsah zobrazeného území (extent).

2.3.1 Nastavení výpočetního regionu

Ve většině případů stačí nastavit výpočetní region na základě rastrové či vektorové mapy. Toto nastavení je
dostupné z kontextového menu správce vrstev.
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Obrázek 2.10: Nastavení výpočetního regionu na základě rastrové mapy.

Nastavení regionu na základě rastrové mapy z příkazové řádky

g.region raster=dmt

Zároveň je možné vybrat pro nastavení výpočetního regionu i více rastrových či vektorových map najednou.

Obrázek 2.11: Nastavení výpočetního regionu na základě více vybraných mapových vrstev.

Nastavení regionu na základě vektorových map z příkazové řádky

g.region vector=ulice,adresnimista_bod

Tip: Prostorové rozlišení může být nastaveno pomocí modulu g.region explicitně (volba res) nebo na
základě rastrových map (raster). Pro vektorové mapy nehraje prostorové rozlišení žádnou roli a tudíž pro
ně není ani definováno.

Obrázek 2.12: Z nástrojové lišty mapového okna lze navíc výpočetní region nastavit podle aktuálního po-
hledu či zcela interaktivně.
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Obrázek 2.13: Příklad definice hranic výpočetního regionu interaktivně.

2.3.2 Pokročilé nastavení výpočetního regionu

Pro manipulaci s výpočetním regionem je určen modul g.region.

Obrázek 2.14: Nastavení výpočetního regionu z menu správce vrstev.

Modul g.region umožňuje nastavit region na základě existujících rastrových, vektorových map či již dříve
uloženého nastavení (parametr save). V níže uvedeném případě nastavíme výpočetní region tak, aby po-
krýval rastrovou mapu dmt a vektorové mapy ulice a adresnimista_bod. Prostorové rozlišení je
určeno z rastrové mapy dmt.

Obrázek 2.15: Nastavení regionu na základě existujících dat.
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Obrázek 2.16: Kontrola nastavení výpočetního regionu v mapovém okně.

Dále je možno nastavit hraniční souřadnice explicitně, např. severní souřadnici na ’1000’ (v mapových
jednotkách) anebo jako offset ’s+1000’ (aktuálně nastavená jižní souřadnice + 1000 mapových jednotek).

Obrázek 2.17: Explicitní nastavení hraničních souřadnic.

Podobně je možné explicitně definovat hodnoty prostorového rozlišení ve směru sever-jih (počet řádků) a
východ-západ (počet sloupců). Pro 3D region ještě prostorové rozlišení ve směru Z-ové osy.

Nastavení prostorového rozlišení na základě rastrové mapy, hraniční souřadnice s offsetem 1000 ma-
pových jednotek od minimálního ohraničujícího obdélníku polygonu města z příkazové řádky

g.region raster=dem vector=mesto n=n+1000 s=s-1000 w=w-1000 e=e+1000
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Obrázek 2.18: Explicitní nastavení prostorového rozlišení.

2.3.3 Kontrola výpočetního regionu

Aktuální nastavení výpočetního regionu lze vytisknout pomocí modulu g.region s přepínačem -p.

Obrázek 2.19: Zobrazení aktuálního výpočetního regionu z menu správce vrstev.

Obrázek 2.20: Aktuálně nastavený výpočetní region.

Zobrazení aktuálně nastaveného regionu z příkazové řádky

g.region -p

Aktuální nastavení výpočetního regionu lze zobrazit i ve stavové liště mapového okna (volba
Comp. region ).
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Obrázek 2.21: Volby stavové lišty mapového okna.

Formát:

souřadnice západ - východ, jih - sever (rozlišení západ-východ, jih-sever)

Obrázek 2.22: Zobrazení výpočetního regionu ve stavové liště mapového okna.

Tip: Rozsah výpočetního regionu lze v mapovém okně i zobrazit. Hraniční souřadnice budou zobrazeny
jako linie červené barvy, pokud je výpočetní region celou plochou uvnitř aktuálního pohledu. V opačném
případě budou hranice výpočetního regionu zobrazeny modrou barvou.

Obrázek 2.23: Zobrazení rozsahu výpočetního regionu v mapovém okně (krok 1).

Obrázek 2.24: Zobrazení rozsahu výpočetního regionu v mapovém okně (krok 2).
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Obrázek 2.25: Zobrazení rozsahu výpočetního regionu v mapovém okně.
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KAPITOLA 3

Dotazování

3.1 Interaktivní dotazování

Funkcionalita interaktivního dotazování je dostupná z nástrojové lišty mapového okna.

Obrázek 3.1: Interaktivní dotazování.

Obrázek 3.2: Podle typu aktuálně zvolené mapové vrstvy ve správci vrstev (1) se zobrazí informace rastro-
vého (2) či vektorového charakteru.

3.1.1 Rastrová data

Výstup pro rastrová data obsahuje:

• souřadnice dotazu,

• barevnou hodnotu přiřazenou na základě tabulky barev,
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• hodnotu rastrové buňky a

• připadně popisek dané hodnoty.

Obrázek 3.3: Příklad dotazu na rastrová data.

3.1.2 Vektorová data

Výstup pro rastrová data obsahuje:

• souřadnice dotazu,

• kategorii geoprvku, geometrické vlastnosti a informace o připojení vektorových dat (1) a

• výpis připojených atributů (2).

Obrázek 3.4: Příklad dotazu na vektorová data.
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3.2 Atributové dotazy

Atributové dotazy, tj. výběr geoprvků na základě jejich popisných vlastností, lze provádět pomocí správce
atributových dat.

Poznámka pro pokročilé

Pokročilejší uživatelé mohou ve svých skriptech využít specializované moduly ze skupiny db.*, viz kapi-
tola Pokročilé dotazování .

Správce atributových dat (Attribute Table Manager) je základním nástrojem pro práci s atributovými daty v
GUI (Grafické uživatelské rozhraní) systému GRASS. Lze jej spustit několika způsoby:

1. z nástrojové lišty správce vrstev

Obrázek 3.5: Spuštění správce atributových dat z nástrojové lišty.

2. z kontextového menu správce vrstev

Obrázek 3.6: Spuštění správce atributových dat z kontextového menu.

3. z příkazové řádky jako modul g.gui.dbmgr

g.gui.dbmgr map=ulice

Dialog správce atributových dat má tři záložky:

Browse data Prohlížení, dotazování a editace atributových dat (záznamů v tabulce)
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Manage tables Přidání, přejmenování, odebraní sloupce v atributové tabulce

Manage layers Správa atributových tabulek připojených k vektorové mapě. Tato problematika je ale
nad rámec tohoto školení a je probírána v navazující školení pro pokročilé uživatele.

3.2.1 Dotazování

Dotazovat se na atributová data je možné v záložce Browse data a to bud’ v základním (Simple) anebo
interaktivním (Builder) módu, viz kapitola SQL Builder.

Základní mód umožňuje definovat jednoduchou where podmínku typu sloupec <op> hodnota.

Obrázek 3.7: Jednoduchý atributový doraz (krok 1 - výběr sloupce pro where podmínku).
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Obrázek 3.8: Jednoduchý atributový doraz (krok 2 - výběr operátoru pro where podmínku).

Obrázek 3.9: Jednoduchý atributový doraz (krok 3 - určení hodnoty pro where podmínku).

3.2. Atributové dotazy 43



Školení GRASS GIS pro začátečníky, verze 1.1.0

Obrázek 3.10: Jednoduchý atributový doraz - zobrazení výsledku.

Poznámka: Vybírat vektorové geoprvky na základě jejich atributů lze i pomocí modulu v.extract, více
informací v kapitole Výběr z vektorové mapy.

3.2.2 Zvýraznění výběru v mapovém okně

Výsledek atributové dotazu lze vizualizovat přímo v mapovém okně a to pomocí volby Highlight selected
features.

Obrázek 3.11: Zvýraznění korespondujících geoprvků v mapovém okně.

YouTube – Zvýraznění vektorových prvků jako výsledek atributového dotazu
http://www.youtube.com/embed/ITHLtQRsbEY
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3.2.3 SQL Builder

Interaktivní (Builder) mód umožňuje zadat SQL (Structured Query Language) SELECT dotazy přímo do
dialogu správce atributových dat.

Obrázek 3.12: Pokročilé dotazování, SQL SELECT dotaz (výběr se provede pro stisknutí klávesy Enter).

SQL dotaz lze sestavit pohodlně pomocí SQL Builderu, tlačítko SQL Builder.

Obrázek 3.13: Spuštění SQL Builderu ze správce atributových dat.
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Obrázek 3.14: Správce atributových dat a sestavení SQL SELECT dotazu v okně SQL Builderu.

YouTube – SQL Builder - jednoduchá podmínka ’where’
http://www.youtube.com/embed/PByk8pipCz4

YouTube – SQL Builder - výčet sloupců a jednoduchá podmínka ’where’
http://www.youtube.com/embed/qD7ourfheJo

3.3 Prostorové dotazy

Prostorové dotazy, tj. výběr geoprvků na základě jejich prostorových vztahů, zajišt’uje modul v.select (Vector
→ Feature selection → Select by another map).

Systém GRASS podporuje následující prostorové operátory:

• equals - geoprvky jsou totožné

• disjoint - geoprvky jsou prostorově různé

• intersects - geoprvky se prostorově protínají

• touches - geoprvky se prostorově dotýkají

• crosses - geoprvky se kříží
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• within - geoprvek je prostorově lokalizován uvnitř jiného geoprvku

• contains - geoprvek je prostorově obsažen v jiném geoprvku

• overlaps - geoprvky se prostorově překrývají

• relate - obecný prostorový vztah definovaný jako vztahová matice

Podrobný popis prostorových operátorů je k nalezení v OGC specifikaci Simple Features Access více infor-
mací specifikaci zde.

Poznámka: Nativně v.select podporuje pouze jeden prostorový operátor: overlap - geoprvky se částečně či
úplně překrývají. Ostatní výše zmíněné operátory jsou implementovány v knihovně GEOS, kterou systém
GRASS používá.

Příklad

Výběr obcí (vektorová mapa obce_polygon@ruian), ve kterých je umístěna alespoň jedna (v
tomto případě může použít např. prostorový operátor contains) požární stanice (vektorová mapa
pozarni_stanice@osm).

Obrázek 3.15: Spuštění modulu v.select.

Spuštění z příkazové řádky

v.select ainput=obce_polygon binput=pozarni_stanice output=obce_stanice \
operator=contains
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Obrázek 3.16: Výsledek prostorového dotazu.

YouTube – Příklad dalšího prostorového dotazu - výběr komunikací, které kříží železnice.
http://www.youtube.com/embed/teA-x-vmXYc
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KAPITOLA 4

Rastrové analýzy

4.1 Základní statistiky rastrových dat

Kromě výpisu základních metadat rastrových map systém GRASS disponuje dalšími moduly pro výpis
statistických informací rastrových dat:

• r.report pro přehledný výpis informací o rastrové mapě,

• r.univar pro základní statistiku a

• r.stats pro výpis vybraných statistik (určeno především pro pokročilé uživatele a jejich skripty).

4.1.1 Report

Základní informace o rastrových datech poskytuje modul r.report dostupný bud’ z menu Raster → Reports
and statistics → Sum area by raster map and category anebo z kontextového menu správce vrstev.

Obrázek 4.1: Pokud je modul vyvolán z kontextového menu, je automaticky spuštěn s parametrem
units=h,c,p (tj. výměra v hektarech, počet buněk a procentuální pokrytí).

49

http://grass.osgeo.org/grass70/manuals/r.report.html


Školení GRASS GIS pro začátečníky, verze 1.1.0

Příklad pro rastrovou mapu s hodnotami s plovoucí desetinnou čárkou

Příklad výpisu statistiky pro rastrovou vrstvu dmt:

• výměra v kilometrech čtverečních

• procentuální pokrytí

• rozděleno do 10 tříd

Obrázek 4.2: Nejprve vybereme rastrovou mapu (1), pro kterou si přejeme vypsat report.

Obrázek 4.3: Dále zvolíme informace, které si přejeme vypsat (2).

Obrázek 4.4: Zvolíme počet tříd, do kterých se mají data s plovoucí desetinnou čárkou rozdělit (3) a modul
spustíme (4).
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Obrázek 4.5: Výsledný report, např. území s nadmořskou výškou do 202.5 metrů pokrývá necelé tři procenta
území ČR.

Důležité: Jak již bylo uvedeno v kapitole výpočetní region drtivá většina modulů pro zpracování rastrových
dat pracuje vždy v aktuální výpočetním regionu! Pokud např. změníme prostorové rozlišení výpočetního
regionu na 100m, změní se i report rastrové mapy dmt. Modul nejprve data převzorkuje metodou nejbližšího
souseda do mřížky s velikostí buňky 100x100m a teprve nad těmito daty vypočítá údaje pro report.

g.region rast=dmt res=1000

Obrázek 4.6: Pro takto převzorkovaná data bude např. území s nadmořskou výškou do 202.5 metrů pokrývat
místo původních 2,85% nově 2,83%.
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4.1.2 Základní statistika

Základní statistiku o rastrových datech poskytuje modul r.univar dostupný bud’ z menu Raster → Repors
and statistics → Univariate raster statistics anebo z kontextového menu správce vrstev.

Obrázek 4.7: Základní statistika rastrových dat dostupná z kontextového menu správce vrstev.

Obrázek 4.8: Příklad statistiky pro rastrovou mapu dmt (s výpočetním regionem nastaveným na tuto mapu).
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4.1.3 Pokročilá statistika

Modul r.stats je základní modul poskytující statistiku rastrových dat, jde nicméně o modul určený především
pro pokročilé uživatele, kteří si píší vlastní skripty. Modul je dostupný z menu Raster → Repors and statistics
→ General statistics.

Výpis statistiky rastrové mapy z příkazové řádky

Výpis počtu buněk na základě 10 intervalů seřazených sestupně (znak * označuje no-data, tj. rastrové bunky
bez hodnoty)

r.stats -c input=dmt nsteps=10 sort=desc

* 94752766
355.686188-508.843563 43213697
202.528812-355.686188 34747630
508.843563-662.000938 28140420
662.000938-815.158314 8635189
49.371437-202.528812 6291794
815.158314-968.315689 3363937
968.315689-1121.473064 1231565
1121.473064-1274.63044 447183
1274.63044-1427.787815 104742
1427.787815-1580.94519 12743

Kromě skriptů můžete tento modul využít například pro export statistiky rastrové mapy do Vašeho ta-
bulkové procesoru (např. LibreOffice Calc či MS Excel) a to přes výměnný formát CSV (parametr
separator=comma).

r.stats -acp input=dmt separator=comma output=elev_stat.csv

Obrázek 4.9: Soubor elev_stat.csv poté můžete načíst do Vašeho oblíbeného tabulkového procesoru.
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4.2 Nastavení masky

Pomocí masky lze definovat nepravidelnou oblast výpočtu. To souvisí s výpočetním regionem, který má
obecně tvar obdélníka. Masku lze vytvořit a odstranit pomocí modulu r.mask (Raster → Mask).

Obrázek 4.10: To zda je maska aktivována, zjistíte ze stavové lišty mapového okna.

Tip: Pokud si přejete přepsat již existující masku musíte přidat přepínač --overwrite.

Obrázek 4.11: Přepsání stávající masky.

Poznámka pro pokročilé

Maska je v systému GRASS definovaná jako standardní rastrová mapa s názvem MASK. Buňky s hodnotou
no-data anebo 0 budou při výpočtu ignorovány, naopak nenulové hodnoty označují buňky, jejichž hodnota
nebude při výpočtu ignorována.

Pokud rastrovou mapu s tímto názvem odstraníte, bude tím deaktivována i maska.

4.2.1 Příklad nastavení masky na základě rastrové mapy

Obrázek 4.12: Nejprve vybereme rastrovou mapu (1) na základě, které chceme masku nastavit a posléze
definujeme hodnoty z této mapy (2), které poslouží pro vytvoření masky - v tomto případě hodnoty 500 až
800.
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Poznámka: Rastrová mapa na základě, které chcete definovat masku musí být celočíselná, viz typ CELL.
Pokud tomu tak není, např. v našem případě je rastrová mapa dmt typu FCELL, je potřeba na základě ni
vytvořit mapu celočíselnou a tu potom použít pro vytvoření masky.

Tuto operaci lze provést např. pomocí modulu r.mapcalc, více v kapitole rastrová algebra.

g.region raster=dmt
r.mapcalc expr="dmt_int = int(dmt)"

Obrázek 4.13: Po aktivaci masky se zobrazí pouze část území, které odpovídá nadmořské výšce mezi 500 a
800 metry.

Poznámka: Maska samozřejmě ovlivňuje veškeré výpočty nad rastrovými daty, např. modul r.univar v
tomto případě vypíše základní statistiku pouze pro území s nadmořskou výškou mezi 500 a 800 metry (viz
hodnoty minimum a maximum).

Obrázek 4.14: Výpis základní statistiky rastrových dat s aktivovanou maskou.
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4.2.2 Příklad nastavení masky na základě vektorové mapy

Na tomto místě si ukážeme postup vytvoření masky na základě území Ústeckého kraje. Vektorová mapa
kraje vznikla jednoduchým atributovým dotazem.

Obrázek 4.15: Digitální model terénu a hranice Ústeckého kraje.

Masku nastavíme standardně pomocí modulu r.mask s volbou vector.

Obrázek 4.16: Nastavení masky na základě vektorových dat.

Obrázek 4.17: Výsledek vytvoření masky podle hranice Ústeckého kraje.
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4.2.3 Odstranění masky

Odstranit masku lze přepínačem -r modulu r.mask.

Obrázek 4.18: Odstranění masky.

Poznámka pro pokročilé

Jelikož je maska standardní rastrovou mapou, lze ji deaktivovat jejím pouhým odstraněním.

g.remove -f type=rast name=MASK

4.3 Tabulka barev

Tabulka barev představuje zápis pravidel pro barevnou interpretaci rastrových hodnot. Podobu tabulky barev
pro zvolenou rastrovou mapu zobrazuje nástroj dostupný z menu Raster → Manage colors → Manage color
rules interactively.

Obrázek 4.19: Příklad tabulky barev pro rastrovou mapu dmt.
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Poznámka pro pokročilé

Podobu tabulky barev pro zvolenou rastrovou mapu vypisuje modul r.colors.out (Raster → Manage colors
→ Export color table).

Obrázek 4.20: Tabulka barev pro rastrovou mapu dmt, barvy jsou v notaci RGB, tabulka např. definuje, že
buňka s hodnotou 355.686 se vykreslí zeleně (0:255:0).

Tento nástroj umožňuje tabulku barev navíc interaktivně měnit včetně náhledu na data.

Obrázek 4.21: Příklad interaktivně změněné tabulky barev (1) pouze v náhledu (2).
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Nástroj umožňuje použít některou z předdefinovaných tabulek barev.

Obrázek 4.22: Příklad pro výběr tabulky barev odstínů šedi (1), tabulka barev se nastaví pro náhled po
stisknutí tlačítka Set (2).

Obrázek 4.23: Příklad pro výběr tabulky barev odstínů šedi. Tabulka barev je aplikována pouze pro náhled,
pokud ji chceme nastavit, stiskneme tlačítko (1). Návrat k výchozí tabulce barev poskytuje (2).

4.3. Tabulka barev 59



Školení GRASS GIS pro začátečníky, verze 1.1.0

Tabulku barev lze dále načíst anebo uložit do souboru.

Obrázek 4.24: Uložení a načtení tabulky barev do/z souboru.

4.3.1 Pokročilé nastavení tabulky barev

Kromě interaktivního nástroje samozřejmě v systému GRASS existuje modul, který umožňuje nastavit ta-
bulku barev neinteraktivně, jde o r.colors. Tento modul je dostupný bud’ z menu Raster → Manage colors
→ Color tables anebo z kontextového menu rastrové mapy.

Obrázek 4.25: Nastavení tabulky barev z kontextového menu správce vrstev.

Modul umožňuje definovat tabulku barev manuálně, použít předefinovanou či již přiřazenou jiné rastrové
mapě.

Obrázek 4.26: Příklad nastavení tabulky barev odstínů šedi v opačném pořadí.
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Obrázek 4.27: DMT v inverzních odstínech šedi.

4.4 Togografické analýzy

Základní topografické analýzy povrchu poskytuje modul r.slope.aspect (Raster → Terrain analysis → Slope
and aspect).

Obrázek 4.28: V dialogu nejprve zvolíme vstupní rastrovou mapu s povrchem (1) a poté v záložce (2)
požadovaný výstup.

Důležité: Podobně jako ostatní moduly pro zpracování rastrových dat i tento modul pracuje v aktuálním
výpočetním regionu. Proto je vhodné před výpočtem tento region nastavit podle vstupní rastrové mapy.

4.4.1 Míra svahu

Obrázek 4.29: Výpočet míry svahu.
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Obrázek 4.30: Výsledná mapa míry svahu ve stupních.

4.4.2 Orientace svahu

Orientaci (expozici) svahu opět počítá modul r.slope.aspect v kombinaci s parametrem aspect.

Obrázek 4.31: Výpočet orientace svahu.

Obrázek 4.32: Azimut orientace svahu.
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Obrázek 4.33: Výsledná mapa orientace svahu.

Tip: Postup jak orientaci svahu reklasifikovat je prezentováno v kapitole reklasifikace.

Obrázek 4.34: Výsledek reklasifikace mapy orientace svahu
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4.4.3 Analýza viditelnosti

Klíčový modul pro výpočet analýzy viditelnosti je modul r.viewshed (Raster → Terrain analysis → Visibi-
lity).

Obrázek 4.35: Zvolíme vstupní rastrovou mapu (1) s povrchem, název výstupní mapy viditelnosti (2) a
souřadnice observačního bodu a to bud’ manuálně či interaktivně z mapového okna (3).

Tip: Výpočet omezíme na menší území, např. interaktivním nastavením výpočetního regionu přímo z ma-
pového okna.

Obrázek 4.36: Observační bod je v mapovém okně označen černým křížkem, obdélník červené barvy zob-
razuje hranice výpočetní regionu.
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Obrázek 4.37: Výsledek analýzy viditelnosti z observačního bodu včetně legendy zobrazující velikost úhlu,
pod kterým je místo z daného observačního bodu vidět.

4.5 Rastrová algebra

Základním nástrojem pro rastrovou algebru je v systému GRASS modul r.mapcalc.

Rastrový kalkulátor je dostupný z menu Raster → Raster Map Calculator anebo z nástrojové lišty správce
vrstev.

Obrázek 4.38: Spuštění rastrového kalkulátoru.

4.5.1 Postup

1. zadání výstupní rastrové mapy

2. zadání výrazu pro r.mapcalc

3. spuštění vypočtu
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Obrázek 4.39: Dialog rastrového kalkulátoru.

Obrázek 4.40: Příklad určení výměry území s nadmořskou výšku mezi 500 a 700 metry.

YouTube – Příklad výběru oblasti s nadmořskou výškou větší než 1000m
http://www.youtube.com/embed/zADAJD3sytI

Použití z příkazové řádky

Modul r.mapcalc lze spustit z příkazové řádky podobně jako ostatní moduly systému GRASS.

Výraz pro výpočet může být předán jako parametr expression, např.

r.mapcalc expression="dmt_1000 = if(dmt > 1000, 1, null())"

Výrazy lze uložit do souboru (na každý řádek jeden výraz) a soubor předat jako parametr file.
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r.mapcalc file=vyrazy.txt

V tomto případě r.mapcalc vykoná příkazy sekvenčně, tak jak jsou uloženy v souboru.

4.6 Reklasifikace rastrových dat

Reklasifikací rastrové mapy vzniká nová rastrová mapa na základě jejich původních hodnot. Tento proces
provádí v systému GRASS modul r.reclass (Raster → Change category values and labels → Reclassify).

Důležité: Reklasifikovat lze pouze celočíselné rastrové mapy (typ CELL). Pokud má vstupní rastrová mapa
hodnoty s plovoucí desetinnou čárkou, jsou tyto hodnoty před klasifikací převedeny nejprve na celé číslo.

V případě reklasifikace rastrové mapy s hodnotami s plovoucí desetinnou čárkou je třeba namísto r.reclass
použít modul r.recode, viz příklad níže.

Poznámka: Reklasifikací nevzniká fyzicky nová rastrová mapa, nýbrž je zapsána pouze reklasifikační ta-
bulka. To má za následek to, že nelze, pokud existuje reklasifikovaná mapa, její podkladovou mapu přejme-
novat či odstranit.

4.6.1 Příklad reklasifikace DMT

Rastrovou mapu digitálního modelu terénu reklasifikujeme do čtyř typů podle níže uvedené reklasifikační
tabulky:

Min. výška Max. výška Typ
0 300 1 (nížina)
300 800 2 (nízká vysočina)
800 1500 3 (střední vysočina)
1500 4 (vysoká vysočina)

Zápis reklasifikační tabulky pro modul r.reclass vypadá následovně:

<od> thru <do> = hodnota

anebo včetně popisku

<od> thru <do> = hodnota popisek

Dle tabulky výše může vypadat zápis následovně:

0 thru 300 = 1 nížina
300 thru 800 = 2 nízká vysočina
800 thru 1500 = 3 střední vysočina
1500 thru 1700 = 4 vysoká vysočina
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Obrázek 4.41: V dialogu modulu r.reclass nejprve zadáme název rastrové mapy (1), kterou chceme reklasi-
fikovat, název výstupní reklasifikované mapy (2) a reklasifikační tabulku (3).

Výsledku přiřadíme vhodnou tabulku barev, např.

1 173:216:230
2 144:238:144
3 139:105:20
4 255:255:255

Obrázek 4.42: Příklad nastavení tabulky barev pomocí modulu r.colors.
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Obrázek 4.43: Výsledná reklasifikovaná mapa včetně legendy.

4.6.2 Reklasifikace rastrových dat s plovoucí desetinnou čárkou

Našim cílem bude reklasifikovat mapu orientace svahu do následujících tříd:

Od Do Orientace svahu
0 0 0 (rovina)
0 22.5 1 (východ)
22.5 67.5 2 (jihovýchod)
67.5 112.5 3 (jih)
112.5 157.5 4 (jihozápad)
157.5 202.5 5 (západ)
202.5 247.5 6 (severozápad)
247.5 292.5 7 (sever)
292.5 337.5 8 (severovýchod)
337.5 360.0 1 (východ)

V zápisu pro reklasifikační tabulku r.recode budou pravidla vypadat následovně:

0:22.5:1
22.5:67.6:2
67.5:112.5:3
112.5:157.5:4
157.5:202.5:5
202.5:247.5:6
247.5:292.5:7
292.5:337.5:8
337.5:360:1
0:0:0
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Obrázek 4.44: V dialogu r.recode nejprve zvolíme vstupní rastrovou mapu (1), kterou chceme reklasifikovat,
poté název výstupní reklasifikované mapy (2) a reklasifikační tabulku (3).

Tip: Nakonec můžeme ještě přiřadit jednotlivým kategoriím štítky a to pomocí modulu r.category (Raster
→ Report and statistics → Manage category information).

Příklad přiřazení štítků:

0:Rovina
1:V
2:JV
3:J
4:JZ
5:Z
6:SZ
7:S
8:SV

Obrázek 4.45: V záložce Optional zvolíme nejprve oddělovač :.
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Obrázek 4.46: A poté přiřadíme popisky z textového pole v záložce Define .

Obrázek 4.47: Výsledek reklasifikace mapy orientace svahu.

4.7 Rastrová analýza nákladů

Nejprve si v aktuálním mapsetu vytvoříme kopii vektorové mapy silnice.

Poznámka: Tento krok je potřeba, jelikož budeme modifikovat atributovou tabulku vektorové mapy a sys-
tém GRASS umožňuje editovat pouze datové elementy z aktuálního mapsetu.

Přidáme nový atribut rychlost, do něhož uložíme průměrnou rychlost v následující podobě:
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Silnice Typ Rychlost (km/h)
Dálnice 1 110
Rychlostní silnice 2 100
Silnice 1.třídy 3 90
Silnice 2.třídy 4 70
Silnice 3.třídy 5 60

Editaci hodnot atributů umožňuje Field Calculator.

Obrázek 4.48: Příklad uložení atributu rychlosti pro dálnice (typ = 1).

Nastavení atributu rychlosti z příkazové řádky

v.db.addcolumn map=silnice column="rychlost integer"
v.db.update map=silnice column=rychlost value=110 where="typ=1"
v.db.update map=silnice column=rychlost value=100 where="typ=2"
v.db.update map=silnice column=rychlost value=90 where="typ=3"
v.db.update map=silnice column=rychlost value=70 where="typ=4"
v.db.update map=silnice column=rychlost value=60 where="typ=5"

Dále převedeme modulem v.to.rast (File → Map type conversions → Vector to raster) vektorovou mapu
silnice do rastrové reprezentace. Před konverzí je nutné nastavit výpočetní region, např. interaktivně z
mapového okna nebo z příkazové řádky:

g.region res=25 n=-974156.940354 s=-994356.565878 \
w=-766980.908775 e=-736680.675344

v.to.rast input=silnice output=silnice use=attr attrcolumn=rychlost
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Poznámka pro GRASS GIS verze 6

Místo parametru attrcolumn použijte column.

Pomocí modulu r.null (Raster → Develop raster map → Manage NULL values) přiřadíme hodnotě ’NULL’
(žádná data) rychlost pohybu ’5’. Vzniklé rastrové mapě přiřadíme tabulku barev ’sepia’, viz kapitola tabulka
barev.

r.null map=silnice null=5
r.colors -n map=silnice color=sepia

Obrázek 4.49: Rasterizovaná sít’ silnic s atributem průměrné rychlosti.

Modulem v.in.ascii vytvoříme vektorovou mapu s ohniskem požáru (souřadnice v S-JTSK -754063, -
981284).

Obrázek 4.50: Vytvoření mapy s ohniskem požáru - definujeme souřadnice ohniska požáru (1) a název
výsledné vektorové mapy (2).
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Vytvoření vektorové mapy s ohniskem požáru z příkazové řádky

echo "-754063|-981284|1" | v.in.ascii input=- output=pozar

Rastrovou mapu časové náročnosti vytvoříme pomocí modulu r.mapcalc, viz kapitola rastrová algebra.

r.mapcalc expr="silnice_cas = 1.0/silnice"

Pomocí modulu r.cost (Raster → Terrain analysis → Cost surface) vypočteme rastrovou mapu nákladů
pohybu.

r.cost -k input=silnice_cas output=silnice_naklady start_points=pozar

Obrázek 4.51: Analýza nákladů pohybu v terénu, ohnisko požáru a požární stanice.

Dojezdovost pro jednotlivé požární stanice k ohnisku požáru vypočteme z rastru nákladu pomocí modulu
v.what.rast (Vector → Update attributes → Sample raster maps at point locations). Nejprve si v aktuálním
mapsetu vytvoříme kopii vektorové mapy pozarni_stanice. Přidáme nový atribut dojezdovost, do
něhož uložíme hodnotu dojezdovosti pro danou požární stanici.

Přidání atributu dojezdovosti z příkazové řádky

g.copy vect=pozarni_stanice@osm,pozarni_stanice
v.db.addcolumn map=pozarni_stanice column="dojezdovost double precision"

v.what.rast map=pozarni_stanice raster=silnice_naklady column=dojezdovost
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Obrázek 4.52: Nalezení požární stanice s nejmenší hodnotou dojezdovosti, tj. požární stanice s kategorií
’89’.

Souřadnice požární stanice s kategorií ’89’ poskytne modul v.out.ascii (File → Export vector map → ASCII
points or GRASS ASCII vector export).

v.out.ascii input=pozarni_stanice cats=89
-750649.82535985|-992867.12907965|89

Nejkratší (spádovou) cestu vypočteme modulem r.drain (Raster → Terrain analysis → Least cost route or
flow).

r.drain -n input=silnice_naklady output=cesta \
start_coor=-750649.82535985,-992867.12907965

Poznámka pro GRASS GIS verze 6

Místo parametru start_coor použijte coor.
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Obrázek 4.53: Výsledek, nejkratší cesta k požáru.

Obrázek 4.54: Vizualizace rastrové mapy nákladů včetně nejkratší spádové cesty ve 3D.
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KAPITOLA 5

Vektorové analýzy

5.1 Editace vektorových dat

5.1.1 Vytvoření nové vektorové mapy

Novou vektorovou mapu vytvoříme z menu Vector → Develop vector map → Create new vector map.

Obrázek 5.1: Dialog pro vytvoření nové vektorové mapy.

Poznámka pro pokročilé

Klíč (key column) označuje v dialogovém okně název atributu, který bude sloužit pro definovaní vazby mezi
geometrickou a atributovou částí popisu geoprvků, ve výchozím nastavení se jedná o atribut cat.

Vytvoření prázdné vektorové mapy z příkazové řádky

v.edit map=novy_vektor tool=create

Vytvoření a úprava atributové tabulky

Nástroj pro editaci atributové tabulky spustíme z kontextového menu vektorové mapy Show attribute data .
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Obrázek 5.2: Spuštění správce atributových dat.

Přidávat či přejmenovávat atributy lze v záložce Manage attributes , více v sekci editace atributových dat.

Obrázek 5.3: Přidání nového atributu s názvem popis.

5.1.2 Editace vektorové mapy

Existující vektorovou mapu můžeme začít editovat z kontextového menu Start editing .
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Obrázek 5.4: Spuštění editace vektorových dat z kontextového menu správce vrstev.

Nyní můžeme v mapovém okně zvolit nástroj kreslení linie (nebo kterýkoliv jiný) a nakreslit požadovaný
tvar.

Poznámka: Mapové okno bude zobrazovat podkladové mapy, které v něm byly načteny dříve.

Po ukončení editace geoprvku (pravým tlačítkem) se objeví formulář pro vyplnění atributů.

Obrázek 5.5: Definice atributů pro nově vytvořený vektorový geoprvek.

Poznámka: Počáteční a koncové body (tzv. uzly) linií a hranic ploch se na sebe budou automaticky přichy-
távat (výchozí hodnota je 10px).

Uzly jsou vykresleny různou barvou, podle toho jsou-li přichyceny k dalšímu uzlu či nikoliv. Viz dialog
Digitization settings, záložka Symbology.

Při editaci je každá plocha automaticky zaplochována centroidem. K centroidu lze později navázat požado-

5.1. Editace vektorových dat 79



Školení GRASS GIS pro začátečníky, verze 1.1.0

vané atributy plochy. Hranice plochy a jejich centroidy lze také editovat i zvlášt’.

Mazání vybraných prvků je potřeba vždy potvrdit pravým tlačítkem myši.

V nastavení editace můžeme nastavit zobrazení editovaných prvků (šířka, barvy), přichytávání, automatické
přiřazování atributů novým prvkům a další.

Obrázek 5.6: Nastavení editace.

Poznámka pro pokročilé

Editovat vektorové prvky lze také v příkazové řádce pomocí modulu v.edit.

5.2 Prostorové funkce

YouTube – Příklad základních prostorových funkcí (buffer, clip, erase) v kombinaci s atributovými
dotazy
http://www.youtube.com/embed/YWRHFylZCuo

5.2.1 Výběr z vektorové mapy

Vybírat geoprvky z vektorové mapy můžeme selektivně podle jejich kategorií a atributů. Nástroj pro výběr
v.extract můžeme spustit z menu Vector → Feature selection → Select by attributes.

Poznámka: Ujistěte se, že máte v pracovní cestě přidány všechny mapsety tak, abyste mohli pracovat s
daty v nich obsaženými.
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V následujícím příkladě vybereme z vektorové mapy silnice (mapset osm) všechny dálnice (splňující
podmínku typ = 1). Výsledek uložíme do vektorové mapy dalnice.

Obrázek 5.7: Vytvoření tématické vektorové mapy dalnice z OpenStreetMap.

5.2.2 Obalová zóna

Obalovou zónu pro vektorová data vytváří modul v.buffer (Vector → Buffer vector).

Příklad vytvoření obalové zóny s šířkou 5 km.

v.buffer input=dalnice output=hluk distance=5000

Obrázek 5.8: Příklad obalové zóny 5 km okolo dálnic.
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5.2.3 Překrytí, průnik, spojení, vyloučení

Tyto operace zajišt’uje modul v.overlay (Vector → Overlay vector maps → Overlay vector maps).

Překrytí (union)

V našem případě vytvoříme vektorovou mapu chranena_uzemi (4) spojením (3) velkoplošných (2) a
maloplošných chráněných území (1).

Obrázek 5.9: Vytvoření mapy maloplošných a velkoplošných chráněných území.

Spuštění z příkazové řádky

v.overlay ainput=maloplosna_uzemi binput=velkoplosna_uzemi operator=or \
output=chranena_uzemi

K výsledné vektorové mapě je přiřazena atributová tabulka, která je spojena z obou vstupních vektorových
map. Atributy první vektorové mapy (ainput) jsou označeny prefixem a_, atributy druhé (binput) pre-
fixem b_.

Obrázek 5.10: Atributová tabulka výsledné vektorové mapy chranene_uzemi.
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Průnik (intersect)

V tomto případě zjistíme, jak obalová zóna dálnic (2) zasahuje do chráněných území (1). Opět spustíme
modul v.overlay a použijeme operaci průnik (operátor AND - (3)).

Obrázek 5.11: Dálniční obalová zóna procházející chráněným územím.

Spuštění z příkazové řádky

v.overlay ainput=chranena_uzemi binput=hluk operator=and \
output=dalnice_chranenauzemi

Obrázek 5.12: Hluková oblast zasahující maloplošné chráněné území Černovický hájek u Brna.
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Obrázek 5.13: Hluková oblast zasahující velkoplošné chráněné území CHKO Česká kras a CHKO Křivo-
klátsko.

Podobně fungují i operátory XOR a NOT.

5.2.4 Spojení vektorových map (merge)

Alternativním způsob spojení vektorových map umožňuje modul v.patch (Vector → Overlay vector maps
→ Patch vector maps). Na rozdíl od v.overlay tento modul sloučí vstupní vektorové mapy automaticky.

Obrázek 5.14: Příklad vytvoření nové vektorové mapy doprava, která je složena ze vstupních vektorových
map silnice a zeleznice.

Spuštění z příkazové řádky

v.patch input=silnice,zeleznice output=doprava

5.3 Topologie vektorových dat

Jak již bylo uvedeno v úvodní části, vektorová data jsou v prostředí GRASS uložena v topologickém for-
mátu. Znamená to, že nad nimi můžeme rychleji provádět celou řadu operací, které jsou v netopologickém
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formátu daleko náročnější. Toto je na druhou stranu vyváženo náročnější správou dat a potenciálně větším
nebezpečím jejich poškození.

Pokaždé, když je vytvořena nová vektorová mapa či změněna již existující mapa, je vždy nově vytvořena
topologie vektorových prvků v mapě. Tu můžeme znovu vybudovat také manuálně modulem v.build, který
můžete spustit z menu Vector → Topology maintenance → Create or rebuild topology.

Poznámka: Data lze modifikovat (včetně sestavení topologie) pouze v aktuálním mapsetu. Pro řešení níže
uvedené úlohy si nejprve pomocí modulu g.copy či z kontextového menu správce vrstev (viz obr. níže)
vytvoříme v aktuálním mapsetu lokální kopii vektorové mapy obce_polygon (mapset ruian).

Obrázek 5.15: Vytvoření kopie vektorové mapy v aktuálním mapsetu.

Obrázek 5.16: Znovu vybudování topologie pro vektorovou mapu obce_polygon (lokální kopie - 1).
Chyby v topologii uložíme do nové vektorové mapy (2).

5.3.1 Oprava topologických chyb

Pro práci s topologií vektorových dat slouží především modul v.clean (Vector → Topology maintenance →
Clean vector map). Tento modul je zásadní v okamžiku, kdy vektorová mapa obsahuje topologické chyby
např. po importu dat z formátu Esri Shapefile .
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WARNING: 3742 areas represent more (overlapping) features, because polygons
overlap in input layer(s). Such areas are linked to more than 1
row in attribute table. The number of features for those areas is
stored as category in layer 2

6361 input polygons
Total area: 7.891444e+10 (13448 areas)
Overlapping area: 4.078277e+02 (3742 areas)
Area without category: 3.879863e+02 (3327 areas)

Data obsahující topologické chyby je potřeba před dalšími analýzami opravit. V opačném případě budou
výsledkem opět chybová data. Například v případě spojení polygonů obcí v ČR nevznikne celistvá plocha
reprezentující území ČR, ale několik děr a to díky mezerami mezi vstupními polygony. Vstupní data v tomto
případě obsahuje nejen překrývající se polygony ale i tzv. mezery.

Obrázek 5.17: Výsledek spojení polygonů obcí nad daty, které obsahují topologické chyby.

Co se týče polygonových dat, většina topologických chyb může být opravena odstraněním ploch s relativně
malou výměrou, tj. ploch, které reprezentují části, kde dochází k překryvu či mezerám mezi vstupními
polygony. V našem případě bude stačit odstranit plochy s výměrou menší než 10km2.

v.clean input=obce_broken output=obce type=area tool=rmarea thresh=10

Obrázek 5.18: Výsledek spojení polygonů obcí po opravě topologických chyb.

Tato problematika je více rozebrána na portálu FreeGIS.
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5.4 Atributová data

5.4.1 Editace atributových dat

Správce atributových dat umožňuje kromě dotazování (viz kapitola Atributové dotazy) atributová data mo-
difikovat.

Důležité: Editovat lze atributové data vektorových map pouze z aktualního mapsetu.

YouTube – Editace záznamů v atributové tabulce
http://www.youtube.com/embed/UZswOcIyaX8

Editace atributových dat z příkazové řádky

Nabízejí se dva moduly:

• db.execute který umožňuje spustit jakýkoliv SQL příkaz typu UPDATE, ALTER či DELETE

db.execute sql="update obce_polygon set nespravny = ’1’ where kod = 569054"

• anebo v.db.update jako frontend pro vektorové mapy

v.db.update map=obce_polygon column=nespravny value="1" where="kod = 569054"

Správce atributových dat umožňuje přidávat do atributové tabulky nové záznamy.
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YouTube – Přidání nového záznamu do atributové tabulky
http://www.youtube.com/embed/mmPvMRBDxLg

Vložení nového záznamu do atributové tabulky z příkazové řádky

db.execute sql="insert into obce_polygon(cat, nazev) values (6253, ’pokus’)"

Vybrané záznamy lze z atributové tabulky odstranit.

Obrázek 5.19: Odstranění záznamů z atributové tabulky.

Odstranění záznamů z atributové tabulky z příkazové řádky

db.execute sql="delete from obce_polygon where cat = 6253"

Varování: Při odstranění či přidání záznamů do atributové tabulky dochází k modifikaci pouze popisné
složky geoprvků. Např. při odstranění záznamu z atributové tabulky zůstává asociovaná geometrická
složka popisu geoprvku ve vektorové mapě zachována.

Numerické atributy mohou být také vypočítány na základě zvolené funkce.

Obrázek 5.20: Funkce pro výpočet numerických atributů.
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Výpočet hodnoty atributu z příkazové řádky

v.to.db map=obce_polygon option=area columns=vymera

Příklad přidání nového atributu s výměrou a její výpočet (ve čtverečních mapových jednotkách).

YouTube – Přidání nového sloupce do atributové tabulky a výpočet plochy
http://www.youtube.com/embed/qkXgQXF1QkA

5.4.2 Field Calculator

Field Calculator je nástroj, který umožňuje sestavit SQL UPDATE příkaz a pomocí něho modifikovat atri-
butová data.

Obrázek 5.21: Ukázka nástroje Field Calculator.

YouTube – Výpočet poměru obvodu a výměry plochy pomocí Field Calculatoru
http://www.youtube.com/embed/44KmtnBJtgo

5.4.3 Pokročilé dotazování

Atributové dotazy na geoprvky umožňují dva moduly v.db.select a db.select.

Modul v.db.select

Modul v.db.select umožňuje provádět dotazy pouze nad atributovými daty připojenými k dané vektorové
mapě. Je dostupný z menu Database → Query → Query vector attribute data. Pokud není zadána where
podmínka, tak modul vypíše všechny záznamy z atributové tabulky.
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Obrázek 5.22: Atributový dotaz pomocí modulu v.db.select (zadání vektorové mapy).

Obrázek 5.23: Atributový dotaz pomocí modulu v.db.select (volitelně zadání ’where’ podmínky).

Modul db.select

Modul db.select umožňuje provádět SQL dotazy (SELECT) nad libovolnými atributovými daty dostupnými
pomocí daného databázového ovladače. SQL dotazy mohou být uloženy v souboru (parametr input) anebo
definovány jako parametr sql. Tento modul je dostupný z menu Database → Query → Query any table.

Obrázek 5.24: Atributový dotaz pomocí modulu db.select (zadání SQL dotazu).

Obrázek 5.25: Atributový dotaz pomocí modulu db.select (výsledek SQL dotazu).
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Jednoduché atributové dotazu z příkazové řádky

db.select sql="SELECT COUNT(*) FROM obce WHERE ob01/ob91-1 >= 1"

Obrázek 5.26: Vícenásobný atributový dotaz pomocí modulu db.select (zadání SQL dotazů).

Obrázek 5.27: Vícenásobný atributový dotaz pomocí modulu db.select (výsledek SQL dotazů).

Poznámka: Pro ostatní SQL příkazy (INSERT, UPDATE, DELETE, ALTER a další) je určen modul
db.execute.
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5.5 Sít’ové analýzy

GRASS nabízí řadu modulů pro tzv. sít’ové analýzy. Jedná se o typy úloh nad sít’ovým grafem (v tomto
případě cestní sítě).

• v.net - správa vektorové sítě

• v.net.alloc - alokace zdrojů (vytvoření podsítí, např. policejní okrsky)

• v.net.allpairs - počítá nejkratší cesty mezi všemi páry uzlů v síti

• v.net.bridge - hledá mosty a artikulační body

• v.net.centrality - zjišt’uje centralitu (užitečnost) uzlů v síti

• v.net.components - hledá silné a slabé komponenty v síti (grafu)

• v.net.connectivity - zjišt’uje úroveň spojitosti sítě

• v.net.distance - výpočet vzdáleností po síti mezi dvěma skupinami prvků

• v.net.flow - nalezení minimálního toku v síti mezi dvěma skupinami uzlů

• v.net.iso - analýza nákladů pohybu od zdroje

• v.net.path - hledání nejkratší cesty

• v.net.salesman - problém obchodního cestujícího

• v.net.spanningtree - hledá minimální kostru sítě (grafu)

• v.net.steiner - problém minimálního Steinerova stromu

• v.net.timetable - hledá nejkratší cesty s užitím časových plánů

• v.net.visibility - konstrukce grafu viditelnosti

• v.net.turntable - připravovaný modul, v němž bude možné definovat ceny za odbočování v jednotlivých
směrech

Poznámka: Sít’ové analýzy jsou založeny na heuristických algoritmech, což znamená, že nebude pravděpo-
dobně nalezeno optimální řešení, ale pouze suboptimální (kompromis mezi optimálním řešením a omezením
výpočetního času na přípustnou dobu).
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5.5.1 Ukázka

Obrázek 5.28: Příklad nalezení nejkratší cesty pomocí GUI nástroje pro sít’ové analýzy.

YouTube – Příklad sít’ových analýz v GUI systému GRASS
http://www.youtube.com/embed/McOrMauPc_I

Poznámka pro pokročilé

Je možné rozlišovat směr linie tam (forward) a zpět (backward). Všechny moduly totiž obsahují parametry,
které dovolují definovat ceny pro pohyb jednotlivými směry. Zakázané směry jsou reprezentovány negativ-
ními cenami (např. jednosměrné komunikace, uzavírky silnic, atd.).

Příprava dat je náročná a je náplní navazujícího školení pro pokročilé uživatele.
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KAPITOLA 6

Import a export geodat

6.1 Import geodat

Důležité: V této kapitole předpokládáme, že importovaná data jsou lokalizovaná v souřadnicovém systému
odpovídající aktuální lokaci. To, že jsou data v jiném souřadnicovém systému můžete zjistit z dialogu pro
import dat (viz obr. níže). V tomto případě musíte nejprve data naimportovat do nové lokace a následně je
transformovat do aktuální lokace (viz kapitola Geodata v různých souřadnicových systémech).

Obrázek 6.1: Data nejsou v souřadnicovém systému lokace. Je nutné je transformovat.

Většina rastrových formátů může být naimportována modulem r.in.gdal, pro vektorová data existuje modul
v.in.ogr. GUI systému GRASS disponuje specializovanými nástroji pro hromadný import dat (viz níže).

6.1.1 Rastrová data

Nástroj pro import rastrových dat je dostupný z menu File → Import raster data → Common formats import
nebo nástrojové lišty správce vrstev.

V dialogu pro import rastrových dat určíme:

1. typ zdroje
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Obrázek 6.2: Nástroj pro import rastrových dat dostupný z nástrojové lišty správce vrstev.

2. formát dat

3. adresář s daty

4. seznam vrstev k importu

5. spustíme import

Obrázek 6.3: Určení rastrových dat (PNG) z daného adresáře k importu.
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Obrázek 6.4: Průběh importu.

Obrázek 6.5: Naimportovaná data se automaticky přidají do stromu vrstev.

Import rastrových dat z příkazové řádky

r.in.gdal input=dmt.tif output=dmt

Poznámka: Ukázka hromadného importu rastrových dat jako Python skript

import os
import grass.script as grass

for fname in os.listdir("."):
name, ext = os.path.splitext(fname)
if ext in (’.png’, ’.tif’, ’.jpg’, ’.gif’):

grass.run_command(’r.in.gdal’, input = fname, output = name)

Skriptování v jazyce Python je náplní navazujícího školení pro pokročilé uživatele.
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6.1.2 Vektorová data

Nástroj pro import vektorových dat je dostupný z menu File → Import vector data → Common formats
import nebo nástrojové lišty správce vrstev.

Obrázek 6.6: Nástroj pro import vektorových dat dostupný z nástrojové lišty správce vrstev.

V dialogu pro import vektorových dat určíme:

1. typ zdroje

2. formát dat

3. adresář s daty

4. seznam vrstev k importu

5. spustíme import

Obrázek 6.7: Určení vektorových dat (Esri Shapefile) z daného adresáře k importu.
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Obrázek 6.8: Průběh importu.

Obrázek 6.9: Naimportovaná data se automaticky přidají do stromu vrstev.

Import vektorových dat z příkazové řádky

v.in.ogr dsn=lesy.shp

Poznámka: Ukázka hromadného importu vektorových dat z aktuálního adresáře jako Python skript

import os
import grass.script as grass

layers = grass.read_command(’v.in.ogr’, flags = ’l’, dsn=’.’).splitlines()
for fname in layers:

grass.run_command(’v.in.ogr’, dsn = ’.’, layer = fname)

Skriptování v jazyce Python je náplní navazujícího školení pro pokročilé uživatele.
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6.1.3 Poznámky k importu vektorových dat

Při importu vektorových dat provádí v.in.ogr konverzi vektorových dat z reprezentace Simple Features do
topologického formátu systému GRASS, viz kapitola Topologie vektorových dat:

• v případě bodů (point) a lomených čár (linestring) nedochází ke změně povahy vektorového prvku, v
topologickém formátu GRASS jsou vyjádřeny jako points, resp. lines,

• polygony jsou rozloženy na hraniční linie (boundary) a centroidy (centroid), externí ring polygonu je
převeden na hraniční linie (hraniční linie sousedících polygonů je uložena pouze jednou),

• pro každý polygon je vypočten centroid, tj. reprezentativní bod ležící uvnitř plochy,

• polygon je vyjádřen v topologickém modelu systému GRASS jako plocha (area),

• případné díry v polygonu jsou uloženy jako plochy, které tvoří tzv. ostrovy (isle).

Například dva sousedící polygony (jeden s otvorem) jsou v topologickém modelu systému GRASS vyjá-
dřeny čtyřmi hraničními liniemi a dvěma centroidy. Polygony a otvor v druhém polygonu tvoří tři plochy.
Otvor v druhém polygonu a prostor vně polygonu definuje dva ostrovy.

| Number of points: 0 Number of centroids: 2 |
| Number of lines: 0 Number of boundaries: 4 |
| Number of areas: 3 Number of islands: 2 |

Obrázek 6.10: Topologická reprezentace dvou polygonů (druhý polygon s otvorem).

Modul v.in.ogr provádí při importu operace s cílem odstranit případné topologické chyby v datech, které
při konverzi z reprezentace simple features do topologického formátu systému GRASS mohou vzniknout.
Topologické chyby, které nemohou být z nejrůznějších důvodů během importu odstraněny, je možné opravit
pomocí modulu v.clean, více v kapitole Topologie vektorových dat.
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Kódování atributových dat

Při importu dat ve formátu Esri Shapefile je nutné nastavit správné kódování pro atributová data. Atributy
obsahující diakritiku jsou často kódována ve znakové sadě Windows-1250 (kód cp1250). Hodnotu kódo-
vání lze nastavit pomocí parametru encoding modulu v.in.ogr.

Obrázek 6.11: Kódování atributů vektorových dat lze definovat přímo v importním dialogu GUI systému
GRASS.

Import vektorových dat (znaková sada Windows-1250) z příkazové řádky

v.in.ogr dsn=orp.shp encoding=cp1250

Poznámka pro GRASS GIS verze 6

Vzhledem k tomu, že modul v.in.ogr nemá ve verzi GRASS 6 parametr encoding, je nutné znakovou sadu
určit pomocí proměnné prostředí SHAPE_ENCODING.

SHAPE_ENCODING=cp1250 v.in.ogr dsn=orp.shp

Formát DGN

Formát DGN lze naimportovat pouze v případě, že je knihovna GDAL zkompilována s podporou pro tento
formát. Bohužel knihovna GDAL nepodporuje formát verze 8.0 a vyšší.

Poznámka: V případě formátu DGN lze doporučit jeho konverzi do formátu DXF a import do systému
GRASS pomocí modulu v.in.dxf.

Importovaná data a výpočetní region

Pokud se v mapovém okně nezobrazují žádná data, je nutné nastavit pohled na aktuálně vybranou mapu.

Obrázek 6.12: Nastavení pohledu mapového okna na vybranou mapovou vrstvu z kontextového menu
správce vrstev.
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Obrázek 6.13: Nastavení pohledu mapového okna na vybranou mapovou vrstvu.

Import dat nemá vliv na aktuální nastavení výpočetního regionu. Výpočetní region lze nastavit na základě
naimportovaných dat z kontextového menu správce vrstev.

Obrázek 6.14: Nastavení výpočetního regionu na základě mapové vrstvy.

Poznámka: Výpočetní region lze automaticky během importu rozšířit na základě importovaných dat.

Obrázek 6.15: Rozšíření výpočetního regionu na základě importovaných dat.

6.2 Export do ostatních GIS formátů

Rastrové mapy lze ze systému GRASS exportovat do externích formátů pomocí modulu r.out.gdal. Pro
export vektorových map slouží modul v.out.ogr.

Poznámka: Výše zmíněné moduly používají pro export dat knihovnu GDAL, která v režimu zápisu pod-
poruje téměř 200 rastrových a vektorových formátů.

6.2.1 Rastrová data

Modul pro export rastrových dat je dostupný z menu File → Export raster map → Common export formats
anebo z kontextového menu správce vrstev.
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Obrázek 6.16: Export rastrových dat z kontextového menu správce vrstev.

V následujícím dialogu zvolíme název výstupního souboru a jeho formát.

Obrázek 6.17: Zvolíme rastrovou mapu pro export (1), cestu k výstupnímu souboru (2) a formát výstupního
souboru (3). V tomto případě se data vyexportují do souboru dmt.tif v aktuálním adresáři.

Export rastrové mapy do formátu GeoTIFF z příkazové řádky

r.out.gdal input=dmt output=dmt.tif format=GTiff

6.2.2 Vektorová data

Modul pro export vektorových dat je dostupný z menu File → Export vector map → Common export formats
anebo z kontextového menu správce vrstev.

Obrázek 6.18: Export vektorových dat z kontextového menu správce vrstev.

V následujícím dialogu zvolíme název výstupního souboru a jeho formát.
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Obrázek 6.19: Zvolíme vektorovou mapu pro export (1), cestu k výstupnímu souboru (2) a formát výstupního
souboru (3). V tomto případě se data vyexportují do souboru obce.shp v aktuálním adresáři.

Export vektorové mapy do formátu Esri Shapefiel z příkazové řádky

v.out.ogr input=obce_polygon dsn=obce.shp format=ESRI_Shapefile

6.2.3 Export obsahu mapové okna do obrázku

Kromě exportu dat do GIS formátů je možné uložit obsah mapové okna do obrazového souboru jako je např.
PNG. Tato funkce je dostupná z nástrojé lišty mapového okna.

Obrázek 6.20: Export obsahu mapového okna do obrázku.

Obrázek 6.21: V následující dialogu zvolíme dimenzi výstupního obrázku.
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Obrázek 6.22: Příklad výsledku včetně legendy, měřítka a textového popisku (viz kapitola Mapové ele-
menty).

6.3 Přenost dat

GRASS disponuje vlastním formátem pro přenost dat. Zabalit rastrovou mapu do tohoto formátu umožňuje
modul r.pack (File → Export raster map → Pack raster map), pro vektorová data je k dispozici modul v.pack
(File → Export vector map → Pack vector map). Rozbalit takto vytvořený soubor (tzv. pack) umožňují
moduly r.unpack (File → Import raster map → Unpack raster map) a v.unpack (File → Import vector map
→ Unpack vector map).

Obrázek 6.23: Zabalení rastrové a vektorové mapy z GUI systému GRASS.
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Obrázek 6.24: Funkce rozbalení rastrové či vektorové mapy je dostupné z nástrojové lišty správce vrstev.

Důležité: Takto zabalenou rastrovou či vektorovou mapu lze rozbalit pouze v lokaci se stejnými souřadni-
covým systémem. Pokud tato podmínka není splněna, tak rozbalení skončí chybou.

Obrázek 6.25: Kontrola souřadnicového systému při rozbalení dat.

Poznámka: Takto zabalené mapy jsou samozřejmě multiplatformní a lze je přenášet mezi různými operač-
ními systémy, např. z GNU/Linux na MS Windows.

6.3.1 Přenos mapsetů či lokací

Přenášet mapsety či lokace lze snadno, tak že je zabalíme například pomocí aplikace zip.

Důležité: Při přenášení mapsetů platí pouze jedna podmínka. Mapset může být umístěn pouze do lokace se
stejným souřadnicovým systém. V opačném případě dojde k nekozistenci dat, se kterou si GRASS neporadí.
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6.4 Vytvoření vlastní lokace

Novou lokaci lze vytvořit pomocí průvodce, který je dostupný z uvítací obrazovky systému GRASS. Spus-
tíme GRASS a sekci Select GRASS Location stiskneme tlačítko New .

Obrázek 6.26: Spuštění průvodce tvorbou lokace.

Průvodce tvorbou lokace je možné spustit i z běžící seance a to z menu Settings → GRASS working envi-
ronment → Create new location.

Obrázek 6.27: Spuštění průvodce tvorbou lokace z menu správce vrstev.

Lokaci lze vytvořit několika různými postupy:

1. pomocí EPSG kódu

2. na základě georeferencovaných dat
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3. na základě WKT či PRJ souboru

4. výběrem kartografického zobrazení, referenčního elipsoidu

5. definicí parametrů pro knihovnu PROJ.4

6. bez zadaní parametrů (pro negeoreferencovaná data)

Většinou bude stačit vytvořit novou lokaci na základě EPSG kódu (viz tabulka níže) anebo ze vstupních
geodat, pokud je máme k dispozici.

EPSG Souřadnicivý systém
EPSG:5514 S-JTSK
EPSG:4328 WGS-84
EPSG:3857 Web Mercator
EPSG:32632 UTM (zóna 32)
EPSG:32633 UTM (zóna 33)
EPSG:3835 S-42
EPSG:4258 ETRS-89

Níže uvedené postupy ukazující tři nejpoužívanější metody vytvoření lokace.

• S-JTSK na základě EPSG kódu

• Pro data SRTM na základě geodat

• Lokace pro souřadnicově nepřípojená data (XY)

6.4.1 Příklad vytvoření lokace pro data v souřadnicovém systému S-JTSK

Na úvodní stránce průvodce vyplníme název lokace (Project Location) a volitelně i krátký popisek (Optional
Location Title).

Obrázek 6.28: Vytvoření lokace pro S-JTSK (krok 1).

Na další stránce vybereme způsob vytvoření lokace.
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Obrázek 6.29: Vytvoření lokace pro S-JTSK (krok 2).

V našem případě vytvoříme lokaci na základě EPSG kódu, pro souřadnicový systém S-JTSK EPSG:5514.

Poznámka: EPSG:5514 podporuje systém GRASS pouze pokud používate verzi knihovny PROJ.4
4.9 a vyšší (tuto informaci získáte z menu Help → About system). V opačném případě musíte při-
dat parametry pro S-JTSK do konfiguračního souboru ručně: na začátek souboru s definicí kódů
EPSG (v případě OS GNU/Linux bývá umístěn v /usr/share/proj/epsg, u MS Windows
c:\OSGeo4W\share\proj\epsg), přidáme následující 2 řádky:

# Krovak S-JTSK
<5514> +proj=krovak +lat_0=49.5 +lon_0=42.5 +alpha=30.28813972222222
+k=0.9999 x_0=-0 +y_0=-0 +ellps=bessel +pm=ferro +to_meter=-1 +no_defs
+towgs84=570.8,85.7,462.8,4.998,1.587,5.261,3.56

Soubor uložte, zavřete a případně restartujte GRASS Location Wizard, aby došlo ke znovu načtení databáze
kódů EPSG.

Obrázek 6.30: Vytvoření lokace pro S-JTSK (krok 3).
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Obrázek 6.31: Vytvoření lokace pro S-JTSK (krok 4). Po zadání EPSG kódu se objeví dialog pro volbu
transformačních parametrů.

Obrázek 6.32: Vytvoření lokace pro S-JTSK (krok 5). Po zadání EPSG kódu se objeví dialog pro volbu
transformačních parametrů.

Obrázek 6.33: Vytvoření lokace pro S-JTSK (krok 6). Nastavení výchozího výpočetního regionu přesko-
číme. Výchozí region nastavíme později po importu dat.

Obrázek 6.34: Vytvoření lokace pro S-JTSK (krok 7). Případně ještě můžeme vytvořit vlastní mapset (ma-
pset PERMANENT je vytvořen vždy).
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Obrázek 6.35: Poté se spustí systém GRASS s právě vytvořenou lokací.

Vytvoření lokace z příkazové řádky

grass70 -c EPSG:5514:3 /opt/grassdata/skoleni-s-jstk

6.4.2 Vytvoření lokace na základě geodat

Obrázek 6.36: Vytvoření lokace pro data SRTM (krok 1).
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Obrázek 6.37: Vytvoření lokace pro data SRTM (krok 2).

Obrázek 6.38: Vytvoření lokace pro data SRTM (krok 3).

Obrázek 6.39: Vytvoření lokace pro data SRTM (krok 4).
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Obrázek 6.40: Vytvoření lokace pro data SRTM (import dat, krok 1). Volitelně můžeme data, na základě
kterých byla lokace vytvořena, i naimportovat (do mapsetu PERMANENT).

Obrázek 6.41: Vytvoření lokace pro data SRTM (import dat, krok 2).

6.4.3 Vytvoření lokace pro souřadnicově nepřipojená data

Obrázek 6.42: Vytvoření lokace pro XY (krok 1).

Obrázek 6.43: Vytvoření lokace pro XY (krok 2).
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Obrázek 6.44: Vytvoření lokace pro XY (krok 3).

Vytvoření nového mapsetu v rámci lokace

Nový mapset v rámci již existující lokace můžeme vytvořit dvěma způsoby:

• z uvítací obrazovky systému GRASS anebo

Obrázek 6.45: Vytvoření nového mapsetu (2) v rámci vybrané lokace (1).

• z menu Správce vrstev Settings → GRASS working environment → Create new mapset.
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Obrázek 6.46: Vytvoření nového mapsetu v rámci aktuální lokace z menu správce vrstev.

Obrázek 6.47: V následující dialogu zvolíme jeho název.

Po vytvoření nového mapsetu se do něj systém GRASS automaticky přepne.

6.5 Geodata v různých souřadnicových systémech

Důležité: Tento postup se od verze GRASS 7.0.2 výrazně zjednodušuje. GRASS od této verze poskytuje
nástroj, který nejen vstupní geodata naimportuje do aktuálního mapsetu, ale také provede jejich transformaci
v případě, že se souřadnicové systémy vstupních geodat a dané lokace liší. Jedna se moduly r.import a
v.import.
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V případě, že se souřadnicový systém vstupních geodat a dané lokace liší (viz Projection match na 6.48)
nelze import provést přímo. Postup vyžaduje hned několik kroků.

Obrázek 6.48: Vstupní data nejsou v souřadnicovém systému lokace. Je nutné je transformovat.

6.5.1 Postup

1. Vytvořit novou lokaci se souřadnicovým systémem vstupních geodat.

2. Do této nové lokaci se přepnout a geodata tam naimportovat.

3. Dále se vrátit opět do původní lokace a do této naimportovaná geodata transformovat.

Vytvoření nové lokace

Z menu Settings → GRASS working environment → Create new location spust’te průvodce tvorby lokace,
novou lokaci můžete vytvořit více způsoby, nejrychlejší je v tomto případě tvorba na základě vstupních
geodat. Po vytvoření nové lokace se objeví dialog, který umožňuje se do této lokace přepnout.

Obrázek 6.49: Přepnutí do nově vytvořené lokace.

Obrázek 6.50: Potvrzení aktuální lokace.
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Import geodat do nové lokace

Geodata do nově vytvořené lokace naimportuje standardní cestou, položka Projection match by měla ob-
sahovat již hodnotu Yes. Po importu dat se vrátíme do původní lokace Settings → GRASS working envi-

Obrázek 6.51: Souřadnicový systém dat a lokace se shoduje.

ronment → Change location and mapset.

Obrázek 6.52: Dialog změny lokace a mapsetu.

Aktuální nastavení lokace můžeme volitelně uložit do souboru s projektem (tzv. workspace file).

Obrázek 6.53: Dialog pro uložení projektu (workspace).

Poté se objeví dialog, který potvrzuje, že aktuální lokace je opět ta cílová.

Obrázek 6.54: Dialog potvrzující přepnutí do původní lokace a mapsetu.
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Transformace dat do cílové lokace

Transformovat rastrová data umožňuje modul r.proj dostupný z menu Raster → Develop raster map →
Reproject raster map from different GRASS location, podobně pro vektorová data existuje v.proj (Vector →
Develop vector map → Reproject vector map from different GRASS location).

Následuje příklad pro transformaci vektorových dat.

Obrázek 6.55: V záložce Source vybereme lokaci (1) a mapset (2), který obsahuje vstupní data, dále vstupní
vektorovou mapu (3). Pokud by lokace byla umístěna v jiném adresáři, tak je potřeba jej definonat pomocí
parametru dbase.

Obrázek 6.56: Případně můžeme v záložce Target zvolit název pro výstupní mapu (4). Transformaci spus-
tíme (5).

Po úspěšné transformaci se vytvořená vrstva automaticky přidá do správce vrstev a zobrazí v mapovém
okně.

6.6 Georeferencování

Souřadnicové připojení geodat (tzv. georeferencování) umožňuje v systému GRASS nástroj GCP Manager
dostupný z menu File → Georectify anebo přímo z nástroje lišty správce vrstev.
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Obrázek 6.57: Spuštění nástroje pro georeferencování dat ze správce vrstev.

Nástroj je dále dostupný z příkazové řádky jako modul g.gui.gcp.

Tento nástroj umožňuje souřadnicově připojit jak rastrová tak vektorová data.

6.6.1 Postup

Na vstupu tedy máme souřadnicově nepřipojená rastrová či vektorová data. Tato data nejprve do systému
GRASS naimportujeme. Pro tento účel se nejprve vytvoří lokace s matematickým souřadnicovým systémem.
Do této lokace data naimportujeme a poté se vrátíme zpět do lokace, do které chceme data georeferencovat.

Následně na to spustíme GCP Manager a v průvodci postupně vybereme:

Obrázek 6.58: Nejprve zvolíme typ dat, které chceme souřadnicově připojit - bud’ rastrová anebo vektorová
data (1), dále zvolíme lokaci (2) a mapset (3), ve které jsou tato data uložena.

Obrázek 6.59: Dále vytvoříme skupinu, která bude obsahovat data určená pro souřadnicové připojení (4).
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Obrázek 6.60: Zvolíme název skupiny (5) a přidáme do ni rastrové či vektorové mapy (6). Pokud do skupiny
přidáme více map najednou, tak budou všechny tyto mapy souřadnicově připojeny na základě stejných
identických bodů.

Obrázek 6.61: Zvolíme typ dat (7), který budeme to skupiny přidávat - rastrová či vektorová data, dále
zvolíme mapset (8), ze které bude tato data volit a nakonec zvolíme data (9).

Obrázek 6.62: Vytvoření skupiny potvrdíme (10).
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Obrázek 6.63: Přejdeme na poslední dialog (11).

Obrázek 6.64: Tam zvolíme z cílové (aktuální lokace) rastrovou či vektorovou mapu (12), kterou chceme
použít jako referenci pro souřadnicové připojení a průvodce ukončíme (13).

Následně na to se objeví okno GCP Manageru s rastrovou či vektorovou mapou určenou k souřadnicovému
připojení vlevo a referenční rastrovou či vektorovou mapu vpravo. Začneme volit identické body (Ground
Control Points) nejprve ve zdrojové lokaci (vlevo) a poté v cílové lokaci (vpravo).

Výběr identických bodů probíhá následovně:

Obrázek 6.65: Z nástrojové lišty vybere nástroj definice identických bodů (1), zvolíme číslo identického
bodu, který chceme definovat (2) a jeho pozici nejprve ve zdrojové (3) a poté v cílové lokaci (4).
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Obrázek 6.66: Takto postupně zvolíme první tři identické body.

Obrázek 6.67: Další identické body můžeme přidat z nástrojové lišty.

Obrázek 6.68: Pokud nejsou identické body aktivovány, tak je nejprve aktivujeme (1) a poté nastavíme
vlastnosti souřadnicového připojení (2).
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V dialogu nastavení:

Obrázek 6.69: V záložce Rectification nastavíme stupeň polynomické interpolace (1) a metodu pro převzor-
kování rastru (2) - obecně lze říci, že pro kategorizovaná data (např. geologická mapa) je vhodná metoda
nejbližšího souseda (nearest), pro data jako je digitální model reliéfu naopak lineární interpolace (linear) či
kubická konvoluce (cubic).

Před vlastním souřadnicovým připojení můžeme spočíst na základě identických bodů tzv. RMS chybu a na
jejím základě vyřadit nebo naopak přidat nové identické body.

Poznámka: Střední kvadratická (RMS) chyba by neměla přesáhnout polovinu rozlišení hodnoty cílové
lokace.

Obrázek 6.70: Střední kvadratická (RMS) chyba.

Obrázek 6.71: Vlastní výpočet spustíme pomocí funkce Georecify dostupnou z nástrojové lišty.
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Obrázek 6.72: Souřadnicově připojená rastrová či vektorovou mapu přidáme do správce vrstev.

Obrázek 6.73: A zobrazíme společně s dalšími mapovými vrstvami v mapovém okně.
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KAPITOLA 7

Mapové výstupy

7.1 Mapové elementy

Do mapové okna lze přidat základní mapové elementy jako je legenda, směrová růžice, měřítko či textový
popis. Tato funkcionalita je dostupná z nástrojové lišky mapového okna.

Obrázek 7.1: Mapové elementy.

Poznámka: Mapové okno není určeno pro tvorbu plnohodnotných mapových výstupů. K tomuto účelu je
určen Cartographic Composer, více v kapitole mapové výstupy.

7.1.1 Legenda

Legendu pro rastrová data lze do mapového okna přidat z jeho nástroje lišty:

Obrázek 7.2: Přidání legendy do mapového okna.
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Obrázek 7.3: Pokud je ve správci vrstev aktuálně vybraná rastrová mapa, tak se automaticky legenda zobrazí
pro ni.

V opačném případě se zobrazí dialog pro výběr rastrové mapy, pro kterou si přejete legendu zobrazit.

Obrázek 7.4: Vybereme rastrovou mapu pro kterou chceme legendu zobrazit (1) a nastavení potvrdíme (2).

Legendu můžete v mapovém okně skrýt bud’ z nástorové lišty anebo z kontextového menu legendy (pravé
tlačítko myši nad legendou):

Obrázek 7.5: Skrytí legendy.

Z tohoto menu lze také změnit velikost legendy i její orientaci.
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Obrázek 7.6: Změna velikosti legendy.

Obrázek 7.7: Příklad změněné orientace legendy.

Vlatnosti legendy můžeme změnit z dialogu modulu d.legend dostupného pomocí dvojkliku nad legendou
umístěnou v mapovém okně.

Obrázek 7.8: Přiklad změny legendy - otočení škály.

Obrázek 7.9: Výsledek otočení škály legendy.

Poznámka: Legendu v současnosti lze definonat pouze pro rastrová data, legenda pro vektorové mapy
není modulem d.legend podporována. Tato funkcionalita je plánovana pro další verze systému GRASS.
Legendu pro vektorové mapy lze nicméně definovat v aplikaci Cartographic Composer, více v kapitole
mapové výstupy.
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Tip: Pokud se popisky legenda nezobrazují korektně, je potřeba změnit font legendy.

Obrázek 7.10: Chybně vykreslená legenda.

Písmo změníme v dialogu nastavení dostupného z menu Settings → Preferences anebo z nástrojové lišty
správce vrstev.

Obrázek 7.11: Nastavení GUI systému GRASS.

Obrázek 7.12: V záložce Map display zvolíme vhodný font.

Obrázek 7.13: Kromě fontu (1) změníme kodóvání na UTF-8 (2).

Obrázek 7.14: Obsah mapové okna překreslíme.
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Obrázek 7.15: Výsledek.

7.1.2 Směrová růžice

Směrovou růžici lze do mapového okna přidat z jeho nástroje lišty:

Obrázek 7.16: Přidání směrové růžice do mapového okna.

Do mapové okna se umístí výchozí směrová růžice:

Obrázek 7.17: Příklad směrové růžice.

Podobu směrové růřice lze změnit z dialogu modulu d.northarrow přes dvojklik nad směrovou růžicí umís-
těnou v mapovém okně.

Obrázek 7.18: Příklad změny stylu směrové růžice.
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Obrázek 7.19: Výsledek změny stylu směrové růžice.

Směrovou růžici můžete v mapovém okně skrýt bud’ z nástorové lišty anebo z kontextového menu směrové
růžice (pravé tlačítko myši nad směrovou růžicí):

Obrázek 7.20: Skrytí směrové růžice.

7.1.3 Měřítko

Měřítko lze do mapového okna přidat z jeho nástroje lišty:

Obrázek 7.21: Přidání měřítka do mapového okna.

Do mapové okna se umístí výchozí měřitko:

Obrázek 7.22: Vychozí měřítko.

Podobu měřítka lze změnit z dialogu modulu d.barscale přes dvojklik nad měřítkem umístěným v mapovém
okně.
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Obrázek 7.23: Příklad změny stylu měřítka.

Obrázek 7.24: Výsledek změny stylu měřítka.

Měřítko můžete v mapovém okně skrýt bud’ z nástorové lišty anebo z kontextového menu měřítka (pravé
tlačítko myši nad měřítkem):

Obrázek 7.25: Skrytí měřítka.

7.1.4 Textový popisek

Textový popisek lze do mapového okna přidat z jeho nástroje lišty:

Obrázek 7.26: Přidání textového popisku do mapového okna.

V následující dialogu uvedeme text a případně můžeme změnit i vlastnosti textového objektu.

Obrázek 7.27: Po nastavení textu (1) můžeme nastavit rotaci či styl písma (2).

7.1. Mapové elementy 131



Školení GRASS GIS pro začátečníky, verze 1.1.0

Obrázek 7.28: Příklad textového popisku v mapovém okně.

Popisek lze skrýt opět pomocí výše uvedeného dialogu přes dvojklik nad daným textovým objektem v
mapovém okně.

Obrázek 7.29: Odstranění textového popisku z mapového okna.

7.2 Tvorba mapových výstupů

Pro tvorbu kvalitních mapových výstupů je určen grafický nástroj Cartographic Composer dostupný z menu
File → Cartographic Composer anebo z nástrojové lišty správce vrstev.

Poznámka: Jde o samostatnou aplikaci, která nesouvisí s aktuální obsahem mapového okna. Všechny
vrstvy, které chceme, aby byly součástí mapového výstupu, je třeba přidat do aplikace ručně.

7.2.1 Ukázky

YouTube – Definice mapového rámce, přidání rastrových a vektorových dat
http://www.youtube.com/embed/ZMwuC14omyA

YouTube – Načtení kompozice ze souboru, přidání textového popisku, měřítka,legendy pro rastrová
a vektorová data
http://www.youtube.com/embed/s0gYrGuzzpo
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Obrázek 7.30: GUI pro tvorbu mapových výstupů

YouTube – Přidání směrové růžice
http://www.youtube.com/embed/XKXtwoMh6Kk

YouTube – Přidání legendy
http://www.youtube.com/embed/8o5cRyH3hb8
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KAPITOLA 8

Různé

8.1 Grafický modeler

Grafický modeler je interaktivní nástroj, který umožňuje grafickou formou modelovat geoprostorové analýzy
v systému GRASS.

Nástroj lze spustit z menu File → Graphical modeler nebo z nástrojové lišty správce vrstev.

Obrázek 8.1: Spuštění grafického modeleru z nástrojové lišty správce vrstev.

Spuštění grafického modeleru z příkazové řádky

Grafický modeler je dostupný z příkazové řádky jako modul g.gui.gmodeler.

g.gui.gmodeler

Obrázek 8.2: Příklad modelu pro výpočet obalové zóny kolem dálnic.
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8.1.1 Ukázky

YouTube – Příklad modelu neřízené klasifikace družicových dat
http://www.youtube.com/embed/0jkO-ih87mw

Další názorná videa na stránkách wiki projektu GRASS.

8.2 Lokalizace

GRASS GIS je lokalizován alespoň částečně do více než 20 jazyků. Statistiku pro jednotlivé jazyky získáte
z menu Help → About GRASS GIS v záložce Translation status .

Obrázek 8.3: Stav lokalizace do češtiny.

Poznámka pro pokročilé

"Fuzzy"označuje překlad, který již neodpovídá původní zprávě programu a musí být aktualizován.

8.2.1 Volba lokalizace

GRASS nastartuje automaticky v lokalizaci odpovídající danému operačnímu systému.

136 Kapitola 8. Různé
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Obrázek 8.4: GRASS lokalizovaný do češtiny pro MS Windows.

Lokalizaci je možné změnit v nastavení GUI systému GRASS Settings → Preferences v záložce
Appearance 1.

Obrázek 8.5: Změna lokalizace uživatelského rozhraní systému GRASS na angličtinu.

Systém GRASS po uložení nastavení a opětovném spuštění (změna jazyka se tedy neprojeví ihned) již
nastartuje ve zvolené lokalizaci.

1 V české lokalizaci jde o Nastavení → Vlastnosti, záložka Vzhled .
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Obrázek 8.6: Příklad uvítací obrazovky systému GRASS v angličtině.

Obrázek 8.7: Příklad uvítací obrazovky systému GRASS v němčině.
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KAPITOLA 9

Dodatky

9.1 Související materiály

Česky:

• Školení GRASS GIS na Les-ejk.cz

• GRASS GIS na portálu FreeGIS

Slovensky:

• GRASS GIS pre geovedné aplikácie

Anglicky:

• Dokumentace systému GRASS 7.0

Literatura:

• Open Source GIS: A GRASS GIS Approach (anglicky)

• GIS GRASS - Praktická rukovět’ (česky, velmi zastaralé)

9.2 Technická podpora

• (česky) Mailing list FreeGeoCZ (obecně Open Source GIS, nikoliv pouze GRASS),
http://mailman.fsv.cvut.cz/mailman/listinfo/freegeocz

• (anglicky) Mezinárodní mailing list projektu GRASS GIS (zajímavostí je archiv sahající až do roku
1991!), http://lists.osgeo.org/mailman/listinfo/grass-user
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9.3 Užitečné odkazy

• http://freegis.fsv.cvut.cz

• http://epsg.io

9.4 O dokumentu

Text dokumentu je licencován pod Creative Commons Attribution-ShareAlike 4.0 International License.

Verze textu dokumentu: 1.1.0 (sestaveno 27.11.2015)

9.4.1 Autoři

Za GISMentors:

• Martin Landa <martin.landa opengeolabs.cz>

• Jáchym Čepický <jachym.cepicky opengeolabs.cz>

9.4.2 Text dokumentu

Online HTML verze textu školení je dostupná na adrese:

• http://training.gismentors.eu/grass-gis-zacatecnik/

Zdrojové texty školení jsou dostupné na adrese:

• https://github.com/GISMentors/grass-gis-zacatecnik
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g.region, 32
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měřítko

mapové elementy, 130
mapová algebra, viz r.mapcalc

algebra, 65
mapové elementy, 125

legenda, 125
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směrová růžice, 129
textový popisek, 131

mapové okno, 16
mapové výstupy

tisk, 132
MAPSET, 14
mapsety, viz lokace, viz MAPSET

struktura dat, 14
maska, viz r.mask, 54
merge, 84
metadata

rastrová data, 25
vektorová data, 28

moduly, 21
nápověda, 24

MS Windows, viz Instalace, 5

N
nápověda

moduly, 24
nejkratší cesta, viz sít’ové analýzy

shortest path, 91

O
obalová zóna

buffer, 81
obrázek

export, 104
open source

free software, 1
orientace svahu

analýza povrchu, 61
expozice, 61

OSGeo4W, viz Instalace, 8

P
překlad

lokalizace, 136
přenos dat

rastrová data, 105
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vektorová data, 105
patch, 84
PNG, 104
popisná data, viz atributy, 30

editace, 86
PostgreSQL, 30
proměnná prostředí

GISDBASE, 14
LOCATION_NAME, 14
MAPSET, 14
SHAPE_ENCODING, 101

prostorové dotazy
dotazování, 46

prostorové funkce, viz v.extract, viz v.buffer, viz
v.overlay, viz v.patch

vektorová data, 80
prostorové rozlišení

rozlišení, 32
ps.map, 132

R
r.category, 70
r.colors, 57
r.cost, 71
r.drain, 71
r.in.gdal, 95
r.info, 25
r.mapcalc, 65
r.mask, 54
r.out.gdal, 102
r.pack, 105
r.proj, 115
r.reclass, 67
r.recode, 68
r.report, 49
r.slope.aspect, 60
r.stats, 52
r.univar, 51
r.viewshed, 64
rastrová algebra

algebra, 65
rastrová data, 25

analýza nákladů, 71
datové typy, 26
export, 102
georerefencování, 118
import, 95
metadata, 25

přenos dat, 105
reklasifikace, 67
statistika, 49
tabulka barev, 57
zobrazení dat, 17

region
import, 101
výpočetní region, 32

reklasifikace, viz r.reclass, viz r.recode
data s plovoucí desetinnou čárkou, 68
rastrová data, 67

rozlišení
prostorové rozlišení, 32

S
S-JTSK, 108
sít’ové analýzy

vektorová data, 91
SHAPE_ENCODING, 101
shortest path

nejkratší cesta, 91
směrová růžice

mapové elementy, 129
souřadnicové systémy, 115
správce vrstev, 16
SQL, 41
SQL builder, 41
SQLite, 30
statistika

rastrová data, 49
struktura dat

lokace, 14
mapsety, 14
vyhledávací cesta, 15

T
tabulka barev, viz r.colors

rastrová data, 57
textový popisek

mapové elementy, 131
tisk, viz g.gui.psmap

mapové výstupy, 132
topologické chyby

topologie, 84
topologie, 28, viz v.clean

import, 99
topologické chyby, 84
vektorová data, 28
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transformace
geodata, 115

U
Ubuntu, viz Instalace, 4
union, 81
Unix, 3

V
v.buffer, 81
v.clean, 84
v.db.execute, 86
v.edit, 77
v.extract, 80
v.in.ogr, 97
v.info, 28
v.out.ogr, 103
v.overlay, 81
v.pack, 105
v.patch, 84
v.proj, 115
v.select, 46
v.to.db, 86
výpočetní region

region, 32
vektorová data, 27

editace, 77
export, 103
georeferencování, 118
import, 97
metadata, 28
přenos dat, 105
prostorové funkce, 80
sít’ové analýzy, 91
topologie, 28
zobrazení dat, 19

viditelnost
analýza povrchu, 64
viewshed, 64

viewshed
viditelnost, 64

vyhledávací cesta
struktura dat, 15

Z
zobrazení dat

rastrová data, 17
vektorová data, 19
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