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1. Sběr dat
Během sběru dat bude vytvořen dataset  
kvalitních snímků vhodných pro fotogrammetrické 
zpracování. V kapitole jsou uvedeny tipy
a doporučení pro snímání modelu.

2. Bodová fáze
V bodové fázi bude z pořízeného datasetu 

vygenerováno husté mračno bodů, oříznuto
na oblast zájmu a zbaveno chyb, které by 

znemožňovaly a komplikovaly další zpracování.

4. Texturování
Cílem texturování je vytvořit a barevně 

upravit texturu modelu. Tento krok je 
volitelný. Odvíjí se od technologie  tisku 

a požadavků autora modelu.

6. Tisk
Výsledkem 3D tisku je vytištěný fyzický 

model. Postup se odvíjí od použité 
technologie, výrobce a typu tiskárny. Popis 

tisku modelu již není součástí návodu. 

3. Polygonová fáze
Během polygonové fáze bude z mračna bodů 
vytvořena polygonová síť, opraveny její chyby, 
proběhne tvarování objektu, úprava topologie
a v posledním kroku bude vymodelována podstava.

5. Předtisková příprava
Předtisková příprava je finální fází přípravy modelu. 
Již hotový 3D model bude kompletně připraven na 
plnohodnotný tisk. Součástí této fáze je generování 
tiskového kódu a příprava tiskárny.
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software
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Agisoft Metashape
Komplexní komerční software určený 

k fotogrammetrickému zpracování 
snímků a generování prostorových dat.

CloudCompare
Open-source software především pro 
zpracování mračna bodů a základní 

editaci polygonové sítě.

MeshLab
Open-source software umožňující 

pokročilou editaci, čištění, opravování a 
kontrolování polygonové sítě.

Autodesk Meshmixer
Volně stažitelný moderní software pro 

čištění, opravu a tvarování polygonové sítě. 
Hlavní předností je intuitivní GUI.

Instant Meshes
Jednoduchý otevřený software pro 

retopogii polygonové sítě. Umožňuje 
určit směr toku polygonů a jejich tvar.

Blender
Komplexní open-source software 

podporující modelování, animování, 
texturování, renderování a mnoho dalších.

GIMP
Free and open-souce grafický 

editor. Umožňuje pracovat 
s rastrovou i vektorovou grafikokou.

Ultimaker Cura
Volně stažitelný software pro 

předtiskovou přípravu 3D modelu. 
Generuje tiskový kód.



doporučení
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Průběžně ukládejte1 V závislosti na výkonnosti používané PC 
sestavy se některé softwary mohou při 
nastavení enormních hodnot parametrů a při 
některých funkcích potýkat s nestabilitou. 
Aby nedošlo ke ztrátě modelu, je vhodné 
projekty průběžně ukládat.

Udržujte pořádek2 Během zpracování bude uloženo větší množství 
modelů. Pro lepší orientaci je doporučeno 
ukládané soubory v názvu krokovat (například 
název prvního modelu 01_mujprojekt-dense-cloud, 
název druhého 02_mujprojekt-denoised, název 
třetího 03_mujprojekt-lowpoly atd.)

Ortografická projekce3 Pro účely zpracování a úprav mračna bodů
i polygonové sítě je výhodné pracovat v ortografické 
projekci. Zamezí se tak zkreslení úhlů vznikajícímu 
při perspektivní projekci. Přepnutí do ortgrafické 
projekce je vhodné především při obdélníkovém 
výběru bodů i polygonů.

Nápověda k softwaru4 Před použitím softwaru je vhodné se zběžně 
zorientovat v GUI a osvojit si základní ovládání. 
Jedná se především o nástroje rotace, posun
a přiblížení. V různých softwarech se ovládání liší, 
většinou se jedná o tlačítka myši, případně
v kombinaci s klávesovou zkratkou.
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snímky
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Hlavním cílem při sběru dat je nasnímat objekt tak, aby byl libovolný bod na jeho povrchu vidět 
na dostatečném množství pořízených snímků.  Čím více snímků tento bod obsahuje, tím větší
je pravděpodobnost výpočtu jeho přesné prostorové polohy. Proto je hlavním faktorem při tvorbě 
modelu dostatečný počet kvalitních snímků s velkým překryvem.

Princip

Počet snímků je dán složitostí snímaného objektu a úrovní detailu, které chceme při rekonstrukci 
dosáhnout. Pro jednoduché objekty je referenční hodnotou počet 40-50 snímků. Vždy je však 
vhodné pořídit větší množství než dostačující a počet případně redukovat. 

Počet

Kvalitou snímků se myslí především jejich ostrost a rozlišení. Cílem je zamezit smazu vzniklým 
pohybem objektu ve snímané scéně i pohybem kamery. Rozmazané snímky z datasetu odstraňte. 

Kvalita

Čím vyšší je rozlišení snímku, tím více prvků a detailů je software při zarovnání schopen identifikovat 
a rekonstruovat. Doporučené rozlišení je minimálně 5 Mpx. Horní hranice není stanovena.

Rozlišení



scéna a objekt
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Denní doba nebo sluneční svit mohou výrazně ovlivnit kvalitu a použitelnost pořízených snímků.
Je vhodné snímat během zataženého dne, kdy je světlo difúzního charakteru a objekt je osvětlen 
rovnoměrně. Za přímého osvětlení vznikají ostré stíny a tmavá, expozičně neřešitelná místa,
což je pro rekonstrukci mračna z fotogrammetrických dat nežádoucí. 

Světelné podmínky

Překážkou pro snímání objektu mohou být vlastnosti jeho povrchu. Mezi těžko snímatelné 
povrchy se řadí vysoce odrazivé materiály (např. karoserie auta), průhledné materiály (např. sklo), 
netexturované materiály (např. jednobarevná zeď) nebo příliš repetitivně texturované
(např. cihlová zeď). 

Povrch objektu

Není vhodné snímat pohybující se a příliš komplexní objekty (např. koruna stromu)

Špatně snímatelné objekty

Ideální vlastnosti povrchů mají například kameny, kmeny stromů, sochy nebo budovy. 

Ideální objekty



plán snímání
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Před snímáním je vhodné alespoň zběžně naplánovat scénář snímání a osy záběrů. 
Snímky pořizujte v eliptických drahách okolo modelu ve více vertikálních rovinách.
Není žádoucí objekt snímat ze stacionárního bodu pouze změnou úhlu záběru. 

Letový plán / osy záběru

Bod na modelu, který není vidět minimálně na dvou snímcích, nelze rekonstruovat.
Proto vždy dodržujte dostatečný překryv snímků a to minimálně 60 %. 

Překryv

V případě snímání komplexní části k ní přistupujte jako k samostatnému objektu
a snímky pořizujte z různých úhlů a v dostatečném množství a překryvu.

Komplexní části





bodová fáze

10

Cílem bodové fáze je z fotogrammetricky pořízených dat 
připravit mračno bodů. Nejprve budou určeny prostorové 
polohy kamer (tzv. zarovnání snímků). S tímto krokem bude 
zároveň vytvořeno řídké mračno bodů (sparse cloud).

Zarovnání snímků1
Ze zarovnaných snímků lze pro libovolný bod určit jeho 
polohu v prostoru (za předpokladu, že je tento bod 
viditelný alespoň na dvou různých snímcích). Takových 
bodů je výpočetní algoritmus schopen určit nespočetně
(v závislosti na hloubce rekonstrukce). Všechny takto určené 
body dohromady dávají husté mračno bodů (dense cloud). 

Generování mračna 2
Vytvořené mračno je zpravidla náhodně orientováno.
Pro další zpracování je vhodné orientovat ho tak, aby osy 
objektu odpovídaly osám X, Y a Z. 

Zarovnání mračna 3

Fotogrammetrické softwary běžně generují mračno bodů 
větší, než je snímaný objekt. Proto bude třeba mračno 
ořezat na požadovanou oblast. Současně s tímto krokem 
budou odstraněny i hrubé chyby (např. body volně
v prostoru). 

Ořezání mračna 4
V posledním kroku bodové fáze bude odstraněn 
tzv. šum (tj. body, které jsou nepatrně odchýleny 
od své skutečné polohy). Šum je poměrně relativní 
a způsob jeho odstranění je specifický pro každý model.

Denoising5



zarovnání snímků
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Zarovnání snímků a generování hustého mračna bodů probíhá
v softwaru Agisoft Metashape.

Software

V záložce Workflow > Add Photos přidejte všechny snímky, které 
mají být při rekonstrukci použity. Pomocí Workflow > Add Folder 
lze přidat všechny snímky ze zvolené složky přímo.

Přidání snímků

Pro zarovnání snímků pokračujte v záložce Workflow > Align 
Photos. Tímto krokem budou určeny polohy a orientace kamer.

Zarovnání

Položku Accuracy nastavte v závislosti na požadované přesnosti 
umístění kamer. Pro dosažení kvalitních výsledků použijte 
nastavení Medium a vyšší (doporučeno High). Ostatní položky 
ponechejte ve výchozím nastavení.

Nastavení

Po provedení výpočtu se zobrazí řídké mračno bodů a polohy 
kamer. Pokud se kamery nezobrazí, náhled aktivujte v horní liště 
pomocí ikony Show Cameras.

Náhled kamer

V závislosti na kvalitě datasetu může nastat situace, kdy nebudou 
zarovnány všechny snímky. Pokud není zarovnáno více než 10 % 
snímků, proces opakujte s nastavením nižší přesnosti.

Řešení problémů



generování mračna
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Pro generování hustého mračna bodů pokračujte v záložce 
Workflow > Build Dense Cloud.

Husté mračno

Parametr Quality určuje úroveň detailů a geometrickou 
přesnost mračna (doporučeno Medium až High). Ostatní 
nastavení ponechejte výchozí.

Kvalita

Generování hustého mračna bodů je výpočetně náročný krok. Doba 
rekonstrukce se odvíjí od počtu snímků, nastavené úrovně kvality 
rekonstrukce a konfigurace počítače. Celková doba výpočtu běžně 
přesahuje 30 minut. Po tuto dobu je procesor počítače plně vytížen. 

Výpočetní náročnost

Po provedení výpočtu mračno exportujte v záložce File > Export > 
Export Points (doporučený formát PLY). V nabídce exportu jako 
souřadnicový systém zvolte Local Coordinates. Jako zdrojová data 
použijte Dense Cloud. 

Export mračna

Důležitým krokem je exportovat mračno včetně normál bodů 
(Point Normals). Bez normál nelze provést rekonstrukci povrchu 
modelu. Zahrnutí barev bodů (Point colors) může vizuálně pomoci 
při dalším zpracování, ale pro rekonstrukci není nezbytně nutné.

Normály



zarovnání mračna
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Zarovnání, ořezání a odstranění šumu mračna probíhá 
v softwaru CloudCompare.

Software

Dříve vytvořené mračno nahrajte pomocí záložky File > Open 
a zvolte soubor. Mračno bodů se zobrazí v náhledu. 

Import

V případě, že mračno není stínované, označte jej v databázovém 
stromu (DB Tree) a v nastavení (Properties) aktivujte náhled 
normál (Normals). Rovněž je doporučeno zvětšit velikost bodů 
(Point size) tak, aby byly jednotlivé body v náhledu jasně zřetelné 
(např. velikost 3). Zamezí se tak případnému přehlédnutí 
chybného bodu. 

Nastavení náhledu

Prvním krokem k zarovnání je posunout mračno na počátek souřadnicového systému. V záložce 
Edit > Edit global shift and scale manuálně nastavte posun tak, aby v tabulce Point in original 
coordinate systém byly všechny souřadnice rovny 0. Nastavení Scale ponechte na hodnotě 1.

Posun mračna

Dalším krokem je orientovat mračno tak, aby svou orientací prostorově odpovídalo skutečnosti. 
Tuto akci lze jednoduše provést funkcí Pick three points to make cloud or mesh ’level’ (v levé 
postranní liště). Funkcí zvolíte tři různé body mračna, které mají být zarovnány vodorovně (stejná 
souřadnice Z). První dva zvolené body určují osu X. Pečlivým výběrem těchto bodů lze zarovnat 
mračno ve všech osách. Na základě zvolených bodů bude vyrovnán zbytek mračna. 

Rotace mračna



ořezání mračna
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Ořez mračna se skládá ze dvou kroků – ořez na požadovanou oblast rekonstrukce a ořez 
hrubých chyb. Oba kroky budou provedeny stejným nástrojem.

Body k odstranění

Pro ořez na požadovanou oblast v levé postranní liště aktivujte ortografickou projekci 
(Ortographic projection) a vrchní náhled (Set top view). Ořez bude proveden nástrojem 
Segment (horní lišta). V nástroji zvolte obdélníkový výběr a vyberte body, které mají být 
zachovány. Okolo objektu je vhodné ponechat rezervu. Ořez proveďte příkazem Segment In. 

Oblast zájmu

Ořez hrubých chyb bude taktéž proveden nástrojem Segment. Mezi tyto chyby se řadí 
body umístěné volně v prostoru a body znatelně chybně vygenerované. Pro 
odstranění použijte opačný postup – výběr chybných bodů a odstranění nástrojem 
Segment Out. Pro tento postup je vhodné používat polygonální výběr a dle potřeby 
rotovat náhled okolo objektu. Pro rotaci lze nástroj pozastavit stiskem mezerníku.

Hrubé chyby

Pro dokončení operace ořez potvrďte nástrojem Confirm and delete hidden points. 
Potvrzení segmentace



denoising
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K denoisingu, neboli odstranění šumu, budou použity nástroje Noise Filter a SOR Filter.

Filtry

Pro nástroj Noise Filter v záložce Tools > Clean zvolte položku Noise Filter. Algoritmus 
pro každý bod z mračna vybere nejbližší přilehlé body, kterými proloží rovinu. V případě, 
že je daný bod od této roviny příliš vzdálen, je považován za šum a odstraněn. Pro 
fotogrammetricky pořízená mračna je vhodné volit způsob výběru Radius (Sphere). 
Vždy volte možnost Remove isolated points. Tato funkce odstraní osamocené body.

Noise Filter

Nástroj SOR Filter (Statistical Outlier Removal) se rovněž nachází v záložce 
Tools > Clean. Algoritmus pro každý bod vypočítá průměrnou vzdálenost ke každému 
z nejbližších sousedících bodů (počet sousedících bodů udává první parametr). 
Jako šum vyhodnotí všechny body, které jsou dál než průměrná vzdálenost plus 
n-násobek směrodatné odchylky (druhý parametr).

SOR Filter

U obou nástrojů nelze obecně stanovit optimální hodnoty parametrů. Jejich 
nastavení je specifické pro konkrétní mračno bodů a do jisté míry experimentální. 
Dobrých výsledků lze dosáhnout i za použití výchozích hodnot.

Nastavení

Upravené mračno bodů exportujte v záložce File > Save (doporučený formát PLY).
Export





polygonová fáze
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Prvním krokem je z mračna bodů vytvořit primární 
polygonovou síť. K rekonstrukci je třeba využít vhodného 
algoritmu a zvolit takovou hloubku rekonstrukce, aby 
byl zachován detail o požadované úrovni.

Rekonstrukce sítě1
V závislosti na hloubce rekonstrukce se síť často skládá 
z nadbytečného počtu polygonů. Pro další zpracování je 
třeba tento počet redukovat na minimum, a to 
s ohledem na největší možnou míru zachování detailu. 

Redukce polygonů2
Primárně vytvořená síť obsahuje velké množství 
topologických chyb, které by znemožňovaly další 
úpravy modelu. Je nezbytné tyto chyby opravit. Tento 
krok probíhá automaticky.

Globální editace3
Dále je třeba opravit ty části sítě, která byly tvarově 
chybně rekonstruovány nebo by nebylo možné 
je vytisknout. Tento krok je třeba provést manuálně. 

Odstranění zbytkových chyb4

Během tvarování probíhá manuální úprava polygonové sítě. 
Tento krok zahrnuje opravu špatně rekonstruovaných částí, 
vyhlazování sítě a případné přidávání vlastních prvků. Způsob 
tvarování je specifický pro konkrétní model.

Tvarování5
V oblasti 3D modelování je vždy výhodnější kontrolovat topologii 
(tvar a velikost polygonů, směr toku polygonů…). Špatná topologie 
vede ke vzniku artefaktů způsobujících problémy při tisku. Bude 
vytvořena kompletně nová topologie (provedena tzv. retopogie).

Retopologie6
Posledním krokem polygonové fáze je modelování podstavy 
objektu. Jedná se o pokročilejší operaci, volitelnou, nicméně 
doporučenou. Podstava slouží jako základna modelu při tisku 
a má estetický význam.

Podstava7



rekonstrukce sítě
Tvorba a část editace polygonové sítě probíhá v softwaru MeshLab.
Software

V záložce File > Import Mesh nahrajte upravené mračno bodů.
Import mračna

V záložce Filters > Remeshing, Simplification and Reconstruction zvolte 
Screened Poisson Surface Reconstruction. Tento algorimus je v oblasti 
rekonstrukce sítě z mračna bodů obecně považován za nejlepší.

Algoritmus

Stěžejní parametr algoritmu je hloubka rekonstrukce (Reconstruction 
Depth) udávající stupeň detailu, kterého má být dosaženo. S úrovní 
detailu však roste počet polygonů vytvořené sítě. Příliš mnoho polygonů 
je z hlediska výpočetní i zobrazovací náročnosti nežádoucí. Optimální 
hodnota hloubky je 8 až 10. Je vhodné s hodnotou experimentovat 
a zvolit výsledek zachycující úroveň požadovaného detailu při zachování 
minimálního počtu polygonů.

Hloubka rekonstrukce

Dále zvolte možnost Pre-Clean. Tato funkce aktivuje předčištění 
mračna a odstraní body nevhodné pro zahrnutí do výpočtu.

Pre-clean

Ostatní nastavení ponechte výchozí a nástroj spusťte. 
Další nastavení
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redukce polygonů
Náhled hran polygonové sítě lze aktivovat v okně vrstev akcí Wireframe.
Wireframe

Vytvořená polygonová síť se často skládá z více polygonů, než je pro dosažení 
požadovaného detailu třeba a pro další zpracování je vhodné jejich počet redukovat. 
Nástroj je destruktivní a nevratný. Vytvořenou polygonovou síť před redukcí uložte.

Redukce

V záložce Filters > Remeshing, Simplification and Reconstruction
zvolte Simplification: Quadric Edge Collapse Decimation.

Algoritmus

Cílový počet polygonů (Target number of faces) je hodnota specifická pro 
daný objekt. Referenční hodnotou je 20 % původního počtu polygonů. 
Hodnotu upravte dle potřeby a opět vyberte výsledek zachycující úroveň 
požadovaného detailu při zachování minimálního počtu polygonů.

Počet polygonů

Dále zvolte následující parametry: Quality threshold: 1; Preserve 
Boundary of the mesh; Preserve Normal; Planar Simplification. 
Ostatní nastavení ponechte výchozí a nástroj spusťte.

Další nastavení

V případě potřeby opakování nástroje s jiným nastavením aktuální 
vrstvu odstraňte a v záložce File > Import Mesh nahrajte dříve uloženou.

Řešení problémů
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globální editace
Redukovaná polygonová síť obsahuje množství, na první pohled neviditelných, 
topologických chyb. Cílem globální editace je hromadně tyto chyby odstranit.

Chyby

V záložce Filters > Cleaning and Repairing postupně proveďte tyto příkazy:

 1. Merge Close Vertices

 2. Remove Duplicate Faces

 3. Remove Faces from Non Manifold Edges

 4. Remove Isolated Folded Faces by Edge Flip

 5. Remove Unreferenced Vertices

 6. Remove Zero Area Faces

 7. Select Self Intersecting Faces (pouze provede výběr)

   > odstraňte v záložce Filters > Selection > Delete Selected Faces 

 8. Select Non Manifold Vertices (pouze provede výběr)

   > odstraňte v záložce Filters > Selection > Delete Selected Vertices 

Příkazy

Upravenou polygonovou síť exportujte v záložce File > Export Mesh 
As (doporučený formát OBJ). Zachovejte normály.

Export
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odstranění zbytkových chyb
Odstranění zbytkových chyb a tvarování probíhá v softwaru Autodesk Meshmixer.
Software

V záložce File > Import nahrajte upravenou polygonovou síť.
Import

V levé postranní liště zvolte Analysis > Inspector. Nástroj je schopen rozpoznat a opravit 
tři typy chyb. Každá chyba je označena koulí. Klikem na kouli bude chyba automaticky 
opravena. Barva koule identifikuje typ chyby:

 1. Modrá – díra v polygonové síti (model není tzv. vodotěsný – nelze vytisknout)

 2. Červená – hranu sdílí 3 a více polygonů (ang. non-manifold) – nežádoucí 

 3. Purpurová – oddělená součást (většinou se jedná o malé nepotřebné části sítě)

Nástroj Inspector

Neopravujte díru na spodní straně objektu (modrá koule). Chyba bude později 
manuálně odstraněna při modelování podstavy modelu. Všechny ostatní chyby odstraňte.

Odstranění

Může nastat případ, kdy opravená chyba vyvolá další chybu. Proto nástroj Inspector 
proveďte v několika iteracích a postup opakujte, dokud nebudou všechny chyby odstraněny. 

Vyvolané chyby
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tvarování
Pojmem tvarování se myslí manuální odstranění všech lokálních vad sítě. Cílem je dotvarovat 
síť podle potřeby a specifik konkrétního objektu. Pro tento krok nelze stanovit obecný postup 
nebo návod. Jedná se o odstranění těchto chyb:

 1. Kompletně zdeformovanou část sítě, kterou předchozími kroky nebylo možné opravit

 2. Část sítě, kterou není možné vytisknout nebo nemá být vytištěna

 3. Vyhlazení ploch

 4. Další modelování a manuální zásahy

Chyby

Je doporučeno používat nástroj Sculpt a to především štětce Drag, Flattern a Bubble 
Smooth. Sílu a velikost nastavujte podle potřeby. Je vhodné pracovat i s funkcí Refinement.
V případě použití této funkce pracujte s klávesovou zkratkou W (pro zobrazení hran sítě). 
Snažte se docílit konstantní velikosti polygonů.

Nástroje

V případě kompletně zdeformované části sítě je vhodné celou tuto část nástrojem Select 
vybrat, klávesou Delete odstranit a pomocí dříve použitého nástroje Inspector díru vyplnit. 
Podobně postupujte v případě odstranění částí, které nemohou nebo nemají být vytištěny.

Kompletní deformace

Na polygonové síti se může projevit zbytkový šum, patrný především na původně rovných 
plochách. Vhodným nástrojem pro shlazení je štětec Flattern.

Zbytkový šum

Vytvarovanou síť exportujte v záložce File > Export (doporučený formát OBJ).
Export
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retopologie
Cílem retopologie je vytvořit síť o požadovaném tvaru a velikosti polygonů. 
Retopologií rovněž lze kontrolovat počet polygonů a směr jejich toku. 

Retopologie

Tento krok bude proveden v softwaru Instant Meshes.
Software

V záložce Open mesh > PLY, OBJ nahrajte vytvarovanou síť.
Import

Nastavení Remesh as zvolte Quads 4/4. V nastavení Configuration details zvolte Align 
to boundaries. Target vertex count určuje výsledný počet polygonů. Hodnotu nastavte 
dle potřeb konkrétního objektu. Referenční hodnotou je 100 až 200 tisíc. 

Nastavení

V sekci Orientation Field zvolte Solve, poté v sekci Position Field opět zvolte Solve. 
Po dokončení výpočtu pokračujte v záložce Export mesh > Extract mesh.

Provedení retopologie

Topologicky upravenou síť exportujte v záložce Export mesh > Save (doporučený formát 
OBJ). V případě potřeby za název souboru připište i souborovou příponu (.obj).

Export



podstava: část 1
Modelování podstavy je volitelným krokem, nicméně doporučeným. 
Podstava slouží především jako základna tiskového modelu. V neposlední 
řadě má také estetický význam. Modelování podstavy je pokročilejší a časově 
náročnější operace, proto je její modelování rozděleno do 3 částí.

Podstava

Podstava bude modelována v softwaru Blender.
Software

Po spuštění softwaru odstraňte výchozí objekt umístěný ve scéně. V záložce File 
> Import zvolte formát vytvořeného topologicky upraveného souboru a nahrajte. 

Příprava scény a import

V případě, že se načtený model nachází mimo počátek souřadnicového systému, 
klávesovou zkratkou Shift + Ctrl + Alt + C vyvolejte menu „Set Origin“ 
a zvolte možnost „Geometry to Origin“. Tímto krokem přesunete objekt 
do počátku souřadnicového systému. 

Posun modelu

Je pravděpodobné, že objekt bude orientován v jiné ose, než byl původně 
definován a tedy pootočen o 90 °. Pro opravu orientace zvolte vrchní náhled 
(Numpad 0) a objekt rotujte (klávesová zkratka R) v požadovaném směru (rotaci 
lze omezit pouze na požadované osy, klávesové zkratky X, Y, Z). Při držení klávesy 
Ctrl lze rotovat v 5° inkrementech a docílit tak rotace přesně o 90 °.

Rotace modelu
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podstava: část 2
V následujícím kroku budou zarovnány hrany polygonové sítě.
Cíl

Pro následující krok je doporučeno pracovat ve vrchním pohledu (Numpad 0) 
a v ortografickém režimu (Numpad 5). Přepněte do editovacího módu 
(klávesa Tab) a do režimu hran (Ctrl + Tab > Edges).

Nastavení scény a režimu

Následně použitý nástroj ovlivňuje pouze vybrané hrany. Proto nejprve vyberte 
všechny hrany (klávesa A), poté mezerníkem vyvolejte kontextové vyhledávání 
a vyhledejte nástroj Bisect. 

Nástroj Bisect

Nakreslete linii řezu. V parametrech nástroje (typicky vlevo dole) aproximujte směr 
roviny řezu v nastavení Plane Normal (normálu roviny, ve které je řez veden, nastavte 
na 1, ostatní dvě na 0) a v závislosti na směru řezu zvolte možnost Clean Inner / Clean 
Outer. Tato možnost odstraní nepotřebnou část polygonové sítě.

Nastavení nástroje

Celý postup opakujte pro každou hranu modelované podstavy. (označit hrany 
> Bisect > nastavit normálu roviny řezu > odstranit nepotřebnou část).

4 hrany
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podstava: část 3
V režimu editace hran klávesovou zkratkou Shift + Ctrl + Alt + M vyberte 
obrysové hrany polygonové sítě. 

Výběr hran

Nástrojem Extrude > Edges Only hrany vytáhněte o požadovanou výšku (směr 
vytažení lze opět klávesou X, Y nebo Z omezit na požadovanou osu – typicky Z). 

Vytažení hran

Pro tento krok je důležitá správnost sítě. Je-li v síti jiný otvor, než otvor pro 
podstavu, budou vytvořeny nežádoucí artefakty. V takovém případě se vraťte
do softwaru Meshmixer a díru opravte.

Potenciální chyby

Označené hrany je nutné výškově srovnat do roviny. Nejvhodnějším postupem 
je nástrojem Scale. Nástroj aktivujte a klávesou Z omezte na vertikální 
osu. V parametrech nástroje poté všechny vektory aproximujte přesně na 0. 

Zarovnání hran

Posledním krokem k uzavření modelu je vyplnění díry v podstavě. 
V kontextovém vyhledávání vyhledejte nástroj Fill a spusťte. 

Vyplnění

Po dokončení editace klávesou Tab přepněte do režimu objektu
a model v záložce File > Export uložte (doporučený formát OBJ).

Export
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texturování

28

Pro plnohodnotně editovatelnou texturu bude nejprve 
potřeba provést tzv. UV mapování (tj. dle potřeb rozložit 
polygonovou síť na plátno textury). Tento krok zajistí 
pozdější pohodlnné úpravování textury v grafickém editoru.

UV mapování1
Protože bude textura generována v již existující scéně 
rozmístěných a orientovaných snímků, je potřeba upravený 
model umístit do původního postavení (během tvorby 
došlo k posunu a rotaci). Zarovnání modelu s referencí bude 
provedeno v softwaru CloudCompare.

Zarovnání modelu2
Po zarovnání bude model načten do softwaru Agisoft 
Metashape a nahradí referenční model (ve stejném 
postavení, velikosti i rotaci). Na načtený model 
bude z orientovaných snímků vygenerována textura.

Generování textury3

Vytvořená textura není nic jiného než běžný bitmapový soubor 
(rastr o zadaném rozlišení). Lze ji uložit v několika různých 
rastrových formátech a tedy upravit v libovolném grafickém 
rastrovém editoru. Cílem je odstranit vady jako např. stíny.

Úprava textury4
Protože během generování textury v Agisoft Metashape 
nelze kontrolovat, které polygony mají být texturovány,
s největší pravděpodobností bude otexturována
i podstava. A protože podstava není původně součást 
polygonové sítě, textura bude vytvořena chybně. To je
z estetického hlediska nežádoucí a na těchto polygonech 
je třeba vytvořenou texturu přebarvit.

Barevná úprava podstavy5



uv mapování
UV mapu lze definovat jako rozložení polygonů 3D modelu na 2D plátně. Písmena 
UV značí horizontální a vetrikální souřadnice plátna (X a Y již vyhrazeno pro 3D 
prostor). Software Agisoft Metashape současně s texturou generuje vlastní UV 
mapu, ta však nemusí být pro následné zpracování textury vyhovující. Proto je vždy 
mít lepší nad rozložením plnou kontrolu a mapu přizpůsobit dle potřeb.

UV mapa

V softwaru Blender z pravého horního rohu vytáhněte druhé zobrazovací 
okno a přepněte jej do editoru typu UV/Image Editor (vlevo dole). 
Přepněte do editovacího módu (Tab) a do režimu hran (Ctrl + Tab > Edge). 

Příprava rozhraní a režimu

Dále ve 3D náhledu označte všechny hrany (klávesa A), klávesou U vyvolejte 
menu UV Mapping a zvolte položku Smart UV Project. 

Smart UV Project

Stěžejním parametrem je Angle Limit. Tento parametr nastavte dle potřeb 
(doporučené rozmezí 50 až 90 °). Výchozí nastavení 66 ° je vhodná referenční 
hodnota. Ostatní parametry ponechte výchozí a nástroj spusťte. Po výpočtu se
ve 2D okně zobrazí náhled na mapu. V případě, že s výsledkem nejste spokojeni, 
nástroj opakujte s rozdílným nastavením Angle Limit.

Parametry

Po dokončení mapování model včetně mapy exportujte v záložce File > Export
ve formátu OBJ. V nastavení exportu je nutné označit položku Include UVs.
V opačném případě nebude mapa uložena. 

Export
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zarovnání modelu
Protože během zpracování došlo k posunu a rotaci modelu, je potřeba model v rámci 
souřadnicového systému umístit do takového postavení, aby odpovídal mračnu bodů ve vytvořené 
scéně v softwaru Agisoft Metashape. Zarovnání bude docíleno umístěním upraveného modelu 
přesně do pozice referenčního modelu. Referenční model je nejprve třeba vytvořit.

Postavení modelu

V původní scéně softwaru Agisoft Metashape v záložce Workflow > Build mesh vytvořte model. 
Protože bude model sloužit pouze jako reference, není nutné, aby byl detailní. Je vhodné použít 
nižší nastavení rekonstrukce (př. Source data: Dense Cloud; Surface Type: Arbitrary; Face Count: 
Low). V záložce File > Export model exportujte v lokálním souřadnicovém systému.

Vytvoření referenčního modelu

V softwaru CloudCompare v záložce File > Open nahrajte referenční i upravený model.
Import referenčního modelu

V databázovém stromu označte oba modely a nástrojem Align two clouds by picking equivalet 
point pairs (horní lišta). V okně výběru role nastavte jako zarovnávaný model (Aligned) upravený 
model a druhý model jako referenční (Reference). Toto nastavení určuje, který model bude 
posouván a který bude přichycen.

Zarovní modelu s referencí

Nyní na obou modelech vyberte alespoň 4 odpovídající body a potvrďte akcí Align. 
Tímto upravený model přesunete do stejné pozice, jako referenční.

Výběr bodů

Upravený model exportujte v záložce File > Save ve formátu OBJ.
Export
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generování textury
V softwaru Agisoft Metashape v záložce File > Import > Import model nahrajte 
upravený referencovaný model v lokálním souřadnicovém systému. Původní 
model nenahrazujte. Zkontrolujte, zda se modely nachází na stejné pozici.

Software a import

Ve stromové struktuře přepněte na upravený model a v záložce 
Workflow > Build Texture vytvořte texturu.

Generování textury

Jako Mapping mode nastavte Keep uv. 
Mapping mode

Velikost textury je volitelná. Doporučenou hodnotou je 4096 (tzv. 4K) nebo 2048 (tzv. 2K).
Velikost textury

Ostatní parametry ponechte výchozí a nástroj spusťte.

Další parametry

Model včetně textury exportujte v záložce File > Export > Export Model v lokálním 
souřadnicovém systému, včetně normál. Texturu zahrňte označením položky Export 
texture (doporučený formát TIFF).

Export
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úprava textury
Cílem úpravy textury může být barevné vyvážení, odstranění stínů na modelu, 
přidání vlastních prvků atd.

Úprava

Texturu lze upravit v libovolném grafickém rastrovém editoru 
(např. Photoshop, GIMP, Krita)

Software

Před úpravou nezapomeňte originální neupravenou texturu zálohovat 
pro případ, že byste se k ní chtěli vrátit. 

Zálohování

Způsob opravy se odvíjí od typu chyby. Nicméně vhodné nástroje pro úpravu 
jsou především štětce v různých nastaveních v kombinaci s kapátkem. Kapátko 
slouží pro výběr barvy a štětec pro „přemalování“ nežádoucích prvků.

Nástroje

Ne všechny nedostatky lze jednoduše opravit. Je běžné, že při opravě budete 
limitováni možnostmi softwaru. 

Neopravitelné chyby

Upravenou texturu uložte místo původní neupravené textury ve stejném názvu. 
Pokud texturu uložíte pod jiným názvem a v jiném formátu, je potřeba cestu 
přepsat v MTL souboru.

Název upravené textury
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barevná úprava podstavy
Protože je podstava součást modelu a Agisoft Metashape generuje texturu po celém povrchu 
modelu, nachází se části textury i na podstavě. To je pro výsledný model nežádoucí a neestetické. 
Proto je potřeba texturu na bočních a spodní části podstavy přepsat vhodnou barvou.

Chybná textura

V softwaru Blender v záložce File > Import model nahrajte a klávesou Home 
přemístěte náhled na model. 

Software

Pro vizuální posouzení ve spodní liště aktivujte náhled textury (Method od display > Texture). 
Přepněte do editovacího režimu (Tab) a do režimu polygonů (Ctrl + Tab > Face). Pohled orientujte 
na boční a přepněte do ortografické perspektivy (Num 5). Přepnutím do režimu Wireframe 
(Method of display > Wireframe) lze vybrat i polygony nacházející se v zákrytu dalších polygonů.

Příprava scény

Obdélníkovým výběrem (klávesa B) vyberte celou spodní část podstavy, 
tj. polygony, kterým bude změněna barva.

Výběr

Po výběru polygonů v pravé boční liště přejděte do nastavení materiálů 
(Materials), vytvořte barvu dle požadavků a akcí Assign barvu přiřaďte vybraným 
polygonům. Po provedení tohoto kroku model uložte.

Přiřazení materiálu
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zarovnání modelu
Protože byl model při vytváření textury do scény umístěn v původním 
postavení, je potřeba ho opět zarovnat.

Zarovnání

V softwaru Blender klávesovou zkratkou Shift + Ctrl + Alt + C vyvolejte 
menu „Set Origin“ a zvolte možnost „Geometry to Origin“. Tímto 
krokem přesunete model do počátku souřadnicového systému. 

Software a posun

Přepněte náhled do ortografického režimu (Num 5) a postupně model 
zarovnejte ve všech osách (klávesa R). Je doporučeno zamykání os (klávesy 
X, Y a Z) a detailní krokování (při rotaci přidržet klávesu Shift). V softwaru 
Blender nelze docílit naprosto přesného zarovnání s osami. 

Rotace

V případě použití papírové tiskárny lze nepřesné zarovnání ignorovat, 
protože model je obestoupen papírem a nemusí tedy stát na tiskovém plátu.

Papírová tiskárna

V případě použití plastové tiskárny je vhodné, aby model celou 
plochou podstavy ležel na tiskovém plátu. V softwaru Ultimaker Cura 
lze tento problém opravit příkazem Rotate > Lay Flat.

Plastová tiskárna

35



další postup
Obecně jsou další kroky následující:

 1. změna velikosti modelu

 2. rotace modelu

 3. výpočet tiskových vrstev

 4. generování tiskového kódu

 5. příprava tiskárny

Další kroky

Konkrétní řešení již záleží na použité technologii tisku, výrobci
a modelu tiskárny. Většinou se jedná o intuitivní nenáročné kroky.

Technologie

Po provedení zmíněných kroků zbývá tiskový kód načíst 
do tiskárny a tisk spustit.

Tiskový kód

Tisk ve většině případů trvá v řádech hodin až desítek hodin. 
Časová náročnost

Po vytištění model opatrně sejměte z tiskového plátu a případně 
upravte potřebnými nástroji nebo ošetřete požadovanými prostředky.

Vytištěný model
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o postupu
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Uvedený postup je výsledkem a zároveň hlavní přílohou bakalářské práce “Tvorba 3D tiskových 
modelů z fotogrammetrických dat”. Postup byl tvořen s ohledem na uživatelskou přívětivost
a relativní časovou nenáročnost.

Postup

Postup byl vytvořen s úmyslem v co největší možné míře pracovat ve free and open 
source softwarech. Takový postup umožní nízkonákladově vytvářet 3D modely a tiskové 
3D modely z reálných objektů. Uplatnění by mohl najít zejména v řadách studentů
či u široké veřejnosti.

Free and open source

Sestavený postup byl testován a laděn na několika případových 
studiích, na jejichž základě bylo optimalizováno nastavení 
některých parametrů a doporučených hodnot. Stručné informace
k vybraným případovým studiím jsou uvedeny dále.

Případové studie



studie č. 1
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studie č. 2
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studie č. 3
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použitý software

42

Agisoft Metashape
www.agisoft.com/downloads/installer/

verze: Agisoft Metashape 1.5.2
licence: proprietární

CloudCompare
www.cloudcompare.org/release/

verze: CloudCompare 2.10.2 Zephyrus
licence: GNU GPL

MeshLab
www.meshlab.net/#download

verze: MeshLab 2016.12
licence: GNU GPL

Autodesk Meshmixer
www.meshmixer.com/download.html

verze: Autodesk Meshmixer 3.5.474
licence: free software

Instant Meshes
github.com/wjakob/instant-meshes

latest commit: Jan 26, 2018
licence: BSD

Blender
www.blender.org/download/

verze: Blender 2.79b
licence: GNU GPL

GIMP
www.gimp.org/downloads/

verze: GIMP 2.10.8
licence: GNU GPL

Ultimaker Cura
www.ultimaker.com/en/products/

ultimaker-cura-software
verze: Ultimaker Cura 4.0

licence: GNU LGPL
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