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1. Základní informace 

Mezi základní soubory pro zobrazení dat patří: 

ModelBuilder_data.csv – obsahuje informace o fixacích 

ModelBuilder_traj.csv – obsahuje informace o trajektoriích 

 

1.1. Načtení dat 

V hlavní liště v záložce File se zvolí Load data, poté se zobrazí okno, ve kterém je nutné 

vybrat typ souboru tedy ASCII file. Dále se z adresáře vybere soubor 

ModelBuilder_data.csv a poté v dialogovém okně je potřebné nastavit parametry pro 

načtení souboru, kde je nutné zadat:  

 oddělovač – čárka 

 zaznačit, že popis atributů je v prvním řádku 

 ve kterém sloupci je identifikátor – 1 

 zaznačit, že multilinie mohou být popsány jako jeden objekt 

 zaznačit a nastavit souřadnice    

 

 

Obr. 1 Nastavení parametrů pro vstupní data 

 



Následně prostřednictvím volby Tools → Explore movement data se zobrazí okno, kde se 

označí tabulka ModelBuilder_data.csv a potvrdí se tlačítkem OK. Zobrazí se okno, kde 

nutné zadat: 

o trID → identifiers of lines or trajectories 

o X → x-coordinates 

o Y → y-coordinates 

o time → time moments 

 

 
Obr. 2 Definování parametrů vstupní tabulky 

 

V dalším kroku se definuje typ časových hodnot, v tomto případě se jedná o abstraktní 

časové údaje, proto se nastaví abstract. Poté se zobrazí dialog, ve kterém se zadá, že 

souřadnice NEJSOU geografické.  

 

 

Obr. 3 Nastavení typu časového údaje 



 

Pro načtení daného stimulu se postupuje podobným způsobem. Rozdíl je pouze v tom, že se 

místo ASCII file vybere IMAGE. Následně se v dialogovém okně zadají rozměry vstupujícího 

stimulu tedy 1920x1200.  

 

Obr. 4 Parametry vstupujícího stimulu 

 



1.2. Načtení projektu 

Pro načtení dat do projektu je nutné mít soubor s koncovkou *.app, který lze vytvořit podle 

následujícího vzoru (obr. 5) v jakémkoli textovém editoru. Tento soubor musí být umístěn ve 

stejném adresáři jako příslušné stimuly (obrázky s diagramy) a tabulky typu *.csv, které 

obsahují hodnoty naměřených veličin v testování.     

 

 

Obr. 5 Ukázka souboru *app.(vlevo) a struktura adresáře (vpravo)  

 

1 Pojmenování a nastavení projektu  

– důležité je definovat název projektu, velikost extentu, typ jednotek (pro eye-tracking px) 

2 Popis připojených vrstev (stimulů)  

– nutné definovat název vrstvy, velikost vrstvy, typ a formát vrstvy 

3 Popis připojených tabulek  

– tato část popisuje dva vstupující soubory typu csv, kde potřebné je definovat formát  

souboru, oddělovač, ID, souřadnice a časové údaje 

4 Struktura adresáře 

 



Následně se připojení projektu provede podle následujícího obrázku volbou File → Load 

project. 

 

 
 

 

 

Obr 6. Cesta pro načtení dat (projektu) 

 

 

1.3. Uživatelské rozhraní 

 

 

Obr. 7 Uživatelské rozhraní 

 

1 Nástrojová lišta pro práci s mapovým oknem 

2 Seznam používaných vrstev 

3 Mapové okno 



1.4. Popis záložek v hlavní liště 

 

1 Načíst projekt – *. app 

2 Načíst data – různé druhy 

3 Indexovat parametrem závislou 

tabulku 

4 Vytvořit vrstvu z tabulky 

5 Vytvořit podmnožinu objektů do 

nové vrstvy nebo tabulky 

6 Spojení tabulka-vrstva  

7 Nahrát data znovu 

8 Exportovat data 

9 Uložit projekt 

10 Uložit OSM mapové dlaždice 

místně 

11 Upravit název tabulky 

12 Upravit názvy atributů 

13 Vložit atributy 

14 Vyjmout atributy 

15 Připojit tabulky 

16 Vyjmout tabulku 

17 Vyjmout mapové vrstvy 

18 Vyjmout mapu  

19 Vyjmout všechna data 

20 Tisk 

21 Uložit jako obrázek 

22 Vytvořit stránku – vytvoří 

webovou stránku s výpisem všech 

provedených akcí  

23 Tisk výpisu provedených akcí 

do souboru 

24 Konec 

               Obr. 8 Ukázka záložky „File“ 

 

1 Nastavení vizualizace  

2 Ukázat tabulku 

3 Filtrovat objekty prostorovým oknem 

4 Filtrovat objekty plochami mapové vrstvy 

5 Vyčistit mapu 

6 Další okno 

7 Okna 

8 Uložit Snapshot  

9 Uložit Snapshot 

Obr. 9 Ukázka záložky „Display“ 



 

 

 

 

1 Výpočet v tabulce 

2 Geografické výpočty 

 

Obr. 10 Ukázka záložky „Calculate“ 

 

 

1 Dynamický dotaz 

2 Indexovat objekty 

3 Filtrovat podle výběru 

4 Filtrovat spojení OD 

5 Filtrovat ze dvou souvisejících sad 

6 Seskupovací filtr 

7 Vytvořit atribut reflektující současného 

nastavení filtru  

8 Zobrazit časová data v space-time cube 

9 Analýza dat pomocí databázových operací 

10 Zkoumat data pohybu 

11 Zkoumat data událostí 

12 Analyzovat a modelovat časové řady dat 

13 Zobrazení časové rovnoběžný sad 

14 Sluková analýza 

15 Shluková analýza: kMeans 

16 Analýza podobnosti 

17 Zpracovat tabulková data 

18 Exportovat objekty pro zobrazení v Google 

19 Spojit s Secondo 

20 Klasifikovat objekty 

21 Zobrazit třídy objektů v samostatných 

oknech 

22 Zobrazit animované mapy v samostatných 

oknech 

23 Upravit nebo vytvořit mapovou vrstvu 

24 Vytvořit rastrovou vrstvu 

25 Prostorové vyhlazení číselného atributu 

26 Rozhodovací map 

27 Perspektivní pohled 

28 Měřit vzdálenost 

29 Uložit nebo načíst dříve vytvořená data 

30 Načíst a zkoumat dříve vytvořené schéma 

31 Zkoumat přepravní plán 

32 Funkce času 

                

Obr. 11 Ukázka záložky „Tools“ 



    

  

1 Použít nové mapové okno pro 

každou novou vizualizaci 

2 Ukázat možnosti záznamu   

3 Ptát se na komentář, když se 

vytváří stránka 

4 Ověřit vztah mezi proměnnými 

5 Upozornit na zneužití 

    Obr. 12 Ukázka záložky „Options“ 

 

 

1 Rejstřík 

2 Podpora rozhodování 

3 O programu 

         

       Obr. 13 Ukázka záložky „Help“ 

 

 



2. Základní operace 

2.1. Zobrazení tabulky 

V záložce Display volbou View table (Ctrl+T) se objeví dialogové okno, kde se zvolí 

atributy, které je nutné zobrazit např. „Subject, Stimulus, Duration“. V tabulce je možné 

dvojitým klikem na atribut hodnoty seřadit vzestupně resp. sestupně. Je také možné 

kliknutím na tlačítko Attribute jednotlivé atributy přidávat či ubírat, dále pak kliknutím na 

záznam se provede výběr.  

 

 
Obr. 14 Ukázka tabulky 

 

 

2.2. Dynamický výběr 

Pro funkci dynamického výběru se v záložce Tools zvolí Dynamic query, poté se objeví 

dialogové okno, kde je nutné vybrat atribut, pro který bude výběr prováděn (může být 

vybráno i více atributů). Pokud je výběr realizován pro atributy, jež obsahují kvantitativní 

data, ponechá se nastavení „substr“ a zadá se interval dat, které je nutné zobrazit.  Ovšem 

pokud se jedná o data kvalitativní, nastaví se parametr „list“ a poté volbou Change se 

vyberou příslušné záznamy atributu. Takto lze ze seznamu respondentů (atribut Subject) 

vybrat pouze jednoho nebo více respondentů. Poté lze provádět analýzy pouze s vybranými 

respondenty. Obdobně lze vybírat záznamy i pro všechny zvolené atributy.  

Upozornění: Okno dynamického výběru je nutné mít pořád spuštěné. Pokud se zavře, zruší 

se i provedený výběr dat.       



 

Obr. 15 Ukázka dynamického výběru 

 

 

2.3. Uložení dat a projektu 

Uložení dat se provede vždy volbou File → Export data. Poté se objeví dialogové okno s 

mnoha typy uložení dat (obr. 16). Uložit data je možné ve formě tabulky nebo mapové vrstvy. 

Pro uložení časových záznamů se volí tabulka jako „csv“, pokud je nutné uložit pouze 

grafické zobrazení dat, volí se mapová vrstva ve formátu XML.  

 

Obr. 16 Možnosti uložení dat 



 

Uložení načtených dat 

Jestliže byly data načteny ze souborů, je nejprve nutné pro vytvoření projektu uložit 

vektorovou vrstvu trajektorií jako mapovou vrstvu „csv (comma-separated 

values):trajectories“. Poté v záložce File se zvolí Save project, kde v dialogovém okně se 

zadá název projektu a uloží se do příslušného adresáře. 

 

 

Obr. 17 Ukázka uložení projektu 

 

Uložení již vytvořených dat 

1. Vytvořené vrstvy kreslením – jako mapovou vrstvu ve formátu XML  

2. Voronoi polygony zahrnující časové řady – jako mapovou vrstva formátu XML bez časové 

řady, které se následně uloží zvlášť jako tabulka ve formátu CSV 

3. Flows – jako mapovou vrstvu ve formátu CVS:links or moves between places i s 

časovou řadou 

4. Trajektorie – jako mapovou vrstvu ve formátu CSV: trajectories i časovou řadou 

5. Body nebo kruhy – jako mapovou vrstvu ve formátu CSV:points or circles i časovou 

řadou 

 

Postup pro uložení projektu 

Nejprve je nutné vždy uložit všechny vytvořené vrstvy (pouze polygony musí mít uložené 

časové řady zvlášť), poté nahrané vrstvy a teprve nakonec se v záložce File zvolí Save 

project. 

 



 

3. Metody 

3.1. Flow map  

Metoda flow map umožnuje zobrazit agregované trajektorie prostřednictvím šipek, jejichž 

šířka reprezentuje počet očních přesunů mezi jednotlivými polygony či oblastmi zájmu. 

3.1.1 Základní flow map 

Nejprve se pomocí  záložky Tools vybere nástroj Explore movement data a následně 

v sekci Summarise se zvolí Generalise and summarise trajectories, kde je potřebné 

nastavit příslušné parametry pro výslednou Flow map a nutné v parametru Aggregation 

mode zaškrtnout dynamic.  

1 Výběr vrstvy pro metodu flow map  

2 Minimální úhel změny směru 

3 Minimální trvání fixace 

4 Minimální vzdálenost další fixace 

5 Maximální vzdálenost další fixace 

6 Požadovaný poloměr shluku 

7 Souřadnice mapového extentu 

8 Výběr sítě pro vytvoření centrových bodů (kruh nebo Voronoi polygony) 

9 Další doplňující podmínky 

 

            

Obr. 18 Nastavení parametrů pro Flow map 

 

Výsledkem metody jsou šipky, jejichž směr ukazuje, jak se pohybovaly oči vybraných 

respondentů v daném prostoru. Šířka šipky pak znázorňuje míru očních přesunů.  

 

 

 

 



 

 

Obr. 19 Flow map s Voronoi polygony 

 

Dále pak je možné Flow map vizualizovat podle zvoleného atributu, kterým je „N of moves“. 

V záložce Display se zvolí nástroj Display wizard, vybere se vrstva, atribut a způsob 

vizualiazace (Line thickness). Konečný výsledek pak může vypadat jako na obr. 22, kde 

pomocí interaktviní legendy je vyfiltrován počet přesunů větší jak 8. Je také možné možnost 

zašktnout Vary opacity, jež zobrazí šipky pomocí stínované barvy od průhledné po sytou, 

kde nejsytější barva představuje nejvyšší počet přesunů.  

 

 

Obr. 20 Výběr vrstvy 

 



 

Obr. 21 Výběr způsobu vizualiazce 

 

 

Obr. 22 Ukázky metody vizualizace s legendou 

 



Na obrázku 23 lze vidět mezi jednotlivými výslednými flow map rozdíl. Je to dané rozdílným 

nastavením parametrů, v případě levého obrázku je ponecháno výchozí nastavení tedy úhel 

změny směru 30, minimální trvání fixace 300, minimální/maximální vzdálenost k dalšímu 

bodu 5/25 a poloměr shluku 100.  Na pravém obrázku byly parametry změněny a tak, že 

úhel změny směru je 10, min. trvání fixace je 0, min./max. vzdálenost k dalšímu bodu je 

30/60, vše ostatní je nezměněno. Pro výslednou vizualizaci byl vybrán atribut „N of moves“  a 

byly vyfiltrovány směry menší jak 7 očních přesunů.  

 

 

Obr. 23 Ukázka výsledků metody flow map s různým nastavením parametrů 

 

3.1.2. Flow map založená na zájmových oblastech 

Tento způsob vykreslení Flow map je založený na tvorbě vlastních zájmových oblastí (AOI – 

Area Of Interest). Vytvoření zájmových oblastí se provede volbou Tools → Edit or 

construct map layer se vybere Add new layer, v následujícím okně se pojmenuje nová 

vrstva (např. AOI) a zvolí se typ vymezení (bod, kruh, obdélník nebo vlastní plocha „area“), 

pak už se jenom kreslí zájmové oblasti. Je důležité nechat dialog Editing or constracting of 

a layer stále zapnutý. Až se dokreslí nová vrstva, potvrdí se tlačítkem OK.  

 

                   

 

 

 

 

 

 

 

 

 

 

Obr. 24 Postup při vytváření nové vrstvy 

 

Další postup už stejný jako v předešlém způsobu metody Flow map tedy pomocí nástroje  

Explore movement data, kde v sekci Summarise se zvolí funkce Summarise trajectories 

as moves between existing areas. V následujícím okně se pak vyberou příslušné vrstvy 

(vrstva trajektorií a AOI) a zaškrtne se pole dynamic aggregation. Výsledkem je potom 

mapa jako na obr. 26. 

 



 

Obr. 25 Výběr vrstvy trajektorií a AOI 

 

 

Obr. 26 Ukázka výsledné mapy Flow map založené na AOI 

 

3.2. Attention map 

Tato metoda navazuje na předešlou metodu Flow map. Je tedy nutné nejprve provést 

metodu Flow map, protože metoda attention map využívá dříve vzniklou vrstvu sítě Voronoi 

polygonů. V záložce Display se použije nástroj Display wizard a vybere se vrstva, která 

tvoří síť polygonů vytvořených metodou Flow map (obr. 27). Následně se zvolí atribut(y)  

„N visits“ a v sekci Maps metoda vizualizace „Graduated circles“ tedy kruhy. Dalšími 

možnosti vizualizace je sloupec či trojúhelník. Pro zvolený atribut se tedy vykreslí attention 

map. 



 

 

Obr. 27 Výběr vrstvy pro attention map 

 

Obr. 28 Výběr metody vizualizace 

 

 

Obr. 29 Ukázky metody Attention map 

 



3.3. Multiple flow maps 

Tato metoda umožňuje zobrazit několik Flow map najednou, které jsou zobrazeny v různých 

časových úsecích nebo podle vytvořených tříd.  

 

Pro rozčlenění do jednotlivých časových intervalů či tříd, je nutné mít vytvořenou základní 

Flow map, poté kroky Tools → Explore movement data → v sekci Summarize volbou 

Itemize aggregates by classes (clusters) or by time intervals se vybere vrstva, která 

představuje agregované trajektorie. Je ji možné členit dvěma způsoby. Buď do tříd 

zaškrtnutím pole itemize by clusters (classes of trajectories) of trajectories nebo do 

časových intervalů itemize by time interval. Je možné vybrat i obě možnosti členění vrstvy 

najednou. V tomto případě se bude rozdělovat do několika časových intervalů. 

 

 

Obr. 30 Výběr vrstvy a druhu členění 

 

Po vybrání vrstvy a způsobu dělení se zobrazí okno pro výběr atributu, ve kterém se definují 

časové intervaly. Poté se v dalších zobrazených oknech pojmenují nově vzniklé atributy. 

 

.  

Obr. 31 Okno pro definování časových intervalů 



       

Obr. 32  Dialogové okna pro pojmenování atributů 

 

Výsledné vytvořené třídy či časové intervaly je možné zobrazit skrze záložku Display 

pomocí nástroje Display wizard, kde se vybere příslušná vrstva a zvolí se atribut, v tomto 

případě „(T) N moves by time intervals“. Dále je možné si vybrat způsob vizualizace: 

animovaná mapa, mapa s hodnotou flow diagramu, časový graf nebo jiné další vizualizace.  

 

 

Obr. 33 Výběr způsobu vizualizace 

Zvolí se poslední možnost tedy „Other visualisation methods“, kde se následně musí vybrat, 

intervaly, které budou zobrazeny a poté typ vizualizace Multiple maps with line thickness. 

Výsledek je možné vidět na obr. 35, kde je několik Flow map v definovaných časových 

intervalech. 

 

Obr. 34 Výběr typu vizualizace 



 

Obr. 35 Ukázka vizualizace rozčleněné flow map do časových intervalů  

 

 

3.4. Multiple attention map 

Stejně tak jako v přechozím případě Multiple flow map lze rozdělit attention map. V záložce 

Tools se zvolí Explore movement data → Itemize aggregates by classes (clusters) or 

by time intervals, následně se vybere vrstva, která obsahuje vytvořené polygony či oblasti 

zájmu.  

 
Obr. 36 Výběr vrstvy pro metodu Multiple attetion map 

 

Poté v dialogovém okně Temporal aggregation se zvolí časové intervaly. V dalších krocích 

už se pouze definují nově vzniklé atributy. Vizualizace se provede Display → Display 

wizard, poté se vybere vrstva, určí se atribut pro vizualizaci „(T) N visits by time intervals“ a 

typ vizualizace, čímž je Multiple maps with graduated circles. 



 

Obr. 37 Výsledná Multiple attention map 

 

3.5. Temporal view of trajectories 

Pro znázornění metody Temporal view of trajectories je třeba vytvořit novou bodovou či 

polygonovou vrstvu stejným způsobem jak v kapitole 3.1.2. Počet a umístění bodů či 

polygonů se volí podle místa zájmu. Potom je možné vypočítat, jak daleko respektive jak 

blízko se respondent díval od definovaného místa. Dále v záložce Tools volbou Time 

function se zvolí Trajectory time graph. Poté se zobrazí okno, ve kterém pomocí záložek 

v dolní liště se nastaví výsledný graf.  

 

                                                             
Obr. 38 Výběr funkce času  

 

Nastavení záložek: 

Data – do pole „Trajectory attribute“ se zadá vytvořená polygonová vrstva, tak že 

pomocí tlačítka Change se v sekci Spatial relations vybere Distance to selected 

object(s), následně se zvolí vytvořená polygonová vrstva a definuje se rozsah 

vzdáleností  

 

 

Obr. 39 Záložka data 



Display – zde je potřeba nastavit typ grafu na Time line a v sekci Sort/group by 

vybrat potřebné řazení jednotlivých respondentů (v tomto příkladu atribut „Subject“), 

je zde také možné nastavit šířku sloupce (parametr Bar Width) 

 

 

Obr. 40 Záložka display  

 

Classes – zde se zaškrtnutím pole Value classes určí intervaly vzdáleností a vybere 

se příslušné barevná stupnice 

 

 

Obr. 41 Ukázka okna Time graph 

 

Pro porovnání jednotlivých respondentů je dobré čas znormalizovat. To se provede kroky 

Tools →Time functions → Transformation of time references, kde se zvolí, vůči čemu se 

čas má znormalizovat. V tomto případě zaškrtnutím pole „start and end times“. Další postup 

je stejný jak na začátku kapitoly 3.5. Výsledný graf je vidět na obr. 42, kde lze vidět, že čas je 

znormalizovaný, tak aby počátek i konec měli všichni respondenti stejný.  

 



 

Obr. 42 Ukázka okna Time graph pro znormalizovaný čas 

 

Dále je možné jednotlivé zvolené intervaly vyfiltrovat, tak aby šlo jednoznačně rozpoznat, 

který respondent a kdy byl u hledaného objektu. Legenda v Time graph je interaktivní, to 

znamená, že zaškrtnutím jednotlivých polí barev se docílí toho, že půjdou vidět pouze 

segmenty nevyfiltrované.  

 

Obr.43 Ukázka vyfiltrovaných segmentů 

 



3.6. Path similarity analysis 

Tato metoda vypočítá podobnost trajektorií. Přístupů pro výpočet podobnosti trajektorií je 

více např. všechny vůči jedné nebo více vybraným trajektoriím nebo v rámci celé vrstvy 

trajektorií. 

 

3.6.1. Porovnání vůči vybraným trajektoriím  

Nejprve musí být vybrána jedna nebo více trajektorií, se kterou se budou porovnávat 

všechny ostatní, např. nejkratší, nejrychlejší. V tabulce označím danou trajektorii a poté 

v záložce Tools pomocí nástroje Similarity analysis se vybere operace Compute distance 

to a selected geographical object, dále se zvolí funkce porovnávání Route similarity. 

V posledním kroku se pojmenuje výsledný nový atribut, jehož hodnota je velikost podobnosti 

vůči porovnávané trajektorii či trajektoriím. Na obr. 47 dole lze vidět, do jaké míry jsou si 

trajektorie podobné.  

 

Obr. 44 Ukázka tabulky s označenou trajektorií 

 

 

 

 

Obr. 45 Výběr operace a pojmenování výsledného atributu 



 

 

Obr. 46 Ukázka tabulky s atributem hodnot podobností trajektorií 

 

 

 
 

Obr. 47 Ukázka nejméně podobných trajektorií (vlevo) a nejvíce podobných trajektorií (vpravo) 

 

3.6.2. Porovnání v rámci celé vrstvy trajektorií 

Tato metoda je založena na výpočtu matice vzdáleností trajektorií celé vrstvy, což se 

provede Tools → Similarity analysis → Compute matrix of distance among 

geographical objects. Poté se vybere tabulka CvicnaData-ModelBuilder, následně po 

těchto krocích je třeba zvolit funkci porovnávání Route Similarity a vypočítanou matici 

vzdáleností pojmenovat. 



.                   

Obr. 48 Výběr operace porovnání a funkce vzdáleností  

 

Dále kroky  Tools →Similarity analysis je nutné vybrat operaci Apply Sammon´s 

projection to a pre-computed distance matrix, která zobrazí trajektorie v podobě teček a 

umožní rozdělit respondenty do skupin. Což se provede nastavením parametru shlukování 

„Group radius (%)“ a stiskem tlačítka Tessellate. Poté je možné rozdělení do skupin uložit 

do tabulky volbou Put classes in table column, zobrazí se dialog, kde se pojmenuje 

výsledný atribut, v tomto případě „Class 10“ . 

 

 

Obr. 49 Ukázka rozdělení do tříd pomocí Sammonovy projekce 



 
Obr. 50 Ukázka tabulky s atributem skupin 

 

 

Obr. 51 Ukázka skupin podobností rozdělených Sammonovou projekcí 

 

 


