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1  ÚDRŽBA ZAŘÍZENÍ EMOTIV EPOC+ 
EPOC+ je bezdrátový 14kanálový EEG neuroheadset sloužící zejména pro BCI aplikace, ale jeho nadstavbou je i vestavěné měření úrovní vybraných emocí. 
Součástí balení nutného pro provoz zařízení jsou: 

 Headset se zabudovaným lithiovým akumulátorem (obr. 1.1), 
 USB bezdrátový přijímač (obr. 1.2),  
 balení 16 vyměnitelných senzorů (obr. 1.3), 
 solný roztok (obr. 1.4), 
 kabel s mini USB konektorem (obr. 1.5). 

 

  

Obr. 1.1: Headset Emotiv EPOC+ 

Obr. 1.2: USB bezdrátový přijímač Obr. 1.3: Balení 16 vyměnitelných senzorů 

Obr. 1.4: Solný roztok Obr. 1.5: Kabel s mini USB konektorem 
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Obr. 1.6: Nabíjení headsetu pomocí mini USB kabelu Obr. 1.7: Hydratace senzorů solným roztokem 

Pro úspěšné provozování headsetu Emotiv EPOC+ je nutné provádět dva kroky údržby – nabíjení a hydratace senzorů. 

1.1 NABÍJENÍ HEADSETU 
Nabíjení headsetu se provádí pomocí kabelu s mini USB konektorem (obr. 1.6). Doba plného nabití baterie jsou přibližně 4 hodiny. Při nabíjení se v zadní části headsetu rozsvítí 
červená LED dioda. Pokud je zařízení plně nabito, změní se barva diody na zelenou. Nabíjení musí být prováděno pouze pokud je headset vypnut. 

1.2 HYDRATACE HEADSETU 
Senzory, které se připevňují na headset, musí být při měření dat navlhčené z důvodu zlepšeného přenosu signálu. K průběžné hydrataci senzorů slouží hydratační balení 
s polštářkem, který se musí napustit solným roztokem (obr. 1.7). Kvůli dlouhodobé hydrataci senzorů je možné, že na nich vznikne ušlechtilá rez zelené barvy jako produkt 
solného roztoku a polymeru na senzoru. Taková rez je naprosto přirozená a neměla by ovlivnit kvalitu měření. Odstranění rzi je možné pomocí vatových tamponů napuštěných 
isopropylalkoholem. Není přípustné oddělávat rez ostrými předměty, které mohou kromě rzi odstranit i vrstvu vodivého kovu, čímž by mohlo dojít k porušení funkčnosti senzoru.  
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2  MĚŘENÍ DAT 
V následující kapitole jsou popsány úkony, které jsou důležité pro samotné měření dat. 

2.1 INFORMOVANÝ SOUHLAS 
Před samotným experimentem, ve kterém bude účastníkům měřeno EEG, je nutné požádat účastníka 
o podepsání formuláře informovaného souhlasu. Tento formulář je nutné dát k podepsání před každým EEG 
experimentem. Získání podepsaného formuláře je nutné vzhledem ke skutečnosti, že EEG data se považují za 
osobní a citlivá data. Ve formuláři by se měly objevit informace o průběhu experimentu, o zacházení s daty 
v souladu se zákonem o ochraně osobních údajů a o tom, že se nejedná o diagnostické vyšetření a nelze tedy zjistit případné 
mozkové poruchy, které by tam mohly být. Vzor informovaného souhlasu je připojen k diplomové práci jako Příloha 1. 

2.2 NASAZENÍ SENZORŮ 
Před nasazením senzorů na headset je nutné zkontrolovat zda jsou z hydratačního balení dostatečně vlhké. Pokud nejsou, je třeba na 
ně přidat 2–3 kapky solného roztoku, což zapříčiní jejich plné nasáknutí. Poté je již možné senzory nasadit na headset. Nasazení 
probíhá formou přiložení senzoru k „pacičce“ headsetu a pootočení senzoru do pevné polohy (obr. 2.1). Po dokončení měření je 
nutné senzory z headsetu sejmout a uložit zpět do hydratačního balení. 

2.3 SPÁROVÁNÍ HEADSETU S POČÍTAČEM 
Dalším nutným krokem je spárování headsetu s počítačem. To probíhá bezdrátově pomocí Bluetooth® Smart technologie. Headset 
obsahuje zabudovaný bluetooth vysílač, na straně počítače je pak příjem zajištěn pomocí USB bezdrátového přijímače. Spárování je 
provedeno zasunutím USB bezdrátového přijímače do zdířky počítače 
a zapnutím headsetu. Informace, zda spárování proběhlo úspěšně či 
neúspěšně, je viditelná v horní části startovacího okna softwaru EPOC 
Control Panel™ (obr. 2.2). 

Software použitý v kapitole:  

 EPOC Control Panel™ 
 SMI Experiment Center™ Software 
 SMI BeGaze™ Eye Tracking Analysis Software 

Obr. 2.2: Informace o kvalitě spárovaného signálu v prostředí softwaru EPOC Control panel™ 

Obr. 2.1: Nasazení senzoru 
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2.4 INSTALACE ZAŘÍZENÍ NA HLAVU 
Po propojení headsetu s počítačem je možné jej instalovat na účastníkovu hlavu. Správné umístění headsetu na hlavu je klíčové. Každý senzor má své kódové označení, které 
reprezentuje konkrétní umístění na lebce. Operátor by měl headset nasadit účastníkovi na hlavu takovým způsobem, kdy pomocí obou rukou pomalým pohybem shora dolů tlačí 
na headset, který se účastníkovi sesune do správné pozice (obr. 2.3). Kontrolními body pro správné usazení senzorů jsou skalní kosti, na kterých by měly ležet senzory 
s gumovými polštářky (obr. 2.4). Dva přední senzory (F3, F4) by měly ležet ve vzdálenosti tří prstů od nadočnicového oblouku účastníka (obr. 2.5). 

 

 

 

 

 

 

 

2.5 AKTIVACE SENZORŮ 

Po nasazení je třeba aktivovat senzory, které již byly napuštěny solným roztokem. Aktivace se provádí lehkým stiskem referenčních elektrod (pozice P3 a P4) a jejich 
přidržením po dobu 10 až 20 vteřin (obr. 2.6). Během té doby by se měla v softwaru Epoc Control Panel™ zobrazit aktivita a kvalita signálu na jednotlivých senzorech. Úroveň 
kvality signálu je znázorněna pěti barvami (obr. 2.7) – černá (žádný signál), červená (velmi slabý signál), oranžová (slabý signál), žlutá (dostatečný signál), zelená (ideální signál) 
– přičemž kvalita signálu na senzoru by měla pro úspěšné měření dosahovat nejhůře žluté barvy. Ve většině případů se nepovede aktivace senzorů na první pokus. V takovém 
případě je řešením sejmout headset z hlavy, znovu hydratovat senzory a provést opětovnou instalaci headsetu na hlavu. 

Obr. 2.3: Nasazení headsetu na hlavu Obr. 2.4: Umístění senzorů s gumovými polštářky 
na skalní kosti 

Obr. 2.5: Umístění předních senzorů 



 8 

 

 

2.6 EXPERIMENT 
Spuštění samotného experimentu probíhá v softwaru SMI Experiment Center™ Software. Pro export dat slouží software SMI BeGaze™ Eye Tracking Analysis Software. Vzhledem 
k potřebám dalších kroků zpracování dat je nutné nastavit výstupní formát dat jako .TXT. Další exportní možnosti jako .EDF+ jsou také možné, ale pro zpracování obtížnější. 

  

Obr. 2.6: Referenční senzory, kterými se 
aktivuje přenos na ostatních senzorech Obr. 2.7: Zobrazení kvality signálu na senzorech v prostředí Epoc Control Panel™ 
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3  PŘEDZPRACOVÁNÍ DAT 
Následujícím krokem po naměření dat je předzpracování dat. Hlavním smyslem předzpracování dat je jejich 
úprava do takové podoby, aby na nich mohla být provedena následná analýza. Celý proces předzpracování dat 
probíhá v softwaru EEGLAB1, což je toolbox pro Matlab s GUI (obr. 3.1) sloužící pro zpracování a vizualizaci EEG 
dat. 

3.1 IMPORT DAT 
Pro import dat do toolboxu EEGLAB je důležité mít upravený .TXT soubor, který byl získán po naměření dat. Důležité 
je data rozdělit do více textových souborů pro každého účastníka a každý stimul. Textové soubory musí mít takovou 
strukturu, kdy v nich je pouze 14 sloupců reprezentující hodnoty z každého senzoru headsetu. Je nepřípustné, aby 
byly v souboru názvy sloupců či sloupec s údaji o čase. Po upravení souborů do takové podoby je možné je nahrát do 
prostředí toolboxu EEGLAB pomocí nástroje From ASCII/float file or Matlab array: 

 File > Import Data > Using EEGLAB functions and plugins > From ASCII/float file or Matlab array. 

Po zvolení této funkce se objeví 
okno, kde je nutné vybrat soubor, 
který má být nahrán (Data 
file/array), nastavit jméno 
souboru pro prostředí toolboxu 
(Dataset name) a nastavit 
hodnotu záznamové frekvence 
v níž byla data naměřena (Data 
sampling rate (Hz)) (obr. 3.2). 

                                                           
1
 https://sccn.ucsd.edu/eeglab/ 

Software použitý v kapitole:  

 EEGLAB toolbox for Matlab 
 

Obr. 3.1: Startovací okno toolboxu EEGLAB 

Obr. 3.2: Nastavení parametrů při nahrávání .TXT souboru do toolboxu EEGLAB 
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Obr. 3.3: První okno, které se zobrazí po zvolení nástroje Channel locations 

Hodnota sampling rate je odvozeno od záznamové frekvence zařízení Emotiv EPOC+. Pokud je při experimentu zařízení propojeno i s eye-trackerem, přebírá frekvenci eye-
trackeru. 

3.2 NAHRÁNÍ SOUBORU .CED 
Dalším krokem je lokalizace jednotlivých senzorů na lebce. Pro tuto lokalizaci je nutné mít soubor s údajemi o pozici každého senzoru na lebce. Jedná se o soubor formátu .CED, 
který lze otevřít a upravovat v libovolném textovém editoru. Struktura souboru včetně vyplněných hodnot o poloze senzorů je zobrazena na str. 11 a také je dostupná 
v elektronické formě jako součást DVD Přílohy 6 diplomové práce. Tento soubor lze nahrát pomocí nástroje Channel locations: 

 Edit > Channel locations. 

Po kliknutí na nástroj se objeví okno s dotazem, zda chceme vyhledat lokaci kanalů. Zde je důležité zvolit možnost Cancel  (obr. 3.3). Poté se otevře nové okno, kde je možné 
editovat lokaci jednotlivých kanálů. V tomto okně se zvolí načtení lokací (Read locations) a zvolí se cesta k souboru .CED (obr. 3.4). Po potvrzení cesty a zanechání možnosti 
automatické detekce (autodetect) se načtou lokace jednotlivých senzorů. 

  

Obr. 3.4: Nahrání souboru .CED 
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Number labels theta  radius X  Y    Z  sph_theta sph_phi sph_radius  type 

1  AF3  -23  0.411    0.885  0.376   0.276 23   16  1   1 

2  F7  -54  0.511    0.587  0.809  -0.0349 54   -2  1   2 

3  F3  -39  0.333    0.673  0.545   0.5  39   30    1   3 

4  FC5  -69  0.394    0.339  0.883   0.326 69   19    1   4 

5  T7  -90  0.511  6.12e-17 0.999  -0.0349 90   -2    1   5 

6  P7  -126  0.511   -0.587  0.809  -0.0349 126  -2  1   6 

7  O1  -162  0.511    -0.95  0.309  -0.0349 162   -2    1   7 

8  O2  162  0.511    -0.95 -0.309  -0.0349 -162   -2    1   8 

9  P8  126  0.511   -0.587 -0.809  -0.0349 -126   -2    1   9 

10  T8  90  0.511  6.12e-17 0.999  -0.0349 -90   -2    1   10 

11  FC6  69  0.394    0.339 -0.883   0.326 -69   19    1   11 

12  F4   39  0.333    0.673 -0.545   0.5  -39  30    1   12 

13  F8   54  0.511    0.587 -0.809  -0.0349 -54   -2    1   13 

14  AF4   23  0.411    0.885 -0.376   0.276 -23   16    1   14   
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3.3 ODSTRANĚNÍ ARTEFAKTŮ 
Odstranění artefaktů by mělo být nedílnou součástí předzpracování. Pro odstranění artefaktů lze 
použít vícero metod, avšak žádná kombinace nepovede k absolutnímu odstranění artefaktů. Přílišné 
odstranění artefaktů naopak není žádoucí, neboť i data ovlivněná artefaktem mohou nést užitečnou 
informaci. Jako jedna z variant pro odstranění artefaktů se jeví nástroj Reject continuous data by eye: 

 Tools > Reject continuous data by eye.  

Po zapnutí nástroje se objeví okno s časovým záznamem průběhu EEG dat. Pomocí tahu myší lze 
označit úsek dat, který je zarušen artefakty a odstranit ho pomocí tlačítka Reject (obr. 3.5). Taková 
metoda, při které se označí a smaže časový úsek dat pouze na základě vizuálního vjemu, vyžaduje 
hlubokou a několikaletou znalost v oblasti elektroencefalografie. Další nevýhodou tohoto nástroje je 
jeho časová náročnost, kdy by se musel u každého textového souboru prohlížet záznam dat a hodnotit, 
zda se vyskytují artefakty či nikoliv.  

3.4 ANALÝZA NEZÁVISLÝCH KOMPONENT 
Způsobem, jak odstranit část artefaktů, je použití nástroje Run ICA: 

 Tools > Run ICA.  

V oblasti zpracování signálů může velice často nastat problém, kdy naměřené signály jsou 
ovlivněny nějakým faktorem a neodpovídají tedy signálům původním. Jako tento faktor může 
vystupovat např. nízká selektivita senzoru, která způsobí, že výstup ze senzoru je ve skutečnosti 
kombinací více signálů. Analýza nezávislých komponent je metoda separace signálů, která 
odděluje smíchané nezávislé signály. Při spuštění nástroje Run ICA se nastavuje algoritmus, 
kterým analýza proběhne (obr. 3.6). Stačí ponechat přednastavený algoritmus s názvem runica.  

Obr. 3.5: Vizuální odstranění dat nástrojem Reject continuous data by eye 

Obr. 3.6: Nastavení algoritmu pro spuštění nástroje Run ICA 



 13 

 Po spuštění nástroje Run ICA vznikne takový počet nezávislých signálů, kolik je senzorů. Původ signálů lze 
vizualizovat pomocí nástroje Reject components by map: 

 Tools > Reject data using ICA > Reject components by map 

Vizualizována je lokace původu  jednotlivých nezávislých komponent, přičemž červená barva značí ohnisko 
původu (obr. 3.7). V obecné rovině platí, pokud je poloha ohniska blízko nosu, jedná se o artefakt vzniklý 
mrkáním. Takovou komponentu je tedy vhodné odstranit. Nicméně i v tomto případě platí, že rozpoznání typů 
a původu nezávislých komponent vyžaduje expertní znalost problematiky. 

3.5 ODSTRANĚNÍ KOLÍSÁNÍ NULOVÉ IZOLINIE 

Následným krokem po analýze nezávislých komponent je odstranění kolísání nulové izolinie neboli driftu. Jedná 
se o jev, při kterém se dlouhodobě posouvá úroveň nulové hladiny, což má za následek zkreslení. Tento 
problém lze odstranit pomocí nástroje Remove baseline: 

 Tools > Remove baseline, 

který odečte od signálu jeho průměrnou hodnotu. 

3.6 FILTRACE DO VLNOVÝCH PÁSEM 
Rozdílná vlnová pásma nesou různou charakteristiku dat. Z toho důvodu byla dalším krokem 
filtrace dat dle vlnových pásem δ, θ, α, β a γ. Hraniční hodnoty jednotlivých pásem se liší u různých 
autorů a publikací, např. Moráň (1995)2 používá intervaly: 

0,5–4 Hz = δ, 5–8 Hz = θ, 9–13 Hz = α, 14–30 Hz = β, 31–50 Hz = γ.  

 

                                                           
2
 MORÁŇ, Miroslav. Praktická elektroencefalografie. Brno: Institut pro další vzdělávání pracovníků ve zdravotnictví, 1995. ISBN 80-7013-203-5. 

Obr. 3.7: Mapy původu jednotlivých nezávislých komponent 

Obr. 3.8: Nastavení hraničních hodnot intervalu při použití nástroje Basic FIR 
filter 
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 Pro filtraci dat je v toolboxu EEGlab nástroj Basic FIR filter: 

 Tools > Filter the data > Basic FIR filter.  

V něm se zadávají dolní a horní hranice vlnových pásem (obr. 3.8). Filtraci je nutné na datasetu provést pětkrát, pro každé vlnové pásmo zvlášť, čímž vznikne pět nových 
datasetů. 

3.7 EXPORT DAT  
Výsledných pět datasetů je potřebné z toolboxu EEGlab vyexportovat opět ve formátu .TXT. Pro export slouží nástroj Data and ICA activity to text file: 

 File > Export > Data and ICA activity to text file.  

Vzhledem k požadavkům na strukturu souboru, vzhledem k dalšímu kroku práce, bylo nutné při exportu nastavit transponování struktury výsledného souboru, neboť nativně 
toolbox EEGLAB exportuje data do řádků, nikoliv sloupců. Stejně tak je nutné změnit export časových značek a popisu sloupců ve výsledném souboru (obr. 3.10). 

  Obr. 3.9: Nastavení exportu .TXT souboru 
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3.8 SKRIPT 
Výstupem z předzpracování dat je pět textových souborů pro každého uživatele a každý stimul. Vzhledem k očekávanému vysokému objemu dat je nutné proces předzpracování 
automatizovat. Výhodou automatizace je značná úspora času, nevýhodou pak je nemožnost manuální korekce dat u nástrojů Reject continuous data by eye a Reject components 
by map. Vzhledem k nízké erudici v oblasti elektroencefalografie je od manuálních úkonů upuštěno ve prospěch automatizace. Byl vytvořen skript, který je spustitelný 
v příkazovém řádku softwaru Matlab. 

[ALLEEG EEG CURRENTSET ALLCOM] = eeglab; 
EEG = pop_importdata('dataformat','ascii','nbchan',0,'data','absolutní cesta vstupního souboru','setname','eeg','srate',250,'pnts',0,'xmin',0);     

% nahrání .TXT souboru 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 0,'gui','off');  
EEG = eeg_checkset( EEG ); 
EEG = pop_runica(EEG, 'extended',1,'interupt','on');    % spuštění analýzy nezávislých komponent 
[ALLEEG EEG] = eeg_store(ALLEEG, EEG, CURRENTSET); 
EEG = eeg_checkset( EEG ); 
EEG = pop_rmbase( EEG, [0  3484]);      % odstranění kolísání nulové izolinie 
[ALLEEG EEG] = eeg_store(ALLEEG, EEG, CURRENTSET); 
EEG = pop_eegfiltnew(EEG, 0.5, 4, 1650, 0, [], 1);      %filtrace 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 1,'setname','delta','gui','off');  
EEG = pop_eegfiltnew(EEG, 5, 8, 414, 0, [], 1); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 2,'setname','theta','gui','off');  
EEG = pop_eegfiltnew(EEG, 9, 13, 368, 0, [], 1); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 3,'setname','alfa','gui','off');  
EEG = pop_eegfiltnew(EEG, 14, 30, 236, 0, [], 1); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 4,'setname','beta','gui','off');  
EEG = pop_eegfiltnew(EEG, 31, 50, 108, 0, [], 1); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 5,'setname','gamma','gui','off');  
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 6,'retrieve',2,'study',0);  
EEG = eeg_checkset( EEG ); 
pop_export(EEG,'absolutní cesta pro export souboru','transpose','on','elec','off','precision',4); % export souborů 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 2,'retrieve',3,'study',0);  
EEG = eeg_checkset( EEG ); 
pop_export(EEG,'absolutní cesta pro export souboru','transpose','on','elec','off','precision',4); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 3,'retrieve',4,'study',0);  
EEG = eeg_checkset( EEG ); 
pop_export(EEG,'absolutní cesta pro export souboru','transpose','on','elec','off','precision',4); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 4,'retrieve',5,'study',0);  
EEG = eeg_checkset( EEG ); 
pop_export(EEG,'absolutní cesta pro export souboru','transpose','on','elec','off','precision',4); 
[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG, EEG, 5,'retrieve',6,'study',0);  
EEG = eeg_checkset( EEG ); 
pop_export(EEG,'absolutní cesta pro export souboru','transpose','on','elec','off','precision',4); 
eeglab redraw; 
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4  EXTRAKCE CHARAKTERISTICKÝCH RYSŮ 
Krokem následujícím po předzpracování dat se stala analýza dat. Hlavním cílem analýzy dat bylo extrahovat 
charakteristické rysy signálů. Takovým charakteristickým rysem signálu je tzv. výkonové spektrum signálu 
(power spectral density, zkr. PSD. Postupné kroky v této kapitole směřují k výpočtu PSD. Veškeré výpočty fáze 
analýzy dat byly výlučně prováděny v softwaru Matlab.  

4.1 IMPORT DAT 
Data do prostřdí softwaru Matlab je nutné nejdříve nahrát. K tomu slouží nástroj 
Import Data, který se nachází v horní části v pásu karet (obr. 4.1). Po výběru 
cesty k textovému souboru, který má být nahrán, se otevře nové okno, kde je 
důležité vybrat formát, v jakém budou data reprezentována v prostředí Matlab. 
Tímto formátem by měla být matice (obr. 4.2). Po úspěšném nahrání se data 
zobrazí v okně Workspace. 

 

 

 

  

Software použitý v kapitole:  

 Matlab 
 

Obr. 4.2: Nástroj Import Data na pásu karet v softwaru Matlab 

Obr. 4.1: Nastavení importu dat 
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4.2 FOURIEROVA TRANSFORMACE 
Prvním krokem po nahrání dat do prostředí Matlab je rychlá Fourierova transformace (FFT). Fourierova transformace je základním nástrojem pro zpracování signálů. Smyslem 
Fourierovy transformace je převod signálu z časové domény na frekvenční doménu. Rychlá varianta transformace se nazývá rychlá Fourierova transformace. V softwaru Matlab 
odpovídá rychlé Fourierově transformaci funkce fft.  

Pro provedení rychlé Fourierovy transformace stačí napsat do příkazového okna (Command Window) softwaru Matlab  příkaz v podobě: 

 Y=fft(název importovaných dat) 

Potvrzením příkazu pomocí klávesy enter se na datech vypočítá Fourierova transformace a uloží se do okna Workspace jako proměnná s názvem Y. 

 

4.3 VÝKONNOVÉ SPEKTRUM SIGNÁLU 
Po výpočtu rychlé Fourierově transformaci, je možné na datech vypočítat výkonové spektrum signálu. Výkonové spektrum odpovídá na otázku, které frekvence daného signálu 
obsahují výkon signálu. Jinými slovy, výkonové spektrum je funkce, která nám říká, jaká část výkonu je nesena jakými frekvenčními složkami. Výkonové spektrum se udává ve 
wattech na hertz. Matematicky je výkonové spektrum vyjádřeno jako druhá mocnina hodnoty frekvence ve frekvenční doméně.  

Vzhledem ke skutečnosti, že frekvenční doména byla získána pomocí Fourierovy transformace, výkonnové spektrum bude získáno pokud proměnná Y bude umocněna: 

 PS=abs(Y).^2 

Potvrzením příkazu pomocí klávesy enter se na proměnné Y vypočítá výkonnové spektrum a uloží se do okna Workspace jako proměnná s názvem PS. 

4.4 PRŮMĚRNÁ HODNOTA VÝKONOVÉHO SPEKTRA 
Doposud probíhaly výpočty takovým způsobem, že každý EEG signál vystupující z předzpracování, je v prostředí Matlab reprezentován maticí. Vzhledem k závěrečnému kroku 
celého postupu prací, jímž je klasifikace dat, je nutné každý EEG signál převést na jedno číslo, neboť použitý klasifikátor nemá možnost použít celou matici jako charakteristiku 
daného signálu. Z toho důvodu musí být z výkonového spektra vypočítána jeho průměrná hodnota. Tato hodnota pak bude reprezentovat hlavní charakteristiku signálu při 
závěrečné klasifikaci dat. 
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Pro výpočet průměrné hodnoty slouží v softwaru Matlab funkce mean. Do příkazového okna se vloží příkaz v podobě: 

 M=mean(PS) 

Potvrzením příkazu pomocí klávesy enter se na proměnné PS vypočítá průměrná hodnota výkonnového spektra a uloží se do okna Workspace jako proměnná s názvem M. 

4.5 EXPORT DAT 
Výsledná data s hodnotami průměrného výkonového spektra pro každý senzor je nutné vyexportovat. Pro export se vzhledem k potřebám další práce jako nejvhodnější jeví 
soubor .MAT. Pro export dat je vhodné použít funkci save. Příkaz pro uložení souboru má podobu: 

 save relativní cesta pro export souboru.mat M 

4.6 SKRIPT 

Výše sepsané kroky je nutné opakovat pro každého účastníka a každý stimul experimentu. Vzhledem k velmi vysokému počtu vstupních souborů (pro každý stimul a účastníka 
pět souborů s EEG daty rozdělených do vlnových pásem δ, θ, α, β, γ) a nutnosti opakovat proces pro každý soubor zvlášť, je vhodné proces extrakce charakteristických rysů opět 
převést do podoby skriptu za účelem automatizace procesu. 
 
x=load('relativní cesta importovaného souboru') 
y=fft(x) 
PS=abs(y).^2 
M=mean(PS) 
save relativní cesta exportovaného souboru.mat M 
clear 
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5  KLASIFIKACE DAT 
Závěrečným krokem celého zpracování dat je klasifikace dat. Smyslem klasifikace je roztřídění 
charakteristických rysů EEG dat do klasifikačních tříd. Klasifikace probíhá v aplikaci Classification Learner, což 
je aplikace implementovaná v softwaru Matlab. 

5.1 PŘÍPRAVA DAT 
Před samotnou klasifikací a trénováním je nutné si data připravit do odpovídající podoby. Vzhledem k potřebám 
aplikace Classification Learner je potřeba mít veškerá data, která jsou určená k trénování, v jedné matici. Data pocházející od jednoho účastníka a jednoho stimulu, rozdělená do 
pěti souborů  δ, θ, α, β a γ, je nyní nutné spojit horizontálně spojit. K tomu slouží funkce horzcat. Po spojení vznikne matice o jednom řádku a 70 sloupcích, neboť sloupce 
představují 14 EEG senzorů v každém vlnovém pásmu (14 × 5 = 70). Po provedení horizontálního spojení u každého stimulu, je nutné tyto stimuly spojit do matice navzájem a to 
vertikálně. K tomu slouží funkce vertcat. Po propojení veškerých stimulů, které vstupují do trénování dat je nutné k matici připojit ještě jeden sloupec, ve kterém jsou 
numerickými hodnotami vyjádřeny klasifikační třídy. Výsledná matice tedy obsahuje tolik řádků, kolik je stimulů vstupujících do trénování dat a 71 sloupců. 

5.2 TRÉNOVÁNÍ DAT 
Pro trénování a klasifikaci dat slouží aplikace Classification Learner. Tu je možné nalézt na pásu karet v záložce Apps (obr. 5.1). 

 Následným krokem po otevření aplikace je zvolení nové relace (New Session). Otevře se okno rozdělené do tří částí (obr. 5.2). V první části se vybírá připravená matice. V druhé 
části ve sloupci Import As se nastavují funkce jednotlivých sloupců při trénování dat. Možnost Do Not Import znamená, že data z daného sloupce nebudou do trénování zahrnuta. 
Možnost Predictor představuje skutečnost, že daný sloupec bude figurovat v procesu trénování jako atribut a možnost Response znamená, že daný sloupec představuje 
klasifikační třídy, do kterých bude výsledný klasifikační model klasifikovat další data. Možnost Response se musí nastavit právě jednou a to pouze pro sloupec obsahující celá 

Obr. 5.1: Umístění aplikace Classification Learner na pásu karet 

Software použitý v kapitole:  

 Aplikace Classification Learner v prostředí 
Matlab 

 Matlab 
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čísla. V třetí části okna se nastavuje křížová validace, která slouží jako ochrana pro přetrénování dat. Je možné ji nastavit v rozmezí od dvojnásobné po padesátinásobnou. Po 
kliknutí na tlačítko Start Session se otevře nové okno, s možnostmi nastavení typu klasifikátoru a samotné spuštění trénování dat (obr. 5.3). Je zde také možnost spustit ještě 
analýzu hlavních komponent (PCA) a snížit tak dimenzionalitu dat. Z nabízených klasifikátorů jsou zde na výběr rozhodovací stromy, diskriminační analýzy, Support vector 
machines, metoda K-nejbližšího souseda a vícemodelové klasifikátory.  

  

Obr. 5.3: Výběr klasifikátoru a spuštění procesu trénování 

Obr. 5.2: Nastavení procesu trénování 
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5.3 EXPORT KLASIFIKAČNÍHO MODELU 
Po dokončení procesu trénování se v okně History zobrazí všechny natrénované klasifikátory společně s jejich přesností klasifikace (obr. 5.4). Vybraný natrénovaný klasifikátor 
pak lze vyexportovat do podoby klasifikačního modelu, který lze poté uplatnit na další data (obr. 5.5). Po vyexportování modelu může být aplikace Classification Learner zavřena. 

  

Obr. 5.4: Seznam natrénovaných 
klasifikátorů 

Obr. 5.5: Export vybraného natrénovaného klasifikátoru 
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5.4 POUŽITÍ KLASIFIKAČNÍHO MODELU 
Vyexportovaný model lze použít v prostředí softwaru Matlab pro klasifikaci dalších dat. Nová data, která mají být klasifikovaná, musí mít stejnou strukturu jako data, na kterých 
model vzniknul, vyjma posledního sloupce s klasifikačními třídami. Pro použití klasifikačního modelu na nových datech slouží v softwaru Matlab funkce predictFcn. Použitý 
příkaz pak vypadá takto: 

 Yfit = C.predictFcn(X) , 

kde C je název klasifikačního modelu a X je název matice, na které probíhá klasifikace. 

 

 

 

 

 

ZÁVĚR 
Výsledkem zpracování EEG signálu je klasifikační model, který může dosahovat i nízkých hodnot v přesnosti. Důvodů, proč se dospěje k tak málo příznivému výsledku, může být 
několik. Prvním z nich může být chyba měření. To se může stát kvůli chybnému usazení headsetu na hlavu. Ten není vůči nepřesnému usazení na hlavu nijak uzpůsoben. Ano, celý 
headset má pevně danou pozici senzorů vůči sobě navzájem, nicméně při nesprávné manipulaci s ním, může být umístěn na hlavu pod různými úhly. K úspěšnému přenosu 
signálu i přes chybné umístění dojde. Stačí, aby byly senzory headsetu řádně hydratovány. Další problém, který může ovlivnit měření dat, je postupné vysychání senzorů, s čímž 
bylo spojeno postupné snižování kvality přenosu signálu. Jiného výsledku může být dosaženo při různém nastavení trénování dat a použití odlišného klasifikátoru. Potenciálních 
kombinací řešících, jak objemný použít soubor trénovacích dat, kolikanásobnou křížovou validaci nastavit a jaký nejvhodnější klasifikátor použít, je velké množství. Počet 
klasifikačních tříd vstupujících do klasifiakce také ovlivní výslednou přesnost klasifikačního modelu. Čím více bude klasifikačních tříd, tím bude přesnost klasifikačního modelu 
klesat. 


